Bug 257362 - KMail freezes randomly when Composing mail
Summary: KMail freezes randomly when Composing mail
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.13.5
Platform: openSUSE Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 247624 265413 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-19 22:48 UTC by Graham Lauder
Modified: 2011-05-01 00:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: kdepim 4.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Lauder 2010-11-19 22:48:18 UTC
Version:           1.13.5 (using KDE 4.4.4) 
OS:                Linux

Kmail freezes, seemingly randomly for about a minute or so at a time.  Auto save turned off, no difference.  This happens while composing emails.    

Reproducible: Didn't try




OS: Linux (x86_64) release 2.6.34-12-desktop
Compiler: gcc
Comment 1 Graham Lauder 2010-11-21 03:34:29 UTC
It is now doing this with increasing frequency, every 5 minutes or so.  This has only started happening since my last update, is there any way I can roll back to an earlier version
Comment 2 Graham Lauder 2010-11-21 20:04:06 UTC
I tried reverting to an earlier version of Kontact, but problem continued. 

Turned off KDM and switched to GDM and then ran under Gnome.  The freezing stops.
Comment 3 Christophe Marin 2011-02-15 18:17:00 UTC
*** Bug 265413 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Marin 2011-02-15 18:17:15 UTC
*** Bug 247624 has been marked as a duplicate of this bug. ***
Comment 5 Jörg Walter 2011-04-11 21:42:24 UTC
I get the same behaviour. Kubuntu Maverick with KDE 4.6.1 packages.

As noted in #247624, "akonadictl restart" works. Somewhere in related bugs I have read that suspend might have something to do with this -- I use suspend extensively.
Comment 6 Ivan D Vasin 2011-04-11 21:59:39 UTC
as Jörg Walter pointed out, this looks similar to bug #248026.
Comment 7 Christophe Marin 2011-05-01 00:20:06 UTC
Cannot reproduce with KMail2. Open a new report for the kmail2 product if you can reproduce this issue with kdepim > 4.6beta5