Bug 256901 - WISH : using tools twice in batch queue manager
Summary: WISH : using tools twice in batch queue manager
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: BatchQueueManager-Workflow (show other bugs)
Version: 1.5.0
Platform: Archlinux Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-14 18:38 UTC by nvlplx
Modified: 2016-07-04 05:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nvlplx 2010-11-14 18:38:03 UTC
Version:           1.5.0 (using KDE 4.5.3) 
OS:                Linux

When you create a new queue, it's not possible to apply twice a tool with different settings. 

In my process, I use the unsharp mask with a big radius in order to emphasize details and optimize the local contrast, then the sharpen tool to control the visual sharpen of the picture. 
In a other way, I very often apply the "adjust curve" tool several times on a picture to control separately whole luminance and luminance repartition in specific "part" with equivalent luminosity in the picture. 

Unfortunately, I cannot reproduce my different processes with the batch queue manager because it doesn't accept twice the same tool. 

You can make several queue but it imposes you to save one or two intermediate pictures before obtain desired result. 

Reproducible: Always



Expected Results:  
It could be very usefull to use twice the tools in the batch queue manager, especially the sharpening tools and the "adjust curve" one.
Comment 1 caulier.gilles 2010-11-14 20:23:25 UTC
Thanks for the feedback. I don't know why it cannot be possible to apply tools twice. I will take a look

Gilles Caulier
Comment 2 nvlplx 2010-11-14 21:00:03 UTC
Thank you very much. I'll really appreciate you find the solution. 


PLX

--- En date de : Dim 14.11.10, Gilles Caulier <caulier.gilles@gmail.com> a écrit :

> De: Gilles Caulier <caulier.gilles@gmail.com>
> Objet: [Bug 256901] WISH : using tools twice in batch queue manager
> À: nvlplx@yahoo.fr
> Date: Dimanche 14 novembre 2010, 20h23
> https://bugs.kde.org/show_bug.cgi?id=256901
> 
> 
> Gilles Caulier <caulier.gilles@gmail.com>
> changed:
> 
>            What 
>   |Removed           
>          |Added
> ----------------------------------------------------------------------------
>              
>    CC|         
>                
>   |caulier.gilles@gmail.com
> 
> 
> 
> 
> --- Comment #1 from Gilles Caulier <caulier gilles gmail
> com>  2010-11-14 20:23:25 ---
> Thanks for the feedback. I don't know why it cannot be
> possible to apply tools
> twice. I will take a look
> 
> Gilles Caulier
> 
> -- 
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 3 caulier.gilles 2011-08-31 11:41:46 UTC
*** Bug 272784 has been marked as a duplicate of this bug. ***
Comment 4 caulier.gilles 2012-12-13 13:17:52 UTC
Git commit aa1f2d0d9c1cbd1802678b21617a837131dbc1d7 by Gilles Caulier.
Committed on 13/12/2012 at 14:16.
Pushed by cgilles into branch 'master'.

Batch Queue Manager : add the capability to assign more than one time the same tool to a queu to process

M  +2    -32   utilities/queuemanager/views/assignedlist.cpp

http://commits.kde.org/digikam/aa1f2d0d9c1cbd1802678b21617a837131dbc1d7