Bug 255719 - Plasma desktop crashing on login
Summary: Plasma desktop crashing on login
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 08:44 UTC by Stratos Zolotas
Modified: 2010-10-31 15:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stratos Zolotas 2010-10-31 08:44:49 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2) "release 10"
Qt Version: 4.7.0
Operating System: Linux 2.6.36-90-default x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Plasma craches on login. I think this happened after some xorg packages updates.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa04d319760 (LWP 4479))]

Thread 2 (Thread 0x7fa024a35710 (LWP 4635)):
#0  0x00007fa04bcc2709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fa04bf4cf12 in wait (this=<value optimized out>, mutex=0x19343f0, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x19343f0, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa04bf42d28 in QThreadPoolThread::run (this=0x190ea90) at concurrent/qthreadpool.cpp:140
#4  0x00007fa04bf4c8be in QThreadPrivate::start (arg=0x190ea90) at thread/qthread_unix.cpp:266
#5  0x00007fa04bcbda4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007fa04aa7d82d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa04d319760 (LWP 4479)):
[KCrash Handler]
#6  0x00007fa04c4ab674 in SharedMemory::removeEntry (this=0x7fa03252f000, index=4837) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1160
#7  0x00007fa04c54150f in KSharedDataCache::insert (this=<value optimized out>, key=..., data=...) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1269
#8  0x00007fa04ccd614d in KImageCache::insertImage (this=0x794d60, key=..., image=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:86
#9  0x00007fa04cdea906 in KImageCache::insertPixmap (this=0x794d60, key=..., pixmap=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:105
#10 0x00007fa043812ff5 in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x78a410) at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:275
#11 0x00007fa043815c82 in Plasma::Theme::qt_metacall (this=0x74fc40, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x7fff28de0ab0) at /usr/src/debug/kdelibs-4.5.2/build/plasma/theme.moc:119
#12 0x00007fa04c04cb5f in QMetaObject::activate (sender=0x798fb0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#13 0x00007fa04c04b509 in QObject::event (this=0x798fb0, e=<value optimized out>) at kernel/qobject.cpp:1175
#14 0x00007fa04b1ddf34 in QApplicationPrivate::notify_helper (this=0x67fb30, receiver=0x798fb0, e=0x7fff28de1250) at kernel/qapplication.cpp:4396
#15 0x00007fa04b1e635a in QApplication::notify (this=<value optimized out>, receiver=0x798fb0, e=0x7fff28de1250) at kernel/qapplication.cpp:4277
#16 0x00007fa04ccbd7b6 in KApplication::notify (this=0x674b50, receiver=0x798fb0, event=0x7fff28de1250) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#17 0x00007fa04c0379dc in QCoreApplication::notifyInternal (this=0x674b50, receiver=0x798fb0, event=0x7fff28de1250) at kernel/qcoreapplication.cpp:732
#18 0x00007fa04c065189 in sendEvent (this=0x683250) at kernel/qcoreapplication.h:215
#19 QTimerInfoList::activateTimers (this=0x683250) at kernel/qeventdispatcher_unix.cpp:617
#20 0x00007fa04c061f58 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#21 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#22 0x00007fa047b81a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fa047b82270 in ?? () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fa047b82510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007fa04c0625ff in QEventDispatcherGlib::processEvents (this=0x675580, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#26 0x00007fa04b281eee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fa04c036e12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007fa04c037025 in QEventLoop::exec (this=0x7fff28de1560, flags=...) at kernel/qeventloop.cpp:201
#29 0x00007fa04c03b43b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#30 0x00007fa03e09470b in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#31 0x00000000004074a9 in launch (argc=1, _name=0x66db28 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=
    0x0, avoid_loops=false, startup_id_str=0x40b117 "0") at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:723
#32 0x0000000000407fc5 in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1215
#33 0x000000000040873a in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1408
#34 0x0000000000409390 in main (argc=4, argv=0x7fff28de29c8, envp=0x7fff28de29f0) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1892

This bug may be a duplicate of or related to bug 253795.

Possible duplicates by query: bug 255717, bug 255709, bug 254625, bug 254176, bug 254111.

Reported using DrKonqi
Comment 1 Stratos Zolotas 2010-10-31 08:49:46 UTC
I think that has something to do with the change o clock. Today the clock has changed (winter time) and after that i rebooted the system in windows. Back on linux and the problem appeared. Setting the clock again manually solved the problem.
Comment 2 Christoph Feck 2010-10-31 15:28:04 UTC

*** This bug has been marked as a duplicate of bug 253795 ***