Bug 256065 - Solver falsely reports Gypsy game as unwinnable
Summary: Solver falsely reports Gypsy game as unwinnable
Status: RESOLVED DUPLICATE of bug 204581
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: 0.7.4
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 17:48 UTC by Unknown
Modified: 2011-01-08 23:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Game in winnable state (811.44 KB, image/jpeg)
2010-11-04 17:48 UTC, Unknown
Details
Save game (5.35 KB, application/octet-stream)
2010-11-06 11:58 UTC, Unknown
Details
Another saved game (4.68 KB, application/octet-stream)
2010-11-09 23:28 UTC, Unknown
Details
Another saved game (5.36 KB, application/octet-stream)
2010-11-11 05:30 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2010-11-04 17:48:42 UTC
Created attachment 53134 [details]
Game in winnable state

Version:           0.7.4
OS:                MS Windows

Playing gypsy game 26146, had a situation where making a reversible move resulted in the solver reporting the game as unwinnable.
Screenshots attached.

Reproducible: Didn't try




OS: WindowsNT (i686) release Windows 7
Compiler: cl.exe
Comment 1 Parker Coates 2010-11-04 22:20:47 UTC
Could you please attach a saved game in which the game is reported as unwinnable and the exact move required to return it to a winnable state?
Comment 2 Unknown 2010-11-06 11:58:56 UTC
Created attachment 53191 [details]
Save game

Move the 4 of hearts in column 5 to column 6.
Comment 3 Parker Coates 2010-11-08 14:33:32 UTC
Thanks for the save file.
Comment 4 Unknown 2010-11-09 23:28:39 UTC
Created attachment 53291 [details]
Another saved game

Another example of the same bug.
Saved in the 'not winnable' state.
Move the Queen of hearts from column 2 onto the King of clubs in column 8 to make it display as winnable.
Note that then moving the queen of diamonds from column 4 to column 2 also makes it display as unwinnable.
I have completed this game, so it should be saying that it is winnable.
Comment 5 Unknown 2010-11-09 23:34:02 UTC
Also reproduced the same bug in Xubuntu 10.10 64 bit, so it is not just a problem with the windows port.
Comment 6 Unknown 2010-11-11 05:30:41 UTC
Created attachment 53313 [details]
Another saved game

Another saved game file showing the same bug.
Move the 7 of spades from column 1 to column 7.
Comment 7 Parker Coates 2011-01-08 23:32:18 UTC

*** This bug has been marked as a duplicate of bug 204581 ***