Bug 204581 - Solver doesn't look up everything in gypsy
Summary: Solver doesn't look up everything in gypsy
Status: RESOLVED FIXED
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
: 256065 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-20 22:51 UTC by coyotte508
Modified: 2011-01-26 14:00 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Saved game that reproduces the bug when moving the three of diamonds. (5.45 KB, text/plain)
2009-08-20 22:53 UTC, coyotte508
Details

Note You need to log in before you can comment on or make changes to this bug.
Description coyotte508 2009-08-20 22:51:36 UTC
Version:           3.1 (using 4.2.2 (KDE 4.2.2), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.29-1-netbook

This bug is similar to https://bugs.kde.org/show_bug.cgi?id=204544 (bug 204544).

Solver is overoptimized and doesn't move a card to another pile if the destination and starting 'base cards' are the same, which induces different possibilities when dealing new cards.

I'm attaching a saved game where moving the three of diamonds from a four of spades to another gives two different results for the solver.

PS: I don't know if fixing bug 204544 also fixed that bug (as those are different games), so I'm posting it anyway.
Comment 1 coyotte508 2009-08-20 22:53:26 UTC
Created attachment 36313 [details]
Saved game that reproduces the bug when moving the three of diamonds.
Comment 2 Parker Coates 2011-01-08 23:32:18 UTC
*** Bug 256065 has been marked as a duplicate of this bug. ***
Comment 3 Stephan Kulow 2011-01-26 14:00:51 UTC
SVN commit 1217247 by coolo:

gypsy: don't ignore valid moves, but give them low prio
BUG: 204581


 M  +2 -1      gypsysolver.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217247