Bug 256058 - Settings dialogs of plasma applets are not translated
Summary: Settings dialogs of plasma applets are not translated
Status: RESOLVED DUPLICATE of bug 255971
Alias: None
Product: amarok
Classification: Applications
Component: Context View (show other bugs)
Version: 2.4-GIT
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 17:00 UTC by Johannes Obermayr
Modified: 2010-11-04 21:24 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Obermayr 2010-11-04 17:00:21 UTC
Version:           2.4-GIT (using Devel) 
OS:                Linux

The settings dialogs of plasma applets within amarok are not translated because the libplasma catalog is not loaded.

I do not know whether it has to be loaded manually by amarok or should be loaded automatically since other plasma applets on workspace do not show this problem and are translated.

See the problem here:
http://img183.imageshack.us/i/amarok.png/
http://img183.imageshack.us/i/amarok1.png/

As I mentioned on #kde-devel and in bug 254481 (in an abstract way) it is devs part asking i18n people (kde-i18n-doc@kde.org or #kde-i18n).

I can reproduce it on 3 systems.

Reproducible: Always
Comment 1 Panagiotis Papadopoulos 2010-11-04 18:20:04 UTC
I can confirm this on Arch Linux:

Qt: 4.7.0
KDE: 4.5.3
Amarok: 2.3.2
Comment 2 Kevin Funk 2010-11-04 21:24:52 UTC

*** This bug has been marked as a duplicate of bug 255971 ***