Bug 255632 - Plasma crash while clicking on system tray
Summary: Plasma crash while clicking on system tray
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 01:08 UTC by Jake
Modified: 2010-11-02 10:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jake 2010-10-30 01:08:57 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Clicking on the "fetching updates" icon in Plasma, no other windows open.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7753720 (LWP 1558))]

Thread 2 (Thread 0xae8b9b70 (LWP 1561)):
#0  0x00cc5e36 in clock_gettime () from /lib/librt.so.1
#1  0x0599150b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x05a686e5 in QTimerInfoList::updateCurrentTime (this=0x8c54f34) at kernel/qeventdispatcher_unix.cpp:339
#4  0x05a6872a in QTimerInfoList::timerWait (this=0x8c54f34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x05a667a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae8b90ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x05a6683d in timerSourcePrepare (source=0x0, timeout=0xcc9ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0226de6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x0226e279 in ?? () from /lib/libglib-2.0.so.0
#9  0x0226e848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x05a6659f in QEventDispatcherGlib::processEvents (this=0x8c54c18, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x05a36609 in QEventLoop::processEvents (this=0xae8b9280, flags=) at kernel/qeventloop.cpp:149
#12 0x05a36a8a in QEventLoop::exec (this=0xae8b9280, flags=...) at kernel/qeventloop.cpp:201
#13 0x05932b7e in QThread::exec (this=0x8c51eb8) at thread/qthread.cpp:490
#14 0x05a1535b in QInotifyFileSystemWatcherEngine::run (this=0x8c51eb8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x05935df9 in QThreadPrivate::start (arg=0x8c51eb8) at thread/qthread_unix.cpp:266
#16 0x002e2cc9 in start_thread () from /lib/libpthread.so.0
#17 0x00e9f6ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7753720 (LWP 1558)):
[KCrash Handler]
#7  0x070323aa in KJob::isAutoDelete (this=0x9824478) at ../../kdecore/jobs/kjob.cpp:353
#8  0x004a15a7 in Plasma::ServiceJob::setResult (this=0x9824478, result=...) at ../../plasma/servicejob.cpp:80
#9  0x05d39d6d in StatusNotifierItemJob::contextMenuReady (this=0x9824478, menu=0x9537250) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x05d39ded in StatusNotifierItemJob::qt_metacall (this=0x9824478, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfc307b8) at ./statusnotifieritemjob.moc:75
#11 0x05a3d8ca in QMetaObject::metacall (object=0x9824478, cl=95861176, idx=27, argv=0xbfc307b8) at kernel/qmetaobject.cpp:237
#12 0x05a506ad in QMetaObject::activate (sender=0x97d4478, m=0x5d40c40, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#13 0x05d330a3 in StatusNotifierItemSource::contextMenuReady (this=0x97d4478, _t1=0x9537250) at ./statusnotifieritemsource.moc:109
#14 0x05d332b1 in StatusNotifierItemSource::contextMenuReady (this=0x97d4478) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#15 0x05d38803 in StatusNotifierItemSource::qt_metacall (this=0x97d4478, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfc308dc) at ./statusnotifieritemsource.moc:90
#16 0x05a3d8ca in QMetaObject::metacall (object=0x97d4478, cl=95861176, idx=11, argv=0xbfc308dc) at kernel/qmetaobject.cpp:237
#17 0x05a506ad in QMetaObject::activate (sender=0x97cc810, m=0xcbbd84, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#18 0x00ca6567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#19 0x00cabcdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x00cacf2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#21 0x05a3d8ca in QMetaObject::metacall (object=0x97cc810, cl=95861176, idx=12, argv=0xbfc30b1c) at kernel/qmetaobject.cpp:237
#22 0x05a506ad in QMetaObject::activate (sender=0x9537250, m=0x1e60fe8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#23 0x0199fee7 in QMenu::aboutToShow (this=0x9537250) at .moc/release-shared/moc_qmenu.cpp:151
#24 0x019a7193 in QMenu::qt_metacall (this=0x9537250, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc30c6c) at .moc/release-shared/moc_qmenu.cpp:97
#25 0x05a3d8ca in QMetaObject::metacall (object=0x9537250, cl=95861176, idx=27, argv=0xbfc30c6c) at kernel/qmetaobject.cpp:237
#26 0x05a41352 in QMetaMethod::invoke (this=0xbfc30dfc, object=0x9537250, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#27 0x05a42a1f in QMetaObject::invokeMethod (obj=0x9537250, member=0xcb23e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#28 0x00ca693e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#29 0x05d346ef in StatusNotifierItemSource::contextMenu (this=0x97d4478, x=1027, y=781) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#30 0x05d3b33e in StatusNotifierItemJob::start (this=0x9824478) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#31 0x004a1423 in Plasma::ServiceJobPrivate::slotStart (this=0x9866ab8) at ../../plasma/servicejob.cpp:37
#32 0x004a14f4 in Plasma::ServiceJob::qt_metacall (this=0x9824478, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x9820df8) at ./servicejob.moc:72
#33 0x05d39dca in StatusNotifierItemJob::qt_metacall (this=0x9824478, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x9820df8) at ./statusnotifieritemjob.moc:70
#34 0x05a3d8ca in QMetaObject::metacall (object=0x9824478, cl=95861176, idx=26, argv=0x9820df8) at kernel/qmetaobject.cpp:237
#35 0x05a48df6 in QMetaCallEvent::placeMetaCall (this=0x986e4a8, object=0x9824478) at kernel/qobject.cpp:534
#36 0x05a4a6a2 in QObject::event (this=0x9824478, e=0x843baf0) at kernel/qobject.cpp:1219
#37 0x014dbfdc in QApplicationPrivate::notify_helper (this=0x839db20, receiver=0x9824478, e=0x986e4a8) at kernel/qapplication.cpp:4396
#38 0x014e204e in QApplication::notify (this=0x8392798, receiver=0x9824478, e=0x986e4a8) at kernel/qapplication.cpp:3798
#39 0x011d168a in KApplication::notify (this=0x8392798, receiver=0x9824478, event=0x986e4a8) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x05a37b3b in QCoreApplication::notifyInternal (this=0x8392798, receiver=0x9824478, event=0x986e4a8) at kernel/qcoreapplication.cpp:732
#41 0x05a3ad8b in sendEvent (receiver=0x0, event_type=0, data=0x837c028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x837c028) at kernel/qcoreapplication.cpp:1373
#43 0x05a3af4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x05a66a74 in sendPostedEvents (s=0x839ff10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x839ff10) at kernel/qeventdispatcher_glib.cpp:277
#46 0x0226a855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x0226e668 in ?? () from /lib/libglib-2.0.so.0
#48 0x0226e848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x05a66565 in QEventDispatcherGlib::processEvents (this=0x837bce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x0159dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x837bce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x05a36609 in QEventLoop::processEvents (this=0xbfc31bd4, flags=) at kernel/qeventloop.cpp:149
#52 0x05a36a8a in QEventLoop::exec (this=0xbfc31bd4, flags=...) at kernel/qeventloop.cpp:201
#53 0x05a3b00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x014dae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x00bef86e in kdemain (argc=1, argv=0xbfc31de4) at ../../../../plasma/desktop/shell/main.cpp:118
#56 0x080485bb in main (argc=1, argv=0xbfc31de4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 241562.

Possible duplicates by query: bug 255434, bug 255201, bug 255095, bug 254603, bug 254035.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-11-02 10:30:55 UTC

*** This bug has been marked as a duplicate of bug 241562 ***