Bug 254035 - Plasma crashed after click on KPackageKit tray icon
Summary: Plasma crashed after click on KPackageKit tray icon
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 07:46 UTC by Andrey
Modified: 2010-11-22 14:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.38 KB, text/plain)
2010-11-22 14:17 UTC, adrien_b4
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey 2010-10-13 07:46:23 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I open `System settings` and choose `Package manager`. Then I close it and saw tray icon of `KPackageManager`. After clicking on this icon Plasma crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Рабочее пространство Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7734720 (LWP 1845))]

Thread 2 (Thread 0xaf0aab70 (LWP 2000)):
#0  0x00f9a416 in __kernel_vsyscall ()
#1  0x00b21de6 in poll () from /lib/libc.so.6
#2  0x0204ca1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x0203f43c in ?? () from /lib/libglib-2.0.so.0
#4  0x0203f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x040ea59f in QEventDispatcherGlib::processEvents (this=0xae700468, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x040ba609 in QEventLoop::processEvents (this=0xaf0aa280, flags=) at kernel/qeventloop.cpp:149
#7  0x040baa8a in QEventLoop::exec (this=0xaf0aa280, flags=...) at kernel/qeventloop.cpp:201
#8  0x03fb6b7e in QThread::exec (this=0x93cfd40) at thread/qthread.cpp:490
#9  0x0409935b in QInotifyFileSystemWatcherEngine::run (this=0x93cfd40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x03fb9df9 in QThreadPrivate::start (arg=0x93cfd40) at thread/qthread_unix.cpp:266
#11 0x00d23cc9 in start_thread () from /lib/libpthread.so.0
#12 0x00b306ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7734720 (LWP 1845)):
[KCrash Handler]
#7  0x055903aa in KJob::isAutoDelete (this=0x9794628) at ../../kdecore/jobs/kjob.cpp:353
#8  0x0032d5a7 in Plasma::ServiceJob::setResult (this=0x9794628, result=...) at ../../plasma/servicejob.cpp:80
#9  0x039e1d6d in StatusNotifierItemJob::contextMenuReady (this=0x9794628, menu=0x9ba3af8) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x039e1ded in StatusNotifierItemJob::qt_metacall (this=0x9794628, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbf8957d8) at ./statusnotifieritemjob.moc:75
#11 0x040c18ca in QMetaObject::metacall (object=0x9794628, cl=69138872, idx=27, argv=0xbf8957d8) at kernel/qmetaobject.cpp:237
#12 0x040d46ad in QMetaObject::activate (sender=0x9bd16a8, m=0x39e8c40, local_signal_index=0, argv=0x22789) at kernel/qobject.cpp:3280
#13 0x039db0a3 in StatusNotifierItemSource::contextMenuReady (this=0x9bd16a8, _t1=0x9ba3af8) at ./statusnotifieritemsource.moc:109
#14 0x039db2b1 in StatusNotifierItemSource::contextMenuReady (this=0x9bd16a8) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#15 0x039e0803 in StatusNotifierItemSource::qt_metacall (this=0x9bd16a8, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf8958fc) at ./statusnotifieritemsource.moc:90
#16 0x040c18ca in QMetaObject::metacall (object=0x9bd16a8, cl=69138872, idx=11, argv=0xbf8958fc) at kernel/qmetaobject.cpp:237
#17 0x040d46ad in QMetaObject::activate (sender=0x9283308, m=0x1fc5d84, local_signal_index=0, argv=0x22789) at kernel/qobject.cpp:3280
#18 0x01fb0567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#19 0x01fb5cdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x01fb6f2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#21 0x040c18ca in QMetaObject::metacall (object=0x9283308, cl=69138872, idx=12, argv=0xbf895b3c) at kernel/qmetaobject.cpp:237
#22 0x040d46ad in QMetaObject::activate (sender=0x9ba3af8, m=0x1e02fe8, local_signal_index=0, argv=0x22789) at kernel/qobject.cpp:3280
#23 0x01941ee7 in QMenu::aboutToShow (this=0x9ba3af8) at .moc/release-shared/moc_qmenu.cpp:151
#24 0x01949193 in QMenu::qt_metacall (this=0x9ba3af8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf895c8c) at .moc/release-shared/moc_qmenu.cpp:97
#25 0x040c18ca in QMetaObject::metacall (object=0x9ba3af8, cl=69138872, idx=27, argv=0xbf895c8c) at kernel/qmetaobject.cpp:237
#26 0x040c5352 in QMetaMethod::invoke (this=0xbf895e1c, object=0x9ba3af8, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#27 0x040c6a1f in QMetaObject::invokeMethod (obj=0x9ba3af8, member=0x1fbc3e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#28 0x01fb093e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#29 0x039dc6ef in StatusNotifierItemSource::contextMenu (this=0x9bd16a8, x=1101, y=1007) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#30 0x039e333e in StatusNotifierItemJob::start (this=0x9794628) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#31 0x0032d423 in Plasma::ServiceJobPrivate::slotStart (this=0x96f73b0) at ../../plasma/servicejob.cpp:37
#32 0x0032d4f4 in Plasma::ServiceJob::qt_metacall (this=0x9794628, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x9bdb300) at ./servicejob.moc:72
#33 0x039e1dca in StatusNotifierItemJob::qt_metacall (this=0x9794628, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x9bdb300) at ./statusnotifieritemjob.moc:70
#34 0x040c18ca in QMetaObject::metacall (object=0x9794628, cl=69138872, idx=26, argv=0x9bdb300) at kernel/qmetaobject.cpp:237
#35 0x040ccdf6 in QMetaCallEvent::placeMetaCall (this=0x9bcdf18, object=0x9794628) at kernel/qobject.cpp:534
#36 0x040ce6a2 in QObject::event (this=0x9794628, e=0x8d7a210) at kernel/qobject.cpp:1219
#37 0x0147dfdc in QApplicationPrivate::notify_helper (this=0x8cc2dc0, receiver=0x9794628, e=0x9bcdf18) at kernel/qapplication.cpp:4396
#38 0x0148404e in QApplication::notify (this=0x8cb4668, receiver=0x9794628, e=0x9bcdf18) at kernel/qapplication.cpp:3798
#39 0x0117368a in KApplication::notify (this=0x8cb4668, receiver=0x9794628, event=0x9bcdf18) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x040bbb3b in QCoreApplication::notifyInternal (this=0x8cb4668, receiver=0x9794628, event=0x9bcdf18) at kernel/qcoreapplication.cpp:732
#41 0x040bed8b in sendEvent (receiver=0x0, event_type=0, data=0x8c9e028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8c9e028) at kernel/qcoreapplication.cpp:1373
#43 0x040bef4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x040eaa74 in sendPostedEvents (s=0x8cc50c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x8cc50c0) at kernel/qeventdispatcher_glib.cpp:277
#46 0x0203b855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x0203f668 in ?? () from /lib/libglib-2.0.so.0
#48 0x0203f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x040ea565 in QEventDispatcherGlib::processEvents (this=0x8c9dce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x0153fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8c9dce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x040ba609 in QEventLoop::processEvents (this=0xbf896bf4, flags=) at kernel/qeventloop.cpp:149
#52 0x040baa8a in QEventLoop::exec (this=0xbf896bf4, flags=...) at kernel/qeventloop.cpp:201
#53 0x040bf00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x0147ce07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x0048786e in kdemain (argc=1, argv=0xbf896e04) at ../../../../plasma/desktop/shell/main.cpp:118
#56 0x080485bb in main (argc=1, argv=0xbf896e04) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 254005, bug 253943, bug 248527, bug 241562.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-10-13 11:28:31 UTC

*** This bug has been marked as a duplicate of bug 241562 ***
Comment 2 adrien_b4 2010-11-22 14:17:36 UTC
Created attachment 53629 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:

 I clicked on the KPackageKit icon in the system tray while it was running an update

- Custom settings of the application:

none

-- Backtrace (Reduced):
#7  0xb68ec3aa in KJob::isAutoDelete (this=0xaea11a8) at ../../kdecore/jobs/kjob.cpp:353
#8  0xb74165a7 in Plasma::ServiceJob::setResult (this=0xaea11a8, result=...) at ../../plasma/servicejob.cpp:80
#9  0xab745d6d in StatusNotifierItemJob::contextMenuReady (this=0xaea11a8, menu=0xa9ad688) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0xab745ded in StatusNotifierItemJob::qt_metacall (this=0xaea11a8, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbf8f9d18) at ./statusnotifieritemjob.moc:75
[...]
[...]
#13 0xab73f0a3 in StatusNotifierItemSource::contextMenuReady (this=0xa6bb890, _t1=0xa9ad688) at ./statusnotifieritemsource.moc:109