Bug 255006 - SuSE 11.3 32-bit Plasma Crash after update
Summary: SuSE 11.3 32-bit Plasma Crash after update
Status: RESOLVED DUPLICATE of bug 254997
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-22 23:43 UTC by jimgravelle
Modified: 2010-10-23 12:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (8.16 KB, text/plain)
2010-10-23 11:43 UTC, stardragon88
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jimgravelle 2010-10-22 23:43:40 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

After updating my OpenSUSE 11.3 32-bit workstation to the latest (as of October 22, 4pm EST) available here:

http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_11.3/

The Plasma desktop crashes right after I log in.  The desktop nor the taskbar displays, the crash happens immediately, regardless of the user account I try.  I tried renaming the ".kde4" directory and logging in...but the crash still occurs.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Floating point exception
[KCrash Handler]
#7  enter (table=0x87c3a18, size=0, hash=2714114297, name=0xb609821a "_ZNSt8time_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE", sym=0xb608a1fc, map=0xb6c242a8) at dl-lookup.c:318
#8  0xb7706771 in do_lookup_x (new_hash=1365446393, old_hash=0xbfc062b8, ref=0xa8d520e0, result=0xbfc062ac, scope=0x87e019c, i=<value optimized out>, flags=1, skip=0x0, undef_map=0x87d1488)
    at dl-lookup.c:400
#9  0xb7706b49 in _dl_lookup_symbol_x (undef_name=0xa8d534be "_ZZN11QMetaTypeIdI5QListIN7Akonadi19NotificationMessageEEE14qt_metatype_idEvE11metatype_id", undef_map=0x87d1488, ref=0xbfc06358, 
    symbol_scope=0x87d1640, version=0x0, type_class=0, flags=1, skip_map=0x0) at dl-lookup.c:736
#10 0xb770845b in elf_machine_rel (scope=0x87d1640, reloc_mode=0, consider_profiling=0) at ../sysdeps/i386/dl-machine.h:344
#11 elf_dynamic_do_rel (scope=0x87d1640, reloc_mode=0, consider_profiling=0) at do-rel.h:120
#12 _dl_relocate_object (scope=0x87d1640, reloc_mode=0, consider_profiling=0) at dl-reloc.c:268
#13 0xb770f82e in dl_open_worker (a=0xbfc064e0) at dl-open.c:367
#14 0xb770b50f in _dl_catch_error (objname=0xbfc06508, errstring=0xbfc06504, mallocedp=0xbfc0650f, operate=0xb770f5b0 <dl_open_worker>, args=0xbfc064e0) at dl-error.c:178
#15 0xb770f2e6 in _dl_open (file=0x87e0008 "/usr/lib/kde4/plasma_engine_calendar.so", mode=-2147483647, caller_dlopen=0xb6d943e5, nsid=-2, argc=4, argv=0xbfc08524, env=0x816dfd0) at dl-open.c:583
#16 0xb5d0dbdd in dlopen_doit (a=0xbfc066b0) at dlopen.c:67
#17 0xb770b50f in _dl_catch_error (objname=0x8071ce4, errstring=0x8071ce8, mallocedp=0x8071ce0, operate=0xb5d0db40 <dlopen_doit>, args=0xbfc066b0) at dl-error.c:178
#18 0xb5d0e342 in _dlerror_run (operate=0xb5d0db40 <dlopen_doit>, args=<value optimized out>) at dlerror.c:164
#19 0xb5d0dca7 in __dlopen (file=0x87e0008 "/usr/lib/kde4/plasma_engine_calendar.so", mode=1) at dlopen.c:88
#20 0xb6d943e5 in QLibraryPrivate::load_sys (this=0x87e0800) at plugin/qlibrary_unix.cpp:205
#21 0xb6d8e864 in QLibraryPrivate::load (this=0x87e0800) at plugin/qlibrary.cpp:484
#22 0xb6d8e948 in QLibraryPrivate::loadPlugin (this=0x87e0800) at plugin/qlibrary.cpp:516
#23 0xb6d88883 in QPluginLoader::load (this=0xbfc069dc) at plugin/qpluginloader.cpp:227
#24 0xb705992f in KPluginLoader::load (this=0xbfc069dc) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:222
#25 0xb7059df5 in KPluginLoader::KPluginLoader (this=0xbfc069dc, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:180
#26 0xb4d52a5a in Plasma::DataEngineManager::loadEngine (this=0x829b440, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/dataenginemanager.cpp:137
#27 0xb4d89c55 in Plasma::DataEngineConsumer::dataEngine (this=0x8329660, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/private/dataengineconsumer.cpp:100
#28 0xb4d0ed97 in Plasma::Applet::dataEngine (this=0x82e17c0, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:663
#29 0xa9b9ef62 in ClockApplet::init (this=0x82e17c0) at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmaclock/clockapplet.cpp:570
#30 0xa9d31a3e in Clock::init (this=0x82e17c0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/generic/applets/digital-clock/clock.cpp:72
#31 0xb4d3692f in Plasma::ContainmentPrivate::initApplets (this=0x8213880) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:474
#32 0xb4d48e46 in Plasma::CoronaPrivate::importLayout (this=0x815ad48, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:525
#33 0xb4d49b95 in Plasma::Corona::loadLayout (this=0x8190318, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:460
#34 0xb4d49c74 in Plasma::Corona::initializeLayout (this=0x8190318, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:363
#35 0xb165619a in PlasmaApp::corona (this=0x80d5588) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:806
#36 0xb165985e in PlasmaApp::setupDesktop (this=0x80d5588) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:286
#37 0xb1662409 in PlasmaApp::qt_metacall (this=0x80d5588, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0x818d4a0)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasmaapp.moc:149
#38 0xb6daa96d in QMetaObject::metacall (object=0x80d5588, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0x818d4a0) at kernel/qmetaobject.cpp:237
#39 0xb6db5465 in QMetaCallEvent::placeMetaCall (this=0x818d390, object=0x80d5588) at kernel/qobject.cpp:534
#40 0xb6db969f in QObject::event (this=0x80d5588, e=0x818d390) at kernel/qobject.cpp:1211
#41 0xb6da471a in QCoreApplication::event (this=0x80d5588, e=0x818d390) at kernel/qcoreapplication.cpp:1561
#42 0xb62a68dd in QApplication::event (this=0x80d5588, e=0x818d390) at kernel/qapplication.cpp:2439
#43 0xb62a41a4 in QApplicationPrivate::notify_helper (this=0x80dc440, receiver=0x80d5588, e=0x818d390) at kernel/qapplication.cpp:4396
#44 0xb62acdd7 in QApplication::notify (this=0x80d5588, receiver=0x80d5588, e=0x818d390) at kernel/qapplication.cpp:3798
#45 0xb73ea9c1 in KApplication::notify (this=0x80d5588, receiver=0x80d5588, event=0x818d390) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#46 0xb6da412e in QCoreApplication::notifyInternal (this=0x80d5588, receiver=0x80d5588, event=0x818d390) at kernel/qcoreapplication.cpp:732
#47 0xb6da7e6c in sendEvent (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.h:215
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.cpp:1373
#49 0xb6da7fbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#50 0xb6dd26d4 in sendPostedEvents (s=0x80e1f10) at kernel/qcoreapplication.h:220
#51 postEventSourceDispatch (s=0x80e1f10) at kernel/qeventdispatcher_glib.cpp:277
#52 0xb5ae2b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#53 0xb5ae3350 in ?? () from /usr/lib/libglib-2.0.so.0
#54 0xb5ae360e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#55 0xb6dd285b in QEventDispatcherGlib::processEvents (this=0x80dbc18, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#56 0xb635919a in QGuiEventDispatcherGlib::processEvents (this=0x80dbc18, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0xb6da340d in QEventLoop::processEvents (this=0xbfc07954, flags=...) at kernel/qeventloop.cpp:149
#58 0xb6da3639 in QEventLoop::exec (this=0xbfc07954, flags=...) at kernel/qeventloop.cpp:201
#59 0xb6da8090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#60 0xb62a1ed4 in QApplication::exec () at kernel/qapplication.cpp:3672
#61 0xb164f06d in kdemain (argc=1, argv=0x80d44c8) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#62 0x0804e441 in launch (argc=1, _name=0x80d2c9c "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80524c3 "0") at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:723
#63 0x0804ef77 in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1215
#64 0x0804f61c in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1408
#65 0x08050499 in main (argc=142414984, argv=0x0, envp=0x0) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1892

Possible duplicates by query: bug 254997, bug 251719, bug 245386.

Reported using DrKonqi
Comment 1 stardragon88 2010-10-23 11:43:14 UTC
Created attachment 52794 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

Plasma crashes on system startup, same with manual plasma launch. Occured after recent OpenSUSE update, main difference being new NVIDIA drivers (from version 256.53 to 260.19).

-- Backtrace (Reduced):
#7  enter (table=0x8f0d100, size=0, hash=2714114297, name=0xb597421a "_ZNSt8time_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE", sym=0xb59661fc, map=0xb65002a8) at dl-lookup.c:318
#8  0xb78a5771 in do_lookup_x (new_hash=1365446393, old_hash=0xbfead088, ref=0xa68d40e0, result=0xbfead07c, scope=0x8ef501c, i=<value optimized out>, flags=1, skip=0x0, undef_map=0x8ef5b60)
    at dl-lookup.c:400
#9  0xb78a5b49 in _dl_lookup_symbol_x (undef_name=0xa68d54be "_ZZN11QMetaTypeIdI5QListIN7Akonadi19NotificationMessageEEE14qt_metatype_idEvE11metatype_id", undef_map=0x8ef5b60, ref=0xbfead128, 
    symbol_scope=0x8ef5d18, version=0x0, type_class=0, flags=1, skip_map=0x0) at dl-lookup.c:736
#10 0xb78a745b in elf_machine_rel (scope=0x8ef5d18, reloc_mode=1, consider_profiling=0) at ../sysdeps/i386/dl-machine.h:344
#11 elf_dynamic_do_rel (scope=0x8ef5d18, reloc_mode=1, consider_profiling=0) at do-rel.h:120
Comment 2 Beat Wolf 2010-10-23 12:15:28 UTC

*** This bug has been marked as a duplicate of bug 254997 ***