Bug 254997 - Plasma crashed by Lancelot or ggl plugins after openSUSE update
Summary: Plasma crashed by Lancelot or ggl plugins after openSUSE update
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 255006 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-22 22:04 UTC by Olaf Schmidt-Wischhöfer
Modified: 2010-10-24 13:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
plasma-desktop-appletsrc-original (8.64 KB, text/plain)
2010-10-22 22:06 UTC, Olaf Schmidt-Wischhöfer
Details
plasma-desktop-appletsrc-changed (7.75 KB, text/plain)
2010-10-22 22:07 UTC, Olaf Schmidt-Wischhöfer
Details
plasma-desktop-appletsrc-diff (1.50 KB, patch)
2010-10-22 22:08 UTC, Olaf Schmidt-Wischhöfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Schmidt-Wischhöfer 2010-10-22 22:04:54 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I updated openSUSE 11.3 to the latest KDE 4.5 packages from the BuildService repository
http://download.opensuse.org/repositories/KDE%3a/Distro%3a/Factory/openSUSE_11.3/

After the next system start, plasma-desktop crashes during restart. Manually restarting plasma-desktop has the same result.

I then had a look at the backtrace and saw that the crash happens when Plasma is trying to load the lancelot plugin. After removing all lancelot and ggl applets from ~/.kde4/share/config/plasma-desktop-appletrc, Plasma is able to start-up again without crash. Re-adding the Lancelot applet via the GUI crashes Plasma again.

I will attach the original plasma-desktop-appletrc as plasma-desktop-appletrc-original. (This crashes plasma-desktop.)
I will also attach my edited plasma-desktop-appletrc as plasma-desktop-appletrc-changed. (This doesn't crash plasma-desktop.)
And I will attach a diff between the two versions of the file as plasma-desktop-appletrc-diff.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma-Arbeitsfläche (plasma-desktop), signal: Floating point exception
[KCrash Handler]
#7  enter (table=0x839cc90, size=0, hash=2714114297, name=0xb58ec21a "_ZNSt8time_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE", sym=0xb58de1fc, map=0xb64782a8) at dl-lookup.c:318
#8  0xb7816771 in do_lookup_x (new_hash=1365446393, old_hash=0xbf8c91c8, ref=0xa99060e0, result=0xbf8c91bc, scope=0x855b0e4, i=<value optimized out>, flags=1, skip=0x0, undef_map=0x855bf70)
    at dl-lookup.c:400
#9  0xb7816b49 in _dl_lookup_symbol_x (undef_name=0xa99074be "_ZZN11QMetaTypeIdI5QListIN7Akonadi19NotificationMessageEEE14qt_metatype_idEvE11metatype_id", undef_map=0x855bf70, ref=0xbf8c9268, 
    symbol_scope=0x855c128, version=0x0, type_class=0, flags=1, skip_map=0x0) at dl-lookup.c:736
#10 0xb781845b in elf_machine_rel (scope=0x855c128, reloc_mode=1, consider_profiling=0) at ../sysdeps/i386/dl-machine.h:344
#11 elf_dynamic_do_rel (scope=0x855c128, reloc_mode=1, consider_profiling=0) at do-rel.h:120
#12 _dl_relocate_object (scope=0x855c128, reloc_mode=1, consider_profiling=0) at dl-reloc.c:268
#13 0xb781f82e in dl_open_worker (a=0xbf8c93f0) at dl-open.c:367
#14 0xb781b50f in _dl_catch_error (objname=0xbf8c9418, errstring=0xbf8c9414, mallocedp=0xbf8c941f, operate=0xb781f5b0 <dl_open_worker>, args=0xbf8c93f0) at dl-error.c:178
#15 0xb781f2e6 in _dl_open (file=0x84d8740 "/usr/lib/kde4/plasma_applet_lancelot_part.so", mode=-2147483647, caller_dlopen=0xb65e83e5, nsid=-2, argc=1, argv=0xbf8cadf4, env=0xbf8cadfc)
    at dl-open.c:583
#16 0xb3891bdd in dlopen_doit (a=0xbf8c95c0) at dlopen.c:67
#17 0xb781b50f in _dl_catch_error (objname=0x8051ffc, errstring=0x8052000, mallocedp=0x8051ff8, operate=0xb3891b40 <dlopen_doit>, args=0xbf8c95c0) at dl-error.c:178
#18 0xb3892342 in _dlerror_run (operate=0xb3891b40 <dlopen_doit>, args=<value optimized out>) at dlerror.c:164
#19 0xb3891ca7 in __dlopen (file=0x84d8740 "/usr/lib/kde4/plasma_applet_lancelot_part.so", mode=1) at dlopen.c:88
#20 0xb65e83e5 in QLibraryPrivate::load_sys (this=0x84f76b0) at plugin/qlibrary_unix.cpp:205
#21 0xb65e2864 in QLibraryPrivate::load (this=0x84f76b0) at plugin/qlibrary.cpp:484
#22 0xb65e2948 in QLibraryPrivate::loadPlugin (this=0x84f76b0) at plugin/qlibrary.cpp:516
#23 0xb65dc883 in QPluginLoader::load (this=0xbf8c9900) at plugin/qpluginloader.cpp:227
#24 0xb692a92f in KPluginLoader::load (this=0xbf8c9900) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:222
#25 0xb692adf5 in KPluginLoader::KPluginLoader (this=0xbf8c9900, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:180
#26 0xb73dfe00 in Plasma::Applet::load (appletName=..., appletId=79, args=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:2346
#27 0xb73f4d65 in Plasma::ContainmentPrivate::addApplet (this=0x830cbe0, name=..., args=..., appletGeometry=..., id=79, delayInit=true) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:2366
#28 0xb73fec99 in Plasma::Containment::restoreContents (this=0x831a3e0, group=...) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:511
#29 0xb73fe05f in Plasma::Containment::restore (this=0x831a3e0, group=...) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:381
#30 0xa9c8a5cf in Panel::restore (this=0x831a3e0, group=...) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/containments/panel/panel.cpp:671
#31 0xb74081c3 in Plasma::CoronaPrivate::importLayout (this=0x80b6480, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:519
#32 0xb7408b95 in Plasma::Corona::loadLayout (this=0x80b5850, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:460
#33 0xb7408c74 in Plasma::Corona::initializeLayout (this=0x80b5850, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:363
#34 0xb77a819a in PlasmaApp::corona (this=0x80a74f0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:806
#35 0xb77ab85e in PlasmaApp::setupDesktop (this=0x80a74f0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:286
#36 0xb77b4409 in PlasmaApp::qt_metacall (this=0x80a74f0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0x812e690)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasmaapp.moc:149
#37 0xb65fe96d in QMetaObject::metacall (object=0x80a74f0, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0x812e690) at kernel/qmetaobject.cpp:237
#38 0xb6609465 in QMetaCallEvent::placeMetaCall (this=0x8133e30, object=0x80a74f0) at kernel/qobject.cpp:534
#39 0xb660d69f in QObject::event (this=0x80a74f0, e=0x8133e30) at kernel/qobject.cpp:1211
#40 0xb65f871a in QCoreApplication::event (this=0x80a74f0, e=0x8133e30) at kernel/qcoreapplication.cpp:1561
#41 0xb5afa8dd in QApplication::event (this=0x80a74f0, e=0x8133e30) at kernel/qapplication.cpp:2439
#42 0xb5af81a4 in QApplicationPrivate::notify_helper (this=0x80bab48, receiver=0x80a74f0, e=0x8133e30) at kernel/qapplication.cpp:4396
#43 0xb5b00dd7 in QApplication::notify (this=0x80a74f0, receiver=0x80a74f0, e=0x8133e30) at kernel/qapplication.cpp:3798
#44 0xb6b809c1 in KApplication::notify (this=0x80a74f0, receiver=0x80a74f0, event=0x8133e30) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#45 0xb65f812e in QCoreApplication::notifyInternal (this=0x80a74f0, receiver=0x80a74f0, event=0x8133e30) at kernel/qcoreapplication.cpp:732
#46 0xb65fbe6c in sendEvent (receiver=0x0, event_type=0, data=0x804e5b8) at kernel/qcoreapplication.h:215
#47 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x804e5b8) at kernel/qcoreapplication.cpp:1373
#48 0xb65fbfbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#49 0xb66266d4 in sendPostedEvents (s=0x80bcd10) at kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=0x80bcd10) at kernel/qeventdispatcher_glib.cpp:277
#51 0xb36ecb49 in g_main_dispatch (context=0x80bcc90) at gmain.c:1960
#52 IA__g_main_context_dispatch (context=0x80bcc90) at gmain.c:2513
#53 0xb36ed350 in g_main_context_iterate (context=0x80bcc90, block=1, dispatch=1, self=0x80ba788) at gmain.c:2591
#54 0xb36ed60e in IA__g_main_context_iteration (context=0x80bcc90, may_block=1) at gmain.c:2654
#55 0xb662685b in QEventDispatcherGlib::processEvents (this=0x8051fd0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#56 0xb5bad19a in QGuiEventDispatcherGlib::processEvents (this=0x8051fd0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0xb65f740d in QEventLoop::processEvents (this=0xbf8cabf4, flags=...) at kernel/qeventloop.cpp:149
#58 0xb65f7639 in QEventLoop::exec (this=0xbf8cabf4, flags=...) at kernel/qeventloop.cpp:201
#59 0xb65fc090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#60 0xb5af5ed4 in QApplication::exec () at kernel/qapplication.cpp:3672
#61 0xb77a106d in kdemain (argc=1, argv=0xbf8cadf4) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#62 0x0804861b in main (argc=1, argv=0xbf8cadf4) at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 251719, bug 245386, bug 142527.

Reported using DrKonqi
Comment 1 Olaf Schmidt-Wischhöfer 2010-10-22 22:06:53 UTC
Created attachment 52779 [details]
plasma-desktop-appletsrc-original
Comment 2 Olaf Schmidt-Wischhöfer 2010-10-22 22:07:41 UTC
Created attachment 52780 [details]
plasma-desktop-appletsrc-changed
Comment 3 Olaf Schmidt-Wischhöfer 2010-10-22 22:08:12 UTC
Created attachment 52781 [details]
plasma-desktop-appletsrc-diff
Comment 4 Beat Wolf 2010-10-23 12:15:28 UTC
*** Bug 255006 has been marked as a duplicate of this bug. ***
Comment 5 Beat Wolf 2010-10-23 12:17:29 UTC

*** This bug has been marked as a duplicate of bug 251719 ***
Comment 6 Olaf Schmidt-Wischhöfer 2010-10-24 13:42:52 UTC
After this report was marked as a duplicate of bug 251719, I switched my video driver away from NVIDIA, and the problem indeed disappears. Very strange, because neither the circumstances of the bug appearing nor the bug trace give any indication why the problem should be graphics driver related ...