Bug 254573 - kstars shows 103P Hartley in wrong location
Summary: kstars shows 103P Hartley in wrong location
Status: RESOLVED FIXED
Alias: None
Product: kstars
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords:
: 252571 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-18 19:19 UTC by step247
Modified: 2011-07-26 09:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Kstars shows 103P Hartley 2 in wrong part of the sky. (71.28 KB, image/jpeg)
2010-10-18 19:19 UTC, step247
Details

Note You need to log in before you can comment on or make changes to this bug.
Description step247 2010-10-18 19:19:45 UTC
Created attachment 52659 [details]
Kstars shows 103P Hartley 2 in wrong part of the sky. 

Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

Kstars shows 103P Hartley 2 in wrong part of the sky. 

Test date 19 Oct 2010, Time 00.10

Info shows, "Comet in Gemini" but at this date, the correct locations is Auriga. 
Kstars shows Ra 07h 52m Ded 18 11 

Proper location is actually close to 5h 08m Dec +43 33


Reproducible: Always

Steps to Reproduce:
start KDE and search for Hartley 2
Comment 1 Alexey Khudiakov 2011-02-18 20:30:37 UTC
*** Bug 252571 has been marked as a duplicate of this bug. ***
Comment 2 Jérôme SONRIER 2011-04-17 03:13:59 UTC
Git commit 99dffed883213ae4354a5a07e6ba65b868f86fa5 by Jérome SONRIER.
Committed on 12/04/2011 at 19:46.
Pushed by jsonrier into branch 'master'.

Add menu entry to update comets.dat file.

CCMAIL: kstars-devel@kde.org
CCBUG: 254573

M  +3    -0    kstars/kstars.h     
M  +6    -0    kstars/kstarsactions.cpp     
M  +4    -0    kstars/kstarsinit.cpp     
M  +4    -0    kstars/kstarsui-indi.rc     
M  +4    -0    kstars/kstarsui-win.rc     
M  +4    -0    kstars/kstarsui.rc     
M  +38   -0    kstars/skycomponents/cometscomponent.cpp     
M  +1    -0    kstars/skycomponents/cometscomponent.h     
M  +5    -0    kstars/skycomponents/skymapcomposite.cpp     
M  +2    -0    kstars/skycomponents/skymapcomposite.h     
M  +6    -0    kstars/skycomponents/solarsystemcomposite.cpp     
M  +2    -0    kstars/skycomponents/solarsystemcomposite.h     

http://commits.kde.org/kstars/99dffed883213ae4354a5a07e6ba65b868f86fa5
Comment 3 Alexey Khudiakov 2011-07-26 09:45:39 UTC
Comet was shown in wrong place due to obsolete data