Bug 254396 - Plasma crashed after clicking on update manager in system tray.
Summary: Plasma crashed after clicking on update manager in system tray.
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-16 19:43 UTC by valunf
Modified: 2010-10-18 10:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (13.33 KB, text/plain)
2010-10-17 14:00 UTC, omega
Details
New crash information added by DrKonqi (7.35 KB, text/plain)
2010-10-18 10:30 UTC, Anderson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description valunf 2010-10-16 19:43:37 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I'm trying to click on update manager in system tray when it has completed update.

The crash can be reproduced every time.

-- Backtrace:
Application: Рабочее пространство Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8ea650c7a0 (LWP 1988))]

Thread 2 (Thread 0x7f8e81565710 (LWP 1990)):
#0  0x00007f8ea5e191d3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8e9aa03009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f8e9aa0345c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f8ea34ce1e6 in QEventDispatcherGlib::processEvents (this=0x32337d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f8ea34a0a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f8ea34a0dec in QEventLoop::exec (this=0x7f8e81564cb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f8ea33ab2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f8ea34805f8 in QInotifyFileSystemWatcherEngine::run (this=0x3232e00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8ea33ae27e in QThreadPrivate::start (arg=0x3232e00) at thread/qthread_unix.cpp:266
#9  0x00007f8e9e060953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f8ea3123971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f8ea5e2591d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8ea650c7a0 (LWP 1988)):
[KCrash Handler]
#6  0x00007f8ea3b72304 in KJob::isAutoDelete (this=0x4d6ab40) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f8ea3b729b8 in KJob::emitResult (this=0x4d6ab40) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f8e86534c73 in StatusNotifierItemJob::contextMenuReady (this=0x4d6ab40, menu=0x4b0eef0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f8e86534ce0 in StatusNotifierItemJob::qt_metacall (this=0x4d6ab40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff33448b70) at ./statusnotifieritemjob.moc:75
#10 0x00007f8ea34b9b27 in QMetaObject::activate (sender=0x4578750, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8ea37d4120) at kernel/qobject.cpp:3280
#11 0x00007f8e8652ec7f in StatusNotifierItemSource::contextMenuReady (this=0x4d6ab40, _t1=0x4b0eef0) at ./statusnotifieritemsource.moc:109
#12 0x00007f8e86533be4 in StatusNotifierItemSource::qt_metacall (this=0x4578750, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff33448c60) at ./statusnotifieritemsource.moc:90
#13 0x00007f8ea34b9b27 in QMetaObject::activate (sender=0x4cac1b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8ea37d4120) at kernel/qobject.cpp:3280
#14 0x00007f8e9bd2889c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f8e9bd29a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f8ea34b9b27 in QMetaObject::activate (sender=0x4b0eef0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8ea37d4120) at kernel/qobject.cpp:3280
#17 0x00007f8ea2a51f40 in QMenu::qt_metacall (this=0x4b0eef0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff334490e0) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f8ea34aabf9 in QMetaMethod::invoke (this=0x7fff33449390, object=0x4b0eef0, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f8ea34ac306 in QMetaObject::invokeMethod (obj=0x4b0eef0, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f8e9bd237c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f8e865301bb in StatusNotifierItemSource::contextMenu (this=0x4578750, x=1068, y=20) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f8e865362d8 in StatusNotifierItemJob::start (this=0x4d6ab40) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f8ea59f2b21 in Plasma::ServiceJob::qt_metacall (this=0x4d6ab40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f8e86534cc0 in StatusNotifierItemJob::qt_metacall (this=0x4d6ab40, _c=QMetaObject::InvokeMetaMethod, _id=40538640, _a=0x7f8ea37d4120) at ./statusnotifieritemjob.moc:70
#25 0x00007f8ea34b3bde in QObject::event (this=0x4d6ab40, e=0x4d6ab40) at kernel/qobject.cpp:1219
#26 0x00007f8ea25ebfdc in QApplicationPrivate::notify_helper (this=0x25eb080, receiver=0x4d6ab40, e=0x4727e60) at kernel/qapplication.cpp:4396
#27 0x00007f8ea25f1aed in QApplication::notify (this=0x25d4100, receiver=0x4d6ab40, e=0x4727e60) at kernel/qapplication.cpp:4277
#28 0x00007f8ea413d156 in KApplication::notify (this=0x25d4100, receiver=0x4d6ab40, event=0x4727e60) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f8ea34a1cdc in QCoreApplication::notifyInternal (this=0x25d4100, receiver=0x4d6ab40, event=0x4727e60) at kernel/qcoreapplication.cpp:732
#30 0x00007f8ea34a4c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x257d560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x257d560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f8ea34ce653 in sendPostedEvents (s=0x25ee7e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x25ee7e0) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f8e9a9ff342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f8e9aa032a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f8e9aa0345c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f8ea34ce193 in QEventDispatcherGlib::processEvents (this=0x257d070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f8ea269ea4e in QGuiEventDispatcherGlib::processEvents (this=0x4d6ab40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f8ea34a0a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f8ea34a0dec in QEventLoop::exec (this=0x7fff3344a620, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f8ea34a4ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f8ea60fca56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f8ea5d5dd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff3344a9e8) at libc-start.c:226
#44 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 241562.

Possible duplicates by query: bug 253759, bug 248527, bug 242202, bug 241657, bug 241562.

Reported using DrKonqi
Comment 1 omega 2010-10-17 14:00:07 UTC
Created attachment 52609 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

- What I was doing when the application crashed:

I'm trying to click on update manager in system tray when it has completed update.

-- Backtrace (Reduced):
#6  0x00007ffb2a654344 in KJob::isAutoDelete (this=0x2a78a40) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007ffb2a6549f8 in KJob::emitResult (this=0x2a78a40) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007ffb0c753c73 in StatusNotifierItemJob::contextMenuReady (this=0x2a78a40, menu=0x4487d30) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007ffb0c753ce0 in StatusNotifierItemJob::qt_metacall (this=0x2a78a40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffeec7f330) at ./statusnotifieritemjob.moc:75
[...]
#11 0x00007ffb0c74dc7f in StatusNotifierItemSource::contextMenuReady (this=0x2a78a40, _t1=0x4487d30) at ./statusnotifieritemsource.moc:109
Comment 2 Beat Wolf 2010-10-17 17:34:13 UTC

*** This bug has been marked as a duplicate of bug 241562 ***
Comment 3 Anderson 2010-10-18 10:30:28 UTC
Created attachment 52636 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:

Clicked on the icon to refresh the update list.

-- Backtrace (Reduced):
#6  0x00007f7d2e6bd304 in KJob::isAutoDelete (this=0x2997f80) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f7d2e6bd9b8 in KJob::emitResult (this=0x2997f80) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f7d10bfbc73 in StatusNotifierItemJob::contextMenuReady (this=0x2997f80, menu=0x291ef80) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f7d10bfbce0 in StatusNotifierItemJob::qt_metacall (this=0x2997f80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1054ef30) at ./statusnotifieritemjob.moc:75
[...]
#11 0x00007f7d10bf5c7f in StatusNotifierItemSource::contextMenuReady (this=0x2997f80, _t1=0x291ef80) at ./statusnotifieritemsource.moc:109