Bug 248527 - Plasma crash when suspening Strigi in System tray
Summary: Plasma crash when suspening Strigi in System tray
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-20 16:32 UTC by Alvise
Modified: 2010-08-20 18:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alvise 2010-08-20 16:32:47 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.00 (KDE 4.5.0)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
I was trying to suspend/enable Strigi, from the system tray:
- open systray (on my system Nepomuk icon is set as always hidden)
- right click on Nepomuk icon
- click on "Suspend file indexing"

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5910710 (LWP 1904))]

Thread 2 (Thread 0xa9812b70 (LWP 2254)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6c7f125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb3e7a1f7 in WTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib/libQtWebKit.so.4
#3  0xb3e7a23f in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib/libQtWebKit.so.4
#4  0xb6c7ab25 in start_thread () from /lib/libpthread.so.0
#5  0xb606746e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5910710 (LWP 1904)):
[KCrash Handler]
#7  KJob::isAutoDelete (this=0x9a35ce0) at /usr/src/debug/kdelibs-4.5.0/kdecore/jobs/kjob.cpp:353
#8  0xb6fa65e0 in KJob::emitResult (this=0x9a35ce0) at /usr/src/debug/kdelibs-4.5.0/kdecore/jobs/kjob.cpp:314
#9  0xb4e8ffa8 in Plasma::ServiceJob::setResult (this=0x9a35ce0, result=...) at /usr/src/debug/kdelibs-4.5.0/plasma/servicejob.cpp:80
#10 0xab219486 in StatusNotifierItemJob::contextMenuReady (this=0x9a35ce0, menu=0x885a698)
    at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#11 0xab219517 in StatusNotifierItemJob::qt_metacall (this=0x9a35ce0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfc9e758)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:75
#12 0xb6df4efd in QMetaObject::metacall (object=0x9a35ce0, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbfc9e758) at kernel/qmetaobject.cpp:237
#13 0xb6e03fe8 in QMetaObject::activate (sender=0x9043fe0, m=0xab227b7c, local_signal_index=0, argv=0xbfc9e758) at kernel/qobject.cpp:3295
#14 0xab2190b5 in StatusNotifierItemSource::contextMenuReady (this=0x9043fe0, _t1=0x885a698)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:109
#15 0xab2190f1 in StatusNotifierItemSource::contextMenuReady (this=0x9043fe0) at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:362
#16 0xab21f14c in StatusNotifierItemSource::qt_metacall (this=0x9043fe0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfc9e86c)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:90
#17 0xb6df4efd in QMetaObject::metacall (object=0x9043fe0, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbfc9e86c) at kernel/qmetaobject.cpp:237
#18 0xb6e03fe8 in QMetaObject::activate (sender=0x971c518, m=0xb5ed5d84, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#19 0xb5ebabe5 in DBusMenuImporter::menuUpdated (this=0x971c518) at /usr/src/debug/libdbusmenu-qt-0.5.2/build/src/dbusmenuimporter.moc:120
#20 0xb5ebb509 in DBusMenuImporter::slotMenuAboutToShow (this=0x971c518) at /usr/src/debug/libdbusmenu-qt-0.5.2/src/dbusmenuimporter.cpp:557
#21 0xb5ec23ec in DBusMenuImporter::qt_metacall (this=0x971c518, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfc9eaac)
    at /usr/src/debug/libdbusmenu-qt-0.5.2/build/src/dbusmenuimporter.moc:105
#22 0xb6df4efd in QMetaObject::metacall (object=0x971c518, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc9eaac) at kernel/qmetaobject.cpp:237
#23 0xb6e03fe8 in QMetaObject::activate (sender=0x885a698, m=0xb6c5d6c8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#24 0xb67bac65 in QMenu::aboutToShow (this=0x885a698) at .moc/release-shared/moc_qmenu.cpp:151
#25 0xb67c13d8 in QMenu::qt_metacall (this=0x885a698, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc9ebec) at .moc/release-shared/moc_qmenu.cpp:97
#26 0xb6df4efd in QMetaObject::metacall (object=0x885a698, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbfc9ebec) at kernel/qmetaobject.cpp:237
#27 0xb6df79c9 in QMetaMethod::invoke (this=0xbfc9ed8c, object=0x885a698, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., 
    val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1533
#28 0xb6df8943 in QMetaObject::invokeMethod (obj=0x885a698, member=0xb5ecb265 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., 
    val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1113
#29 0xb5ebab9f in invokeMethod (this=0x971c518) at /usr/include/QtCore/qobjectdefs.h:416
#30 DBusMenuImporter::updateMenu (this=0x971c518) at /usr/src/debug/libdbusmenu-qt-0.5.2/src/dbusmenuimporter.cpp:490
#31 0xab218c43 in StatusNotifierItemSource::contextMenu (this=0x9043fe0, x=1068, y=152)
    at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:465
#32 0xab21b5a5 in StatusNotifierItemJob::start (this=0x9a35ce0) at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#33 0xb4e8fdfb in slotStart (this=0x9a35ce0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfc9f39c) at /usr/src/debug/kdelibs-4.5.0/plasma/servicejob.cpp:37
#34 Plasma::ServiceJob::qt_metacall (this=0x9a35ce0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfc9f39c) at /usr/src/debug/kdelibs-4.5.0/build/plasma/servicejob.moc:72
#35 0xab2194f2 in StatusNotifierItemJob::qt_metacall (this=0x9a35ce0, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xbfc9f39c)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:70
#36 0xb6df4efd in QMetaObject::metacall (object=0x9a35ce0, cl=QMetaObject::InvokeMetaMethod, idx=26, argv=0xbfc9f39c) at kernel/qmetaobject.cpp:237
#37 0xb6e03fe8 in QMetaObject::activate (sender=0x95782e0, m=0xb6f0a188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#38 0xb6e099d5 in QSingleShotTimer::timeout (this=0x95782e0) at .moc/release-shared/qtimer.moc:82
#39 0xb6e09a8c in QSingleShotTimer::timerEvent (this=0x95782e0) at kernel/qtimer.cpp:308
#40 0xb6e01774 in QObject::event (this=0x95782e0, e=0xbfc9f8d0) at kernel/qobject.cpp:1212
#41 0xb6327c64 in QApplicationPrivate::notify_helper (this=0x80a5cb0, receiver=0x95782e0, e=0xbfc9f8d0) at kernel/qapplication.cpp:4302
#42 0xb632fbf7 in QApplication::notify (this=0x80a0930, receiver=0x95782e0, e=0xbfc9f8d0) at kernel/qapplication.cpp:3706
#43 0xb740c2c1 in KApplication::notify (this=0x80a0930, receiver=0x95782e0, event=0xbfc9f8d0) at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kapplication.cpp:310
#44 0xb6deee0e in QCoreApplication::notifyInternal (this=0x80a0930, receiver=0x95782e0, event=0xbfc9f8d0) at kernel/qcoreapplication.cpp:726
#45 0xb6e1d70e in sendEvent (this=0x80ab934) at kernel/qcoreapplication.h:215
#46 QTimerInfoList::activateTimers (this=0x80ab934) at kernel/qeventdispatcher_unix.cpp:618
#47 0xb6e1a642 in timerSourceDispatch (source=0x80ab900) at kernel/qeventdispatcher_glib.cpp:184
#48 0xb5b6eb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb5b6f350 in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb5b6f60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb6e1ad4b in QEventDispatcherGlib::processEvents (this=0x80a5e88, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#52 0xb63d819a in QGuiEventDispatcherGlib::processEvents (this=0x80a5e88, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0xb6dee11d in QEventLoop::processEvents (this=0xbfc9fb94, flags=...) at kernel/qeventloop.cpp:149
#54 0xb6dee319 in QEventLoop::exec (this=0xbfc9fb94, flags=...) at kernel/qeventloop.cpp:201
#55 0xb6df2c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#56 0xb6325164 in QApplication::exec () at kernel/qapplication.cpp:3581
#57 0xb2d270dd in kdemain (argc=1, argv=0x809cdc0) at /usr/src/debug/kdebase-workspace-4.5.0/plasma/desktop/shell/main.cpp:118
#58 0x0804e3f1 in launch (argc=1, _name=0x807ed14 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8052323 "0") at /usr/src/debug/kdelibs-4.5.0/kinit/kinit.cpp:723
#59 0x0804ef27 in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.5.0/kinit/kinit.cpp:1215
#60 0x0804f5cc in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.5.0/kinit/kinit.cpp:1408
#61 0x08050449 in main (argc=) at /usr/src/debug/kdelibs-4.5.0/kinit/kinit.cpp:1892

Possible duplicates by query: bug 241562.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-20 18:35:59 UTC

*** This bug has been marked as a duplicate of bug 241562 ***