Bug 254202 - Inscriptions beginnings are slightly cut off
Summary: Inscriptions beginnings are slightly cut off
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-networkmonitor (show other bugs)
Version: 4.11.11
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-14 22:40 UTC by Artem S. Tashkinov
Modified: 2015-07-27 12:01 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Bug appearance (108.56 KB, image/png)
2010-10-14 22:40 UTC, Artem S. Tashkinov
Details
network plasmoid in KDE 4.6 beta 2 (147.96 KB, image/png)
2010-12-14 01:29 UTC, Artem S. Tashkinov
Details
CPU load plasmoid (57.11 KB, image/png)
2010-12-14 01:42 UTC, Artem S. Tashkinov
Details
Fedora 17, KDE 4.8.3, Qt 4.8.1 (48.04 KB, image/png)
2012-05-28 18:46 UTC, Artem S. Tashkinov
Details
CentOS 7.0 x64 RC live KDE image running KDE 4.10.5/Qt 4.8.5 (146.96 KB, image/png)
2014-07-05 07:42 UTC, Artem S. Tashkinov
Details
Fedora 21 alpha 1, KDE 4.14 (49.92 KB, image/png)
2014-09-24 03:56 UTC, Artem S. Tashkinov
Details
Screenshot (36.42 KB, image/png)
2015-01-13 00:51 UTC, Christoph Feck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem S. Tashkinov 2010-10-14 22:40:07 UTC
Created attachment 52520 [details]
Bug appearance

Version:           unspecified (using Devel) 
OS:                Linux

Some plasmoids have their inscriptions beginnings slightly cut off, e.g. network monitor and RAM.

Reproducible: Always

Steps to Reproduce:
Add any of those plasmoids to the desktop, resize them up a bit.

Actual Results:  
Inscriptions beginnings slightly cut off

Expected Results:  
Inscriptions fully shown.
Comment 1 Artem S. Tashkinov 2010-11-27 16:49:46 UTC
It's still relevant as for KDE4.6 beta1.
Comment 2 Anne-Marie Mahfouf 2010-12-13 14:03:23 UTC
Not reproduced.

After a discussion on IRC it seems that this is the Tahoma font which is not free and which I don't have.

When I use the Network applet with default font it behaves exactly as it should: when the size of the applet is not big enough to display text then no text is displayed. When I make the applet bigger, the whole strings are correctly displayed.
Comment 3 Artem S. Tashkinov 2010-12-14 01:29:52 UTC
Created attachment 54524 [details]
network plasmoid in KDE 4.6 beta 2

I still can reproduce it with any font here, including _free_ DejaVu font family.

I'm now using KDE 4.6 beta 2.
Comment 4 Artem S. Tashkinov 2010-12-14 01:42:36 UTC
Created attachment 54526 [details]
CPU load plasmoid

This bug affects all plasmoids.

Here's a CPU load plasmoid screenshot.
Comment 5 Jekyll Wu 2012-05-28 17:41:23 UTC
I can't reproduce this. Is it still a problem for the reporter if using recent verions of KDE and Qt like KDE 4.8.x + Qt 4.8.x ?
Comment 6 Artem S. Tashkinov 2012-05-28 18:46:49 UTC
Created attachment 71417 [details]
Fedora 17,  KDE 4.8.3, Qt 4.8.1

(In reply to comment #5)
> I can't reproduce this. Is it still a problem for the reporter if using
> recent verions of KDE and Qt like KDE 4.8.x + Qt 4.8.x ?

100% reproducible in just released Fedora 17.

It's not even funny any more.
Comment 7 matthias.peinhardt 2012-09-14 16:53:34 UTC
Artem Tashkinov, that name rang a bell...

You fiddled with your font setup a lot, right? Can you check whether the problem persists with the default freetype, .fonts.conf etc.? Going from there, can you identify which setting, patch, ... actually triggers the problem?
Comment 8 Artem S. Tashkinov 2012-09-14 18:34:03 UTC
Fedora 17 LiveCD, *with no settings* changed whatsoever. Go check yourself.

http://download.fedoraproject.org/pub/fedora/linux/releases/17/Live/i686/Fedora-17-i686-Live-KDE.iso

P.S. And I don't understand at all why you are bring my name here - I don't make up bug reports, I only report broken things and missing features. It's damn unprofessional and bound to be insulting to treat bug reports this way.
Comment 9 matthias.peinhardt 2012-09-14 22:56:23 UTC
Sorry for any misunderstanding, I brought your name into it because you have this little linuxfont site that I once stumbled upon, right? (See my second sentence!)

So my line of reasoning was: there is this man that likes to tinker with the font setup, and he sees a one-pixel-off glitch that noone can reproduce (so it seems) ... maybe it has something to do with it. No luck with it, but worth a try.

No insult intended, really.
Comment 10 Artem S. Tashkinov 2014-07-05 07:42:40 UTC
Created attachment 87567 [details]
CentOS 7.0 x64 RC live KDE image running KDE 4.10.5/Qt 4.8.5

Almost 4 years later the issue, which probably takes a few minutes to be resolved, is still unfixed.

See yourself: http://buildlogs.centos.org/centos/7/isos/x86_64/CentOS-7-live-KDE-x86_64.iso

<rant_mode_on>Too bad you killed KDE 3.5.10 which I've been using for the past six years already and I still refused to update to anything new. When you keep leaving pieces of KDE unpolished, visually broken, inconsistent, no wonder people start looking for alternatives. When I can no longer use KDE 3.5.10 I will most likely update to XFCE or LXQT. I don't need fancy unusable novelties.</rant_mode_on>
Comment 11 Artem S. Tashkinov 2014-09-24 03:56:08 UTC
Created attachment 88826 [details]
Fedora 21 alpha 1, KDE 4.14

Fedora 21 alpha.

The bug persists.

Hats off to KDE devs!

(I'm still using KDE 3, and I'll probably migrate to XFCE when I cannot use it any more).
Comment 12 Christoph Feck 2015-01-13 00:51:37 UTC
Created attachment 90378 [details]
Screenshot

Cannot reproduce either, see screenshot.

It probably depends on a very specific combination of
- monitor DPI
- font size
- font face
- font rendering settings, especially hinting settings

Checking the code, it does nothing wrong. I do not like blaming other projects, but in this case Qt probably returns a wrong bounding box metric for the particular text and font settings. We have similar problems in Dolphin (see bug 337104) and the file dialog (see bug 328497). See also https://bugreports.qt.io/browse/QTBUG-7768
Comment 13 Artem S. Tashkinov 2015-01-13 10:49:17 UTC
(In reply to Christoph Feck from comment #12)
> Created attachment 90378 [details]
> Screenshot
> 
> Cannot reproduce either, see screenshot.
> 

Run Fedora 21 KDE Live Spin under VirtualBox and reproduce this bug immediately.  This is no longer funny.

No special settings, no special fonts, no special DPI settings, all defaults.

http://download.fedoraproject.org/pub/fedora/linux/releases/21/Live/i386/Fedora-Live-KDE-i686-21-5.iso
Comment 14 Artem S. Tashkinov 2015-07-27 12:01:29 UTC
In Fedora 22 this bug is finally fixed (it looks like the corresponding plasmoid was largely rewritten).

I've no idea which KDE version fixed this bug because KDE's versioning nowadays is a great mystery (Plasma/Applications/Framework).