Bug 254025 - kde crash
Summary: kde crash
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 03:38 UTC by blaze
Modified: 2010-10-13 11:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blaze 2010-10-13 03:38:06 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

was checking for updates when crash happened,had klam av running in system tray,5 mins before checking for updates i had virtualbox running its when desktop started acting up

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2ee49fc780 (LWP 1802))]

Thread 2 (Thread 0x7f2ebd8ee710 (LWP 1806)):
#0  0x00007f2ee43071e3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2ed8f85009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f2ed8f8545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f2ee19bc1e6 in QEventDispatcherGlib::processEvents (this=0x2cfab20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f2ee198ea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f2ee198edec in QEventLoop::exec (this=0x7f2ebd8edd90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f2ee18992fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f2ee196e5f8 in QInotifyFileSystemWatcherEngine::run (this=0x2cfa1a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2ee189c27e in QThreadPrivate::start (arg=0x2cfa1a0) at thread/qthread_unix.cpp:266
#9  0x00007f2ee1611971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f2ee431392d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2ee49fc780 (LWP 1802)):
[KCrash Handler]
#6  QMutex::lock (this=0x65646b3a3a6772af) at thread/qmutex.cpp:151
#7  0x00007f2ee1992642 in QCoreApplication::postEvent (receiver=0x45280d0, event=0x4b57740, priority=0) at kernel/qcoreapplication.cpp:1141
#8  0x00007f2ec68fdc73 in StatusNotifierItemJob::contextMenuReady (this=0x45280d0, menu=0x3c835c0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f2ec68fdce0 in StatusNotifierItemJob::qt_metacall (this=0x45280d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87068ff0) at ./statusnotifieritemjob.moc:75
#10 0x00007f2ee19a7b27 in QMetaObject::activate (sender=0x3c3e590, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4b57730) at kernel/qobject.cpp:3280
#11 0x00007f2ec68f7c7f in StatusNotifierItemSource::contextMenuReady (this=0x65646b3a3a6772af, _t1=0x3c835c0) at ./statusnotifieritemsource.moc:109
#12 0x00007f2ec68fcbe4 in StatusNotifierItemSource::qt_metacall (this=0x3c3e590, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff870690e0) at ./statusnotifieritemsource.moc:90
#13 0x00007f2ee19a7b27 in QMetaObject::activate (sender=0x3345520, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4b57730) at kernel/qobject.cpp:3280
#14 0x00007f2eda2aa89c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f2eda2aba5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f2ee19a7b27 in QMetaObject::activate (sender=0x3c835c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4b57730) at kernel/qobject.cpp:3280
#17 0x00007f2ee0f3ff40 in QMenu::qt_metacall (this=0x3c835c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87069560) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f2ee1998bf9 in QMetaMethod::invoke (this=0x7fff87069810, object=0x3c835c0, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f2ee199a306 in QMetaObject::invokeMethod (obj=0x3c835c0, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f2eda2a57c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f2ec68f91bb in StatusNotifierItemSource::contextMenu (this=0x3c3e590, x=1157, y=753) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f2ec68ff2d8 in StatusNotifierItemJob::start (this=0x45280d0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f2ee3ee0b21 in Plasma::ServiceJob::qt_metacall (this=0x45280d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f2ec68fdcc0 in StatusNotifierItemJob::qt_metacall (this=0x65646b3a3a6772af, _c=79001408, _id=0, _a=0x4b57730) at ./statusnotifieritemjob.moc:70
#25 0x00007f2ee19a1bde in QObject::event (this=0x45280d0, e=0x65646b3a3a6772af) at kernel/qobject.cpp:1219
#26 0x00007f2ee0ad9fdc in QApplicationPrivate::notify_helper (this=0x1ca5140, receiver=0x45280d0, e=0x44e30f0) at kernel/qapplication.cpp:4396
#27 0x00007f2ee0adfaed in QApplication::notify (this=0x1c905f0, receiver=0x45280d0, e=0x44e30f0) at kernel/qapplication.cpp:4277
#28 0x00007f2ee262b156 in KApplication::notify (this=0x1c905f0, receiver=0x45280d0, event=0x44e30f0) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f2ee198fcdc in QCoreApplication::notifyInternal (this=0x1c905f0, receiver=0x45280d0, event=0x44e30f0) at kernel/qcoreapplication.cpp:732
#30 0x00007f2ee1992c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1c75560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1c75560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f2ee19bc653 in sendPostedEvents (s=0x1ca87e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x1ca87e0) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f2ed8f81342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f2ed8f852a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f2ed8f8545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f2ee19bc193 in QEventDispatcherGlib::processEvents (this=0x1c75070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f2ee0b8ca4e in QGuiEventDispatcherGlib::processEvents (this=0x65646b3a3a6772af, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f2ee198ea02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f2ee198edec in QEventLoop::exec (this=0x7fff8706aaa0, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f2ee1992ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f2ee45eaa56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f2ee424bd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff8706ae68) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 254004, bug 250041, bug 249361, bug 242629.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-10-13 11:30:45 UTC

*** This bug has been marked as a duplicate of bug 241562 ***