Bug 254004 - Plasma-Desktop Crashed after click on "Notification"
Summary: Plasma-Desktop Crashed after click on "Notification"
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-12 20:57 UTC by marko.gabriel.cz
Modified: 2010-10-13 11:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marko.gabriel.cz 2010-10-12 20:57:19 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: After update of kernel on Ubuntu 10.10 system notified my, that some upgrade was done. When I clicked on Notifications, Plasma suddenly crashed.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f1720 (LWP 1583))]

Thread 3 (Thread 0xaeaa4b70 (LWP 1586)):
#0  0x00d52e36 in clock_gettime () from /lib/librt.so.1
#1  0x013ec50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x014c36e5 in QTimerInfoList::updateCurrentTime (this=0x8d8a2bc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x014c372a in QTimerInfoList::timerWait (this=0x8d8a2bc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x014c17a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaeaa40ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x014c183d in timerSourcePrepare (source=0x0, timeout=0xd56ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x05c5fe6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x05c60279 in ?? () from /lib/libglib-2.0.so.0
#9  0x05c60848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x014c159f in QEventDispatcherGlib::processEvents (this=0x8d58f40, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x01491609 in QEventLoop::processEvents (this=0xaeaa4280, flags=) at kernel/qeventloop.cpp:149
#12 0x01491a8a in QEventLoop::exec (this=0xaeaa4280, flags=...) at kernel/qeventloop.cpp:201
#13 0x0138db7e in QThread::exec (this=0x8d88ca8) at thread/qthread.cpp:490
#14 0x0147035b in QInotifyFileSystemWatcherEngine::run (this=0x8d88ca8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x01390df9 in QThreadPrivate::start (arg=0x8d88ca8) at thread/qthread_unix.cpp:266
#16 0x00626cc9 in start_thread () from /lib/libpthread.so.0
#17 0x00e2b6ae in clone () from /lib/libc.so.6

Thread 2 (Thread 0xada9ab70 (LWP 1631)):
#0  0x00b43416 in __kernel_vsyscall ()
#1  0x0062b4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00e38dad in pthread_cond_wait () from /lib/libc.so.6
#3  0x022d13a5 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x022d1481 in ?? () from /usr/lib/libQtWebKit.so.4
#5  0x00626cc9 in start_thread () from /lib/libpthread.so.0
#6  0x00e2b6ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb76f1720 (LWP 1583)):
[KCrash Handler]
#7  QMutex::lock (this=0x2d) at thread/qmutex.cpp:151
#8  0x01495724 in QCoreApplication::postEvent (receiver=0x93fab70, event=0x92db4d0, priority=0) at kernel/qcoreapplication.cpp:1141
#9  0x01495aac in QCoreApplication::postEvent (receiver=0x93fab70, event=0x92db4d0) at kernel/qcoreapplication.cpp:1094
#10 0x014a42c4 in QObject::deleteLater (this=0x93fab70) at kernel/qobject.cpp:2131
#11 0x04b96c1c in KJob::emitResult (this=0x93fab70) at ../../kdecore/jobs/kjob.cpp:315
#12 0x009125a7 in Plasma::ServiceJob::setResult (this=0x93fab70, result=...) at ../../plasma/servicejob.cpp:80
#13 0x08389d6d in StatusNotifierItemJob::contextMenuReady (this=0x93fab70, menu=0x94687b8) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#14 0x08389ded in StatusNotifierItemJob::qt_metacall (this=0x93fab70, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfafdd28) at ./statusnotifieritemjob.moc:75
#15 0x014988ca in QMetaObject::metacall (object=0x93fab70, cl=155167600, idx=27, argv=0xbfafdd28) at kernel/qmetaobject.cpp:237
#16 0x014ab6ad in QMetaObject::activate (sender=0x93a52c0, m=0x8390c40, local_signal_index=0, argv=0x94b6f30) at kernel/qobject.cpp:3280
#17 0x083830a3 in StatusNotifierItemSource::contextMenuReady (this=0x93a52c0, _t1=0x94687b8) at ./statusnotifieritemsource.moc:109
#18 0x083832b1 in StatusNotifierItemSource::contextMenuReady (this=0x93a52c0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#19 0x08388803 in StatusNotifierItemSource::qt_metacall (this=0x93a52c0, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfafde4c) at ./statusnotifieritemsource.moc:90
#20 0x014988ca in QMetaObject::metacall (object=0x93a52c0, cl=155167600, idx=11, argv=0xbfafde4c) at kernel/qmetaobject.cpp:237
#21 0x014ab6ad in QMetaObject::activate (sender=0x90b2410, m=0xd4dd84, local_signal_index=0, argv=0x94b6f30) at kernel/qobject.cpp:3280
#22 0x00d38567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#23 0x00d3dcdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#24 0x00d3ef2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#25 0x014988ca in QMetaObject::metacall (object=0x90b2410, cl=155167600, idx=12, argv=0xbfafe08c) at kernel/qmetaobject.cpp:237
#26 0x014ab6ad in QMetaObject::activate (sender=0x94687b8, m=0x338efe8, local_signal_index=0, argv=0x94b6f30) at kernel/qobject.cpp:3280
#27 0x02ecdee7 in QMenu::aboutToShow (this=0x94687b8) at .moc/release-shared/moc_qmenu.cpp:151
#28 0x02ed5193 in QMenu::qt_metacall (this=0x94687b8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfafe1dc) at .moc/release-shared/moc_qmenu.cpp:97
#29 0x014988ca in QMetaObject::metacall (object=0x94687b8, cl=155167600, idx=27, argv=0xbfafe1dc) at kernel/qmetaobject.cpp:237
#30 0x0149c352 in QMetaMethod::invoke (this=0xbfafe36c, object=0x94687b8, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#31 0x0149da1f in QMetaObject::invokeMethod (obj=0x94687b8, member=0xd443e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#32 0x00d3893e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#33 0x083846ef in StatusNotifierItemSource::contextMenu (this=0x93a52c0, x=1121, y=759) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#34 0x0838b33e in StatusNotifierItemJob::start (this=0x93fab70) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#35 0x00912423 in Plasma::ServiceJobPrivate::slotStart (this=0x93fab88) at ../../plasma/servicejob.cpp:37
#36 0x009124f4 in Plasma::ServiceJob::qt_metacall (this=0x93fab70, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x8e6f2c8) at ./servicejob.moc:72
#37 0x08389dca in StatusNotifierItemJob::qt_metacall (this=0x93fab70, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x8e6f2c8) at ./statusnotifieritemjob.moc:70
#38 0x014988ca in QMetaObject::metacall (object=0x93fab70, cl=155167600, idx=26, argv=0x8e6f2c8) at kernel/qmetaobject.cpp:237
#39 0x014a3df6 in QMetaCallEvent::placeMetaCall (this=0x8ad6378, object=0x93fab70) at kernel/qobject.cpp:534
#40 0x014a56a2 in QObject::event (this=0x93fab70, e=0x4) at kernel/qobject.cpp:1219
#41 0x02a09fdc in QApplicationPrivate::notify_helper (this=0x87cf930, receiver=0x93fab70, e=0x8ad6378) at kernel/qapplication.cpp:4396
#42 0x02a1004e in QApplication::notify (this=0x87c45f0, receiver=0x93fab70, e=0x8ad6378) at kernel/qapplication.cpp:3798
#43 0x0115068a in KApplication::notify (this=0x87c45f0, receiver=0x93fab70, event=0x8ad6378) at ../../kdeui/kernel/kapplication.cpp:310
#44 0x01492b3b in QCoreApplication::notifyInternal (this=0x87c45f0, receiver=0x93fab70, event=0x8ad6378) at kernel/qcoreapplication.cpp:732
#45 0x01495d8b in sendEvent (receiver=0x0, event_type=0, data=0x87ae028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x87ae028) at kernel/qcoreapplication.cpp:1373
#47 0x01495f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#48 0x014c1a74 in sendPostedEvents (s=0x87d1d10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#49 postEventSourceDispatch (s=0x87d1d10) at kernel/qeventdispatcher_glib.cpp:277
#50 0x05c5c855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#51 0x05c60668 in ?? () from /lib/libglib-2.0.so.0
#52 0x05c60848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#53 0x014c1565 in QEventDispatcherGlib::processEvents (this=0x87adce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#54 0x02acbbe5 in QGuiEventDispatcherGlib::processEvents (this=0x87adce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x01491609 in QEventLoop::processEvents (this=0xbfaff144, flags=) at kernel/qeventloop.cpp:149
#56 0x01491a8a in QEventLoop::exec (this=0xbfaff144, flags=...) at kernel/qeventloop.cpp:201
#57 0x0149600f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#58 0x02a08e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#59 0x00cf386e in kdemain (argc=1, argv=0xbfaff354) at ../../../../plasma/desktop/shell/main.cpp:118
#60 0x080485bb in main (argc=1, argv=0xbfaff354) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 252098, bug 249361, bug 247792, bug 247467, bug 246493.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-10-13 11:30:41 UTC

*** This bug has been marked as a duplicate of bug 241562 ***