Bug 253220 - AddresseeLineEdit: contacts from autocompletion cannot be selected with mouse, only via keyboard
Summary: AddresseeLineEdit: contacts from autocompletion cannot be selected with mouse...
Status: VERIFIED FIXED
Alias: None
Product: KOrganizer Mobile
Classification: Unclassified
Component: calendar (show other bugs)
Version: unspecified
Platform: Maemo 5 Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: komo3
: 263837 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-04 13:21 UTC by Felix Wolfsteller
Modified: 2011-02-15 18:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
address selection UI (90.64 KB, image/png)
2010-10-04 13:21 UTC, Felix Wolfsteller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Wolfsteller 2010-10-04 13:21:55 UTC
Created attachment 52214 [details]
address selection UI

When adding a participant to an appointment in version 4:4.5~20101001.1181693-1maemo4.1181469 for kolab-managed adresses, an "LDAP" selection dialog is shown.

If I select on of the displayed entries, its value (email address) will unfortunately not been filled into the respective slot.

I expected to be able to select an email address from there.
Comment 1 Tobias Koenig 2011-01-21 12:26:28 UTC
*** Bug 263837 has been marked as a duplicate of this bug. ***
Comment 2 Tobias Koenig 2011-01-21 12:38:05 UTC
SVN commit 1216103 by tokoe:

Fix mouse selection for embedded KCompletionBox

If a KLineEdit is embedded in QML, the completion box
should bypass the graphics proxy widget, otherwise it won't
receive mouse events.

BUG: 253220


 M  +1 -1      kcompletionbox.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216103
Comment 3 Andre Heinecke 2011-02-15 18:30:45 UTC
I can verify that this works now on WinCE