Bug 222190 - keditbookmarks crashed when trying to move a bookmark on the upper level (above "Bookmark")
Summary: keditbookmarks crashed when trying to move a bookmark on the upper level (abo...
Status: RESOLVED DUPLICATE of bug 181856
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 09:38 UTC by Michel BERNARD
Modified: 2010-01-11 15:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel BERNARD 2010-01-11 09:38:21 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.2 (KDE 4.3.2)
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.6-desktop586-1mnb i686
Distribution: "Mandriva Linux 2010.0"

What I was doing when the application crashed:
That happened when I tried to drag'n'drop a bookmark which referenced a remote resource (in KDRC, a RDP connection to a remote server).

I configured a RDP connection, which appeared in the "History" folder of kde bookmarks. I tried to dragndrop the bookmark in the upper folder and the app crashed when I released the left button of the mouse.

 -- Backtrace:
Application: Éditeur de signet (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xb70f3198 in QDomNode::QDomNode () from /usr/lib/libQtXml.so.4
#7  0xb70f46d3 in QDomElement::QDomElement () from /usr/lib/libQtXml.so.4
#8  0xb76b7f9d in TreeItem::bookmark (this=0x0) at /usr/include/kbookmark.h:34
#9  0xb76b55f7 in KBookmarkModel::dropMimeData (this=0x8dceaf0, data=0x8de9db0, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfb95d94)
    at /usr/src/debug/kdebase-4.3.2/apps/keditbookmarks/bookmarkmodel.cpp:341
#10 0xb76b79be in BookmarkFolderViewFilterModel::dropMimeData (this=0x8d30cc8, data=0x8de9db0, action=Qt::CopyAction, row=1, column=0, parent=@0xbfb95e28)
    at /usr/src/debug/kdebase-4.3.2/apps/keditbookmarks/bookmarklistview.cpp:184
#11 0xb64ac72a in QAbstractItemView::dropEvent () from /usr/lib/libQtGui.so.4
#12 0xb5fa52a5 in QWidget::event () from /usr/lib/libQtGui.so.4
#13 0xb6361c95 in QFrame::event () from /usr/lib/libQtGui.so.4
#14 0xb640216c in QAbstractScrollArea::viewportEvent () from /usr/lib/libQtGui.so.4
#15 0xb64b9a94 in QAbstractItemView::viewportEvent () from /usr/lib/libQtGui.so.4
#16 0xb64f5fe0 in QTreeView::viewportEvent () from /usr/lib/libQtGui.so.4
#17 0xb64047c6 in ?? () from /usr/lib/libQtGui.so.4
#18 0xb6927dee in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib/libQtCore.so.4
#19 0xb5f4e660 in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#20 0xb5f565d0 in QApplication::notify () from /usr/lib/libQtGui.so.4
#21 0xb6ed39e1 in KApplication::notify () from /usr/lib/libkdeui.so.5
#22 0xb6928c0e in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#23 0xb5fd4eb3 in ?? () from /usr/lib/libQtGui.so.4
#24 0xb5fd9dd2 in QDragManager::drop () from /usr/lib/libQtGui.so.4
#25 0xb5fd9fe2 in QDragManager::eventFilter () from /usr/lib/libQtGui.so.4
#26 0xb6927eab in QCoreApplicationPrivate::sendThroughApplicationEventFilters () from /usr/lib/libQtCore.so.4
#27 0xb5f4e60a in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#28 0xb5f5693b in QApplication::notify () from /usr/lib/libQtGui.so.4
#29 0xb6ed39e1 in KApplication::notify () from /usr/lib/libkdeui.so.5
#30 0xb6928c0e in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#31 0xb5f5595c in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#32 0xb5fc657a in ?? () from /usr/lib/libQtGui.so.4
#33 0xb5fc5aee in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#34 0xb5ff0d88 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb5519b92 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb551d468 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb551d58e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb69548f1 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#39 0xb5ff04ba in ?? () from /usr/lib/libQtGui.so.4
#40 0xb692726d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#41 0xb69276b9 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#42 0xb5fd9913 in QDragManager::drag () from /usr/lib/libQtGui.so.4
#43 0xb5f62201 in QDrag::exec () from /usr/lib/libQtGui.so.4
#44 0xb64b79b5 in QAbstractItemView::startDrag () from /usr/lib/libQtGui.so.4
#45 0xb64b46ba in QAbstractItemView::mouseMoveEvent () from /usr/lib/libQtGui.so.4
#46 0xb64f5dac in QTreeView::mouseMoveEvent () from /usr/lib/libQtGui.so.4
#47 0xb5fa573f in QWidget::event () from /usr/lib/libQtGui.so.4
#48 0xb6361c95 in QFrame::event () from /usr/lib/libQtGui.so.4
#49 0xb640216c in QAbstractScrollArea::viewportEvent () from /usr/lib/libQtGui.so.4
#50 0xb64b9a94 in QAbstractItemView::viewportEvent () from /usr/lib/libQtGui.so.4
#51 0xb64f5fe0 in QTreeView::viewportEvent () from /usr/lib/libQtGui.so.4
#52 0xb64047c6 in ?? () from /usr/lib/libQtGui.so.4
#53 0xb6927dee in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib/libQtCore.so.4
#54 0xb5f4e660 in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#55 0xb5f5693b in QApplication::notify () from /usr/lib/libQtGui.so.4
#56 0xb6ed39e1 in KApplication::notify () from /usr/lib/libkdeui.so.5
#57 0xb6928c0e in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#58 0xb5f5595c in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#59 0xb5fc657a in ?? () from /usr/lib/libQtGui.so.4
#60 0xb5fc5aee in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#61 0xb5ff0d88 in ?? () from /usr/lib/libQtGui.so.4
#62 0xb5519b92 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#63 0xb551d468 in ?? () from /usr/lib/libglib-2.0.so.0
#64 0xb551d58e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#65 0xb69548f1 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#66 0xb5ff04ba in ?? () from /usr/lib/libQtGui.so.4
#67 0xb692726d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#68 0xb69276b9 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#69 0xb6929b50 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#70 0xb5f4e504 in QApplication::exec () from /usr/lib/libQtGui.so.4
#71 0xb768fd9f in kdemain (argc=5, argv=0xbfb9ace4) at /usr/src/debug/kdebase-4.3.2/apps/keditbookmarks/main.cpp:203
#72 0x0804857b in main (argc=5, argv=0xbfb9ace4) at /usr/src/debug/kdebase-4.3.2/build/apps/keditbookmarks/keditbookmarks_dummy.cpp:3

This bug may be a duplicate of or related to bug 213046

Reported using DrKonqi
Comment 1 Christoph Feck 2010-01-11 15:39:17 UTC

*** This bug has been marked as a duplicate of bug 181856 ***