Bug 251418 - Nepomuk crashes on startup (KDE 4.5.68)
Summary: Nepomuk crashes on startup (KDE 4.5.68)
Status: RESOLVED DUPLICATE of bug 252766
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-16 09:49 UTC by Olivier LAHAYE
Modified: 2011-01-14 14:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.62 KB, text/plain)
2010-09-20 08:58 UTC, Olivier LAHAYE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier LAHAYE 2010-09-16 09:49:08 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.68 (4.6 >= 20100912)
Qt Version: 4.7.0
Operating System: Linux 2.6.35.4-desktop-1mnb x86_64
Distribution: "Mandriva Linux 2010.1"

-- Information about the crash:
- What I was doing when the application crashed:
Nepomuk crashed just after logging in.
I've selected a possible duplicate, but this possible duplicate is marked as fixed in an earlier version while I'm still experiencing the crash in the 4.5.68 version.....

The crash can be reproduced every time.

-- Backtrace:
Application: Jeton du service Nepomuk (nepomukservicestub), signal: Segmentation fault
strcmp () at ../sysdeps/x86_64/multiarch/../strcmp.S:70
	in ../sysdeps/x86_64/multiarch/../strcmp.S
[Current thread is 1 (Thread 0x7ff1ca4b8720 (LWP 5754))]

Thread 3 (Thread 0x7ff1ba2aa710 (LWP 7848)):
#0  0x00007ff1c9c4d0bc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff1c9ed0d7b in wait (this=<value optimized out>, mutex=0x1fdd9f0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1fdd9f0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff1ba8f8a0d in Nepomuk::IndexFeeder::run (this=0x1fdd9d0) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexfeeder.cpp:186
#4  0x00007ff1c9ed068e in QThreadPrivate::start (arg=0x1fdd9d0) at thread/qthread_unix.cpp:266
#5  0x00007ff1c9c48a5d in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff1c79ab15d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff1b13a2710 (LWP 7853)):
[KCrash Handler]
#6  0x00007ff1c9ecc11c in QMutex::lock (this=0x1f35db8) at thread/qmutex.cpp:151
#7  0x00007ff1c48e428c in QMutexLocker (this=0x7ff1ac02f760) at /usr/lib/qt4/include/QtCore/qmutex.h:102
#8  Soprano::Error::ErrorCache::clearError (this=0x7ff1ac02f760) at /usr/src/debug/soprano-2.5.62/soprano/error.cpp:238
#9  0x00007ff1c48e47e0 in Soprano::Error::ErrorCache::setError (this=0x7ff1ac02f760, error=...) at /usr/src/debug/soprano-2.5.62/soprano/error.cpp:225
#10 0x00007ff1c467b825 in Soprano::Client::DBusModel::addStatement (this=0x7ff1ac02f750, statement=<value optimized out>) at /usr/src/debug/soprano-2.5.62/client/dbus/dbusmodel.cpp:82
#11 0x00007ff1c8c0d132 in Nepomuk::MainModel::addStatement (this=0x1f82f00, statement=...) at /usr/src/debug/kdelibs-4.5.68svn1174542/nepomuk/core/nepomukmainmodel.cpp:252
#12 0x00007ff1c48f263e in Soprano::FilterModel::addStatement (this=0x1f837a0, statement=...) at /usr/src/debug/soprano-2.5.62/soprano/filtermodel.cpp:92
#13 0x00007ff1c8c0ab41 in Nepomuk::ResourceFilterModel::addStatement (this=0x1f837a0, statement=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.68svn1174542/nepomuk/core/resourcefiltermodel.cpp:71
#14 0x00007ff1c48dae8e in Soprano::Model::addStatement (this=0x1f837a0, subject=<value optimized out>, predicate=<value optimized out>, object=<value optimized out>, context=<value optimized out>)
    at /usr/src/debug/soprano-2.5.62/soprano/model.cpp:135
#15 0x00007ff1ba8f7662 in Nepomuk::IndexFeeder::generateGraph (this=<value optimized out>, resourceUri=...)
    at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexfeeder.cpp:269
#16 0x00007ff1ba8f7ee5 in Nepomuk::IndexFeeder::addToModel (this=<value optimized out>, rs=...) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexfeeder.cpp:144
#17 0x00007ff1ba8f882d in Nepomuk::IndexFeeder::handleRequest (this=0x1fdd9d0, request=...) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexfeeder.cpp:246
#18 0x00007ff1ba8f88a8 in Nepomuk::IndexFeeder::end (this=0x1fdd9d0, forceCommit=true) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexfeeder.cpp:107
#19 0x00007ff1ba8f60df in Nepomuk::StrigiIndexWriter::finishAnalysis (this=0x1fbed80, idx=0x7ff1b13a1980)
    at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexwriter.cpp:572
#20 0x00007ff1c1691552 in Strigi::AnalysisResult::Private::write (this=0x7ff1ac02ef90) at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:214
#21 0x00007ff1c169169e in Strigi::AnalysisResult::~AnalysisResult (this=0x7ff1b13a1980, __in_chrg=<value optimized out>) at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:183
#22 0x00007ff1ba8fbeda in Nepomuk::Indexer::indexFile (this=<value optimized out>, info=<value optimized out>)
    at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/nepomukindexer.cpp:127
#23 0x00007ff1ba8ec95e in Nepomuk::IndexScheduler::analyzeDir (this=0x1f925a0, dir=..., flags=...) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/indexscheduler.cpp:303
#24 0x00007ff1ba8ee6cf in Nepomuk::IndexScheduler::run (this=0x1f925a0) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/indexscheduler.cpp:271
#25 0x00007ff1c9ed068e in QThreadPrivate::start (arg=0x1f925a0) at thread/qthread_unix.cpp:266
#26 0x00007ff1c9c48a5d in start_thread () from /lib64/libpthread.so.0
#27 0x00007ff1c79ab15d in clone () from /lib64/libc.so.6
#28 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff1ca4b8720 (LWP 5754)):
#0  strcmp () at ../sysdeps/x86_64/multiarch/../strcmp.S:70
#1  0x00007ff1ca2f69ac in check_match (sym=0x7ff1c95211c8) at dl-lookup.c:150
#2  0x00007ff1ca2f7185 in do_lookup_x (new_hash=3826238196, old_hash=0x7fff5f733e68, ref=<value optimized out>, result=<value optimized out>, scope=<value optimized out>, i=4, flags=5, skip=0x0, 
    undef_map=0x1f0ef50) at dl-lookup.c:250
#3  0x00007ff1ca2f74fb in _dl_lookup_symbol_x (undef_name=<value optimized out>, undef_map=0x1f0ef50, ref=0x7fff5f733ec8, symbol_scope=<value optimized out>, version=0x0, 
    type_class=<value optimized out>, flags=5, skip_map=0x0) at dl-lookup.c:721
#4  0x00007ff1ca2fb381 in _dl_fixup (l=<value optimized out>, reloc_arg=<value optimized out>) at ../elf/dl-runtime.c:118
#5  0x00007ff1ca3014e5 in _dl_runtime_resolve () at ../sysdeps/x86_64/dl-trampoline.S:41
#6  0x00007ff1ba8e9119 in factory::~factory (this=0x1f5d260, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/services/strigi/strigiservice.cpp:293
#7  0x00007ff1c9fd2515 in QObjectCleanupHandler::clear (this=0x1f85c80) at kernel/qobjectcleanuphandler.cpp:140
#8  0x00007ff1c9fd254b in QObjectCleanupHandler::~QObjectCleanupHandler (this=0x1f85c80, __in_chrg=<value optimized out>) at kernel/qobjectcleanuphandler.cpp:86
#9  0x00007ff1c9fd2599 in QObjectCleanupHandler::~QObjectCleanupHandler (this=0x1f85c80, __in_chrg=<value optimized out>) at kernel/qobjectcleanuphandler.cpp:87
#10 0x00007ff1c7904792 in __run_exit_handlers () from /lib64/libc.so.6
#11 0x00007ff1c79047e5 in exit () from /lib64/libc.so.6
#12 0x00007ff1c8162f68 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:745
#13 0x00007ff1c90924f8 in KApplication::xioErrhandler (this=0x7fff5f7343d0, dpy=0x1e5b440) at /usr/src/debug/kdelibs-4.5.68svn1174542/kdeui/kernel/kapplication.cpp:416
#14 0x00007ff1c56646ae in _XIOError (dpy=0x1e5b440) at XlibInt.c:3140
#15 0x00007ff1c566cded in _XEventsQueued (dpy=0x1e5b440, mode=<value optimized out>) at xcb_io.c:306
#16 0x00007ff1c56552ab in XEventsQueued (dpy=0x1e5b440, mode=2) at Pending.c:43
#17 0x00007ff1c819b5f7 in x11EventSourcePrepare (s=0x1e592c0, timeout=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:77
#18 0x00007ff1c6e038bf in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#19 0x00007ff1c6e047a9 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007ff1c6e04e4d in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007ff1c9fe485f in QEventDispatcherGlib::processEvents (this=0x1e3df90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#22 0x00007ff1c819b74e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007ff1c9fb8ad2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007ff1c9fb8d1c in QEventLoop::exec (this=0x7fff5f734250, flags=...) at kernel/qeventloop.cpp:201
#25 0x00007ff1c9fbd19b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#26 0x0000000000404094 in main (argc=1601389416, argv=0x7fff5f734828) at /usr/src/debug/kdebase-runtime-4.5.68svn1174542/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 246110.

Possible duplicates by query: bug 246110.

Reported using DrKonqi
Comment 1 Olivier LAHAYE 2010-09-20 08:58:52 UTC
Created attachment 51816 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.68 (4.6 >= 20100912) using Qt 4.7.0

- What I was doing when the application crashed:
Nepomuk crashed just after logging in. Not sure, but maybe just after session restoration finished.

-- Backtrace (Reduced):
#6  0x00007f2960c8011c in QMutex::lock (this=0x100e688) at thread/qmutex.cpp:151
#7  0x00007f295b69828c in QMutexLocker (this=0x7f29400e76a0) at /usr/lib/qt4/include/QtCore/qmutex.h:102
#8  Soprano::Error::ErrorCache::clearError (this=0x7f29400e76a0) at /usr/src/debug/soprano-2.5.62/soprano/error.cpp:238
#9  0x00007f295b6987e0 in Soprano::Error::ErrorCache::setError (this=0x7f29400e76a0, error=...) at /usr/src/debug/soprano-2.5.62/soprano/error.cpp:225
#10 0x00007f295b42f311 in Soprano::Client::DBusModel::executeQuery (this=0x7f29400e7690, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.62/client/dbus/dbusmodel.cpp:108
Comment 2 Dario Andres 2010-11-18 19:04:01 UTC
[Comment from a bug triager]
This bug may be related to bug 245266. Thanks
Comment 3 Sebastian Trueg 2011-01-14 14:05:28 UTC

*** This bug has been marked as a duplicate of bug 252766 ***