Bug 251205 - Using Enter to accept suggestions for completing a command
Summary: Using Enter to accept suggestions for completing a command
Status: RESOLVED DUPLICATE of bug 413709
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
Depends on:
Reported: 2010-09-14 12:46 UTC by angel.tsankov
Modified: 2020-07-08 11:36 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description angel.tsankov 2010-09-14 12:46:22 UTC
Version:           unspecified (using KDE 4.4.5) 
OS:                Linux

I think that it is more convenient to use Enter to accept completion suggestions (and execute them) rather than using End to accept the suggestion and Enter to execute it.

Reproducible: Always
Comment 1 Andreas 2012-04-20 20:06:36 UTC
I agree. This used to work in kDE 3. Shift+Enter, Alt+Enter would also be alternatives. Often finding the End key and pressing Enter takes longer than typing the complete word.
Comment 2 Antonios Pazarlis 2012-05-11 08:09:42 UTC
Tbh it could be even by pressing the left arrow ones and then enter. With pressing the left arrow one time it seems to understand that it should open the first option in the following list that suggests. But if have to only press enter to complete the suggestion and enter again to lunch it would be faster, that's for sure.
Comment 3 Diggory Hardy 2012-11-09 09:44:08 UTC
Did this somehow change in 4.9(.3)?

Previously I would press Alt+F2, type kdeve and press enter to launch kdevelop. Now krunner finds a list of sessions and I have to choose one (up/down arrow or click) before I can launch with enter (otherwise enter does nothing); previously it would just launch the top one.

Same with a script of mine: I execute "disp 2" to switch to display 2, and previously I only had to press Alt+F2, type that and press enter. Now it seems I have to click or use up/down arrows to select before pressing enter.

This bug report is sufficiently unclear that I think this falls under the same umbrella; just wanted to include my 2ยข.
Comment 4 Christoph Feck 2012-11-09 10:29:11 UTC
Diggory, see bug 309787.
Comment 5 Antonios Pazarlis 2012-11-09 10:52:01 UTC
I'm using opensuse 12.2 with kde 4.8.5 and seems that when i press alt+f2, as i start typing i can see the suggestions that appear and if i press enter the first one in the list is being lunched.For example, if i type "moni" the system monitor appears in the list and i have just to hit enter to lunch it without having to press end to complete the name of the application or the need to use arrows. Otherwise hitting the tab button can always scroll through the other options and obviously hit enter to launch.
Comment 6 Diggory Hardy 2012-11-09 11:00:24 UTC
Thanks Christoph, missed that.

That's what used to happen for me too, Antonios. So should this report be closed?
Comment 7 Antonios Pazarlis 2012-11-09 18:12:26 UTC
Diggory Hardy, as there should not be any difference i suppose from distro to distro for this, because works in the same way both on my openSUSE and chakra linux, i think that now it works as  Angel Tsankov wanted to be and as it was in the past. So i suppose it could be considered solved.

As for the version 4.9.3 reported in the <a href="https://bugs.kde.org/show_bug.cgi?id=309787">bug 309787</a>  posted above by Christoph Feck don't know if it's always solved. I must check in my chakra machine.
Comment 8 Reza 2013-01-17 11:14:27 UTC
It might be related to this:
https://bugs.kde.org/show_bug.cgi?id=254365 which alread fixed 
commit 3894923 in KDE/4.10 and master branches of kde-workspace.

could you please try with latest 4.10 or master?
Comment 9 Alexander Lohnau 2020-07-08 11:36:23 UTC
We have discussed alternatives in this bug report, so I am marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 413709 ***