Bug 250878 - Plamsa crash when leaving Kopete
Summary: Plamsa crash when leaving Kopete
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-11 15:16 UTC by bedwyr
Modified: 2010-09-11 20:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bedwyr 2010-09-11 15:16:04 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kubuntu 10.04 KDE 4.4.2
At the moment I leave Kopete, Plasma crashes.

 -- Backtrace:
Application: Espace de travail Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa073028760 (LWP 1616))]

Thread 2 (Thread 0x7fa04a2b3710 (LWP 1619)):
#0  0x00007fa070014f83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa06c9d94a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fa06c9d98fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fa07161d566 in QEventDispatcherGlib::processEvents (this=0x37d9090, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fa0715f2992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fa0715f2d6c in QEventLoop::exec (this=0x7fa04a2b2db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fa0714fcd59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fa0715d3178 in QInotifyFileSystemWatcherEngine::run (this=0x37d55c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa0714ff775 in QThreadPrivate::start (arg=0x37d55c0) at thread/qthread_unix.cpp:248
#9  0x00007fa07126f9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fa0700216fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa073028760 (LWP 1616)):
[KCrash Handler]
#5  0x00007fa071af7027 in QString (this=0x100000027, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=0x100000027, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x00007fa071b02d98 in KIconLoader::loadIcon (this=0x46acf00, _name=..., group=<value optimized out>, size=22, state=<value optimized out>, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x00007fa071afb52c in KIconEngine::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:80
#9  0x00007fa07084226c in QIcon::actualSize (this=<value optimized out>, size=..., mode=QIcon::Normal, state=QIcon::On) at image/qicon.cpp:700
#10 0x00007fa06a0a7497 in Plasma::IconWidgetPrivate::decoration (this=0x4771450, option=<value optimized out>, useHoverEffect=true, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#11 0x00007fa06a0a8afc in Plasma::IconWidget::paint (this=0x46edf50, painter=0x7fffdb333210, option=0x2306e28, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1013
#12 0x00007fa070d9c81a in _q_paintItem (item=<value optimized out>, painter=0x7fffdb333210, option=0x2306e28, widget=0x0, useWindowOpacity=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4243
#13 0x00007fa070d9caac in _q_paintIntoCache (pix=0x7fffdb3338a0, item=<value optimized out>, pixmapExposed=..., itemToPixmap=<value optimized out>, renderHints=)
    at graphicsview/qgraphicsscene.cpp:4281
#14 0x00007fa070db0d33 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=0x46edf60, painter=0x7fffdb335810, option=0x2306e28, widget=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4574
#15 0x00007fa070db1625 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x46edf60, painter=0x7fffdb335810, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x392b2a0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4827
#16 0x00007fa070db2272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x46edf60, painter=0x7fffdb335810, viewTransform=0x7fffdb3355c0, exposedRegion=0x375ec30, 
    widget=0x392b2a0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#17 0x00007fa070db16c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x2da7240, painter=0x7fffdb335810, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x392b2a0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#18 0x00007fa070db2272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x2da7240, painter=0x7fffdb335810, viewTransform=0x7fffdb3355c0, exposedRegion=0x375ec30, 
    widget=0x392b2a0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#19 0x00007fa070db16c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x2a8bb70, painter=0x7fffdb335810, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x392b2a0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#20 0x00007fa070db2272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x2a8bb70, painter=0x7fffdb335810, viewTransform=0x7fffdb3355c0, exposedRegion=0x375ec30, 
    widget=0x392b2a0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#21 0x00007fa070db16c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x28147e0, painter=0x7fffdb335810, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x392b2a0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#22 0x00007fa070db2272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x28147e0, painter=0x7fffdb335810, viewTransform=0x7fffdb3355c0, exposedRegion=0x375ec30, 
    widget=0x392b2a0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#23 0x00007fa070db2c34 in QGraphicsScenePrivate::drawItems (this=0x2306bd0, painter=0x7fffdb335810, viewTransform=0x7fffdb3355c0, exposedRegion=0x375ec30, widget=0x392b2a0)
    at graphicsview/qgraphicsscene.cpp:4619
#24 0x00007fa070dd2465 in QGraphicsView::paintEvent (this=0x39502b0, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3393
#25 0x00007fa06656eb09 in PanelView::paintEvent (this=0x7fffdb332880, event=0x100000027) at ../../../../plasma/desktop/shell/panelview.cpp:1300
#26 0x00007fa0707e6162 in QWidget::event (this=0x39502b0, event=0x7fffdb336150) at kernel/qwidget.cpp:8144
#27 0x00007fa070b8d4e6 in QFrame::event (this=0x39502b0, e=0x7fffdb336150) at widgets/qframe.cpp:557
#28 0x00007fa070dcef0b in QGraphicsView::viewportEvent (this=0x39502b0, event=0x7fffdb336150) at graphicsview/qgraphicsview.cpp:2787
#29 0x00007fa0715f3487 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x392b2a0, event=0x7fffdb336150) at kernel/qcoreapplication.cpp:819
#30 0x00007fa0707901fc in QApplicationPrivate::notify_helper (this=0x22654b0, receiver=0x392b2a0, e=0x7fffdb336150) at kernel/qapplication.cpp:4296
#31 0x00007fa0707966fb in QApplication::notify (this=0x22474c0, receiver=0x392b2a0, e=0x7fffdb336150) at kernel/qapplication.cpp:4183
#32 0x00007fa071b3b526 in KApplication::notify (this=0x22474c0, receiver=0x392b2a0, event=0x7fffdb336150) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007fa0715f406c in QCoreApplication::notifyInternal (this=0x22474c0, receiver=0x392b2a0, event=0x7fffdb336150) at kernel/qcoreapplication.cpp:704
#34 0x00007fa0707ee7dd in QCoreApplication::sendSpontaneousEvent (this=0x36a4f10, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x3b06a10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 QWidgetPrivate::drawWidget (this=0x36a4f10, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x3b06a10)
    at kernel/qwidget.cpp:5339
#36 0x00007fa0707ef478 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x3b06a10) at kernel/qwidget.cpp:5452
#37 0x00007fa0707ee53a in QWidgetPrivate::drawWidget (this=0x375e770, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x3b06a10) at kernel/qwidget.cpp:5388
#38 0x00007fa0709a88c5 in QWidgetBackingStore::sync (this=0x3b06a10) at painting/qbackingstore.cpp:1291
#39 0x00007fa0707dfb60 in QWidgetPrivate::syncBackingStore (this=0x375e770) at kernel/qwidget.cpp:1672
#40 0x00007fa0707e6865 in QWidget::event (this=0x39502b0, event=0x4a5bf60) at kernel/qwidget.cpp:8291
#41 0x00007fa070b8d4e6 in QFrame::event (this=0x39502b0, e=0x4a5bf60) at widgets/qframe.cpp:557
#42 0x00007fa070c188ab in QAbstractScrollArea::event (this=0x39502b0, e=0x4a5bf60) at widgets/qabstractscrollarea.cpp:989
#43 0x00007fa066571590 in PanelView::event (this=0x39502b0, event=0x4a5bf60) at ../../../../plasma/desktop/shell/panelview.cpp:1314
#44 0x00007fa07079022c in QApplicationPrivate::notify_helper (this=0x22654b0, receiver=0x39502b0, e=0x4a5bf60) at kernel/qapplication.cpp:4300
#45 0x00007fa0707966fb in QApplication::notify (this=0x22474c0, receiver=0x39502b0, e=0x4a5bf60) at kernel/qapplication.cpp:4183
#46 0x00007fa071b3b526 in KApplication::notify (this=0x22474c0, receiver=0x39502b0, event=0x4a5bf60) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x00007fa0715f406c in QCoreApplication::notifyInternal (this=0x22474c0, receiver=0x39502b0, event=0x4a5bf60) at kernel/qcoreapplication.cpp:704
#48 0x00007fa0715f67e7 in QCoreApplication::sendEvent (receiver=0x39502b0, event_type=<value optimized out>, data=0x21e8860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x39502b0, event_type=<value optimized out>, data=0x21e8860) at kernel/qcoreapplication.cpp:1345
#50 0x00007fa070db9b7a in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x2306bd0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#51 QGraphicsScenePrivate::_q_processDirtyItems (this=0x2306bd0) at graphicsview/qgraphicsscene.cpp:509
#52 0x00007fa070dba102 in QGraphicsScene::qt_metacall (this=0x2306250, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x4a52240) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#53 0x00007fa069ff7b65 in Plasma::Corona::qt_metacall (this=0x7fffdb332880, _c=39, _id=0, _a=0x0) at ./corona.moc:107
#54 0x00007fa066560bd3 in DesktopCorona::qt_metacall (this=0x7fffdb332880, _c=39, _id=0, _a=0x0) at ./desktopcorona.moc:86
#55 0x00007fa071603d49 in QObject::event (this=0x2306250, e=0x4a56600) at kernel/qobject.cpp:1248
#56 0x00007fa070db5d80 in QGraphicsScene::event (this=0x2306250, event=0x4a56600) at graphicsview/qgraphicsscene.cpp:3500
#57 0x00007fa07079022c in QApplicationPrivate::notify_helper (this=0x22654b0, receiver=0x2306250, e=0x4a56600) at kernel/qapplication.cpp:4300
#58 0x00007fa0707966fb in QApplication::notify (this=0x22474c0, receiver=0x2306250, e=0x4a56600) at kernel/qapplication.cpp:4183
#59 0x00007fa071b3b526 in KApplication::notify (this=0x22474c0, receiver=0x2306250, event=0x4a56600) at ../../kdeui/kernel/kapplication.cpp:302
#60 0x00007fa0715f406c in QCoreApplication::notifyInternal (this=0x22474c0, receiver=0x2306250, event=0x4a56600) at kernel/qcoreapplication.cpp:704
#61 0x00007fa0715f67e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x21e8860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x21e8860) at kernel/qcoreapplication.cpp:1345
#63 0x00007fa07161d9d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#65 0x00007fa06c9d58c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#66 0x00007fa06c9d9748 in ?? () from /lib/libglib-2.0.so.0
#67 0x00007fa06c9d98fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#68 0x00007fa07161d513 in QEventDispatcherGlib::processEvents (this=0x2264e70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#69 0x00007fa07084046e in QGuiEventDispatcherGlib::processEvents (this=0x7fffdb332880, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#70 0x00007fa0715f2992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#71 0x00007fa0715f2d6c in QEventLoop::exec (this=0x7fffdb338240, flags=) at kernel/qeventloop.cpp:201
#72 0x00007fa0715f6aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#73 0x00007fa066567fb2 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:112
#74 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#75 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#76 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#77 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 250645, bug 249962, bug 249783, bug 249400, bug 249179.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-09-11 20:45:50 UTC

*** This bug has been marked as a duplicate of bug 226596 ***