Bug 249400 - Plasma crash when starting screen saver
Summary: Plasma crash when starting screen saver
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-29 13:29 UTC by aku.pietikainen
Modified: 2010-09-01 15:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aku.pietikainen 2010-08-29 13:29:51 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Computer was idle and plasma crashed when (presumably) starting screen saver.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f15ebc19760 (LWP 2056))]

Thread 3 (Thread 0x7f15c634f710 (LWP 2059)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f15c634ebe0 in ?? ()
#2  0x00007fff87dff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f15c3121710 (LWP 2432)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15dd6c42a6 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f15dd9a2220) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007f15dd6c42e9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f15dd9b02ec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007f15e9e669ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f15e8c1872d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f15ebc19760 (LWP 2056)):
[KCrash Handler]
#5  0x00007f15ea6ee027 in QString (this=0x48, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=0x48, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x00007f15ea6f9d98 in KIconLoader::loadIcon (this=0x146a3b0, _name=..., group=<value optimized out>, size=22, state=<value optimized out>, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x00007f15ea6f252c in KIconEngine::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:80
#9  0x00007f15e943926c in QIcon::actualSize (this=<value optimized out>, size=..., mode=QIcon::Normal, state=QIcon::On) at image/qicon.cpp:700
#10 0x00007f15e2c9e497 in Plasma::IconWidgetPrivate::decoration (this=0x295bc70, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#11 0x00007f15e2c9fafc in Plasma::IconWidget::paint (this=0x22878a0, painter=0x7fff87d2e9f0, option=0x13a2248, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1013
#12 0x00007f15e999381a in _q_paintItem (item=<value optimized out>, painter=0x7fff87d2e9f0, option=0x13a2248, widget=0x0, useWindowOpacity=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4243
#13 0x00007f15e9993aac in _q_paintIntoCache (pix=0x7fff87d2f080, item=<value optimized out>, pixmapExposed=..., itemToPixmap=<value optimized out>, renderHints=)
    at graphicsview/qgraphicsscene.cpp:4281
#14 0x00007f15e99a7d33 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=0x22878b0, painter=0x7fff87d30ff0, option=0x13a2248, widget=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4574
#15 0x00007f15e99a8625 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x22878b0, painter=0x7fff87d30ff0, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x1a75ca0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4827
#16 0x00007f15e99a9272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x22878b0, painter=0x7fff87d30ff0, viewTransform=0x7fff87d30da0, exposedRegion=0x1a78e80, 
    widget=0x1a75ca0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#17 0x00007f15e99a86c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x1625790, painter=0x7fff87d30ff0, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x1a75ca0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#18 0x00007f15e99a9272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x1625790, painter=0x7fff87d30ff0, viewTransform=0x7fff87d30da0, exposedRegion=0x1a78e80, 
    widget=0x1a75ca0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#19 0x00007f15e99a86c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x16b3590, painter=0x7fff87d30ff0, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x1a75ca0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#20 0x00007f15e99a9272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x16b3590, painter=0x7fff87d30ff0, viewTransform=0x7fff87d30da0, exposedRegion=0x1a78e80, 
    widget=0x1a75ca0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#21 0x00007f15e99a86c0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x1686050, painter=0x7fff87d30ff0, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x1a75ca0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#22 0x00007f15e99a9272 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x1686050, painter=0x7fff87d30ff0, viewTransform=0x7fff87d30da0, exposedRegion=0x1a78e80, 
    widget=0x1a75ca0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#23 0x00007f15e99a9c34 in QGraphicsScenePrivate::drawItems (this=0x13a1ff0, painter=0x7fff87d30ff0, viewTransform=0x7fff87d30da0, exposedRegion=0x1a78e80, widget=0x1a75ca0)
    at graphicsview/qgraphicsscene.cpp:4619
#24 0x00007f15e99c9465 in QGraphicsView::paintEvent (this=0x1a76e60, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3393
#25 0x00007f15ddc2fb09 in PanelView::paintEvent (this=0x7fff87d2e060, event=0x48) at ../../../../plasma/desktop/shell/panelview.cpp:1300
#26 0x00007f15e93dd162 in QWidget::event (this=0x1a76e60, event=0x7fff87d31930) at kernel/qwidget.cpp:8144
#27 0x00007f15e97844e6 in QFrame::event (this=0x1a76e60, e=0x7fff87d31930) at widgets/qframe.cpp:557
#28 0x00007f15e99c5f0b in QGraphicsView::viewportEvent (this=0x1a76e60, event=0x7fff87d31930) at graphicsview/qgraphicsview.cpp:2787
#29 0x00007f15ea1ea487 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1a75ca0, event=0x7fff87d31930) at kernel/qcoreapplication.cpp:819
#30 0x00007f15e93871fc in QApplicationPrivate::notify_helper (this=0x11a7cc0, receiver=0x1a75ca0, e=0x7fff87d31930) at kernel/qapplication.cpp:4296
#31 0x00007f15e938d6fb in QApplication::notify (this=0x119e460, receiver=0x1a75ca0, e=0x7fff87d31930) at kernel/qapplication.cpp:4183
#32 0x00007f15ea732526 in KApplication::notify (this=0x119e460, receiver=0x1a75ca0, event=0x7fff87d31930) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007f15ea1eb06c in QCoreApplication::notifyInternal (this=0x119e460, receiver=0x1a75ca0, event=0x7fff87d31930) at kernel/qcoreapplication.cpp:704
#34 0x00007f15e93e57dd in QCoreApplication::sendSpontaneousEvent (this=0x1a8dca0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x1a8e490) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 QWidgetPrivate::drawWidget (this=0x1a8dca0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1a8e490)
    at kernel/qwidget.cpp:5339
#36 0x00007f15e93e6478 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a8e490) at kernel/qwidget.cpp:5452
#37 0x00007f15e93e62a9 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a8e490) at kernel/qwidget.cpp:5439
#38 0x00007f15e93e62a9 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=5, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a8e490) at kernel/qwidget.cpp:5439
#39 0x00007f15e93e62a9 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=6, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a8e490) at kernel/qwidget.cpp:5439
#40 0x00007f15e93e553a in QWidgetPrivate::drawWidget (this=0x1a789c0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x1a8e490) at kernel/qwidget.cpp:5388
#41 0x00007f15e959f8c5 in QWidgetBackingStore::sync (this=0x1a8e490) at painting/qbackingstore.cpp:1291
#42 0x00007f15e93d6b60 in QWidgetPrivate::syncBackingStore (this=0x1a789c0) at kernel/qwidget.cpp:1672
#43 0x00007f15e93dd865 in QWidget::event (this=0x1a76e60, event=0x1770610) at kernel/qwidget.cpp:8291
#44 0x00007f15e97844e6 in QFrame::event (this=0x1a76e60, e=0x1770610) at widgets/qframe.cpp:557
#45 0x00007f15e980f8ab in QAbstractScrollArea::event (this=0x1a76e60, e=0x1770610) at widgets/qabstractscrollarea.cpp:989
#46 0x00007f15ddc32590 in PanelView::event (this=0x1a76e60, event=0x1770610) at ../../../../plasma/desktop/shell/panelview.cpp:1314
#47 0x00007f15e938722c in QApplicationPrivate::notify_helper (this=0x11a7cc0, receiver=0x1a76e60, e=0x1770610) at kernel/qapplication.cpp:4300
#48 0x00007f15e938d6fb in QApplication::notify (this=0x119e460, receiver=0x1a76e60, e=0x1770610) at kernel/qapplication.cpp:4183
#49 0x00007f15ea732526 in KApplication::notify (this=0x119e460, receiver=0x1a76e60, event=0x1770610) at ../../kdeui/kernel/kapplication.cpp:302
#50 0x00007f15ea1eb06c in QCoreApplication::notifyInternal (this=0x119e460, receiver=0x1a76e60, event=0x1770610) at kernel/qcoreapplication.cpp:704
#51 0x00007f15ea1ed7e7 in QCoreApplication::sendEvent (receiver=0x1a76e60, event_type=<value optimized out>, data=0x1147db0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x1a76e60, event_type=<value optimized out>, data=0x1147db0) at kernel/qcoreapplication.cpp:1345
#53 0x00007f15e99b0b7a in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x13a1ff0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#54 QGraphicsScenePrivate::_q_processDirtyItems (this=0x13a1ff0) at graphicsview/qgraphicsscene.cpp:509
#55 0x00007f15e99b1102 in QGraphicsScene::qt_metacall (this=0x1393b40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2663210) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#56 0x00007f15e2beeb65 in Plasma::Corona::qt_metacall (this=0x7fff87d2e060, _c=72, _id=0, _a=0x0) at ./corona.moc:107
#57 0x00007f15ddc21bd3 in DesktopCorona::qt_metacall (this=0x7fff87d2e060, _c=72, _id=0, _a=0x0) at ./desktopcorona.moc:86
#58 0x00007f15ea1fad49 in QObject::event (this=0x1393b40, e=0x294e860) at kernel/qobject.cpp:1248
#59 0x00007f15e99acd80 in QGraphicsScene::event (this=0x1393b40, event=0x294e860) at graphicsview/qgraphicsscene.cpp:3500
#60 0x00007f15e938722c in QApplicationPrivate::notify_helper (this=0x11a7cc0, receiver=0x1393b40, e=0x294e860) at kernel/qapplication.cpp:4300
#61 0x00007f15e938d6fb in QApplication::notify (this=0x119e460, receiver=0x1393b40, e=0x294e860) at kernel/qapplication.cpp:4183
#62 0x00007f15ea732526 in KApplication::notify (this=0x119e460, receiver=0x1393b40, event=0x294e860) at ../../kdeui/kernel/kapplication.cpp:302
#63 0x00007f15ea1eb06c in QCoreApplication::notifyInternal (this=0x119e460, receiver=0x1393b40, event=0x294e860) at kernel/qcoreapplication.cpp:704
#64 0x00007f15ea1ed7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1147db0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1147db0) at kernel/qcoreapplication.cpp:1345
#66 0x00007f15ea217e40 in QEventDispatcherUNIX::processEvents (this=0x11a7560, flags=) at kernel/qeventdispatcher_unix.cpp:892
#67 0x00007f15e9438257 in QEventDispatcherX11::processEvents (this=<value optimized out>, flags=) at kernel/qeventdispatcher_x11.cpp:152
#68 0x00007f15ea1e9992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#69 0x00007f15ea1e9d6c in QEventLoop::exec (this=0x7fff87d34020, flags=) at kernel/qeventloop.cpp:201
#70 0x00007f15ea1edaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#71 0x00007f15ddc28fb2 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:112
#72 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#73 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#74 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#75 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

Possible duplicates by query: bug 249179, bug 249071, bug 248298, bug 247542, bug 247273.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-09-01 15:48:45 UTC

*** This bug has been marked as a duplicate of bug 226596 ***