Bug 250299 - akregator crashes when I open it
Summary: akregator crashes when I open it
Status: RESOLVED DUPLICATE of bug 116482
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: 1.6.5
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-05 19:32 UTC by Leandro Santiago da Silva
Modified: 2010-09-14 22:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Santiago da Silva 2010-09-05 19:32:31 UTC
Application: akregator (1.6.5)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-19-generic-pae i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
- Custom settings of the application:
I'm using webkit as html renderer

- There are 120 feed sources separated in three folders

- If I delete .kde/share/apps/akregator/Archive, akregator opens fine.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
[KCrash Handler]
#7  __memcpy_ia32 () at ../sysdeps/i386/i686/multiarch/../memcpy.S:100
#8  0xb0358a2f in c4_String::Init (this=0xb01f07e9, p=0x9da3821, n=165445632) at /usr/include/bits/string3.h:52
#9  0xb034f220 in c4_String (this=0x9daaec0, ptr_=0xbfb0b53c, selfDesc_=true) at ../../../../akregator/plugins/mk4storage/metakit/include/mk4str.inl:209
#10 c4_HandlerSeq::Prepare (this=0x9daaec0, ptr_=0xbfb0b53c, selfDesc_=true) at ../../../../akregator/plugins/mk4storage/metakit/src/handler.cpp:305
#11 0xb0352f5e in c4_Persist::LoadAll (this=0x9daac80) at ../../../../akregator/plugins/mk4storage/metakit/src/persist.cpp:1026
#12 0xb0357f7a in c4_Storage (this=0x9cbd3e8, fname_=0x9dab408 "/home/tenchi/.kde/share/apps/akregator/Archive/archiveindex.mk4", mode_=1)
    at ../../../../akregator/plugins/mk4storage/metakit/src/store.cpp:202
#13 0xb03655d5 in Akregator::Backend::StorageMK4Impl::open (this=0x9ca2c80, autoCommit=true) at ../../../../akregator/plugins/mk4storage/storagemk4impl.cpp:134
#14 0xb0fcc526 in Part (this=0x9d12f40, parentWidget=0x9c69aa8, parent=0x9c69aa8, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../akregator/src/akregator_part.cpp:227
#15 0xb0fcf872 in QObject* KPluginFactory::createPartInstance<Akregator::Part>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/akregatorpart.so
#16 0xb65e89b0 in KPluginFactory::create (this=0x9ce61a0, iface=0xb76e6ac0 "KParts::ReadOnlyPart", parentWidget=0x9c69aa8, parent=0x9c69aa8, args=..., keyword=...)
    at ../../kdecore/util/kpluginfactory.cpp:191
#17 0x0805145c in KPluginFactory::create<KParts::ReadOnlyPart> (this=0x9c69aa8) at /usr/include/KDE/../kpluginfactory.h:491
#18 Akregator::MainWindow::loadPart (this=0x9c69aa8) at ../../../akregator/src/mainwindow.cpp:109
#19 0x08051800 in Akregator::MainWindow::readProperties (this=0x9c69aa8, config=...) at ../../../akregator/src/mainwindow.cpp:152
#20 0x08050bf2 in Akregator::MainWindow::autoReadProperties (this=0x9c69aa8) at ../../../akregator/src/mainwindow.cpp:266
#21 0x08050efe in MainWindow (this=0x9c69aa8, parent=0x0, f=..., __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../akregator/src/mainwindow.cpp:89
#22 0x0804f074 in Akregator::Application::newInstance (this=0xbfb0c7a4) at ../../../akregator/src/main.cpp:58
#23 0xb7316c10 in KUniqueApplicationAdaptor::newInstance (this=0x9c70480, asn_id=..., args=...) at ../../kdeui/kernel/kuniqueapplication.cpp:440
#24 0xb7317372 in KUniqueApplicationAdaptor::qt_metacall (this=0x9c70480, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb0bd0c) at ./kuniqueapplication_p.moc:81
#25 0xb60c51d4 in QDBusConnectionPrivate::deliverCall (this=0x9b69978, object=0x9c70480, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:916
#26 0xb60c647f in QDBusConnectionPrivate::activateCall (this=0x9b69978, object=0x9c70480, flags=337, msg=...) at qdbusintegrator.cpp:819
#27 0xb60c6f20 in QDBusConnectionPrivate::activateObject (this=0x9b69978, node=..., msg=..., pathStartPos=16) at qdbusintegrator.cpp:1376
#28 0xb60c71ca in QDBusActivateObjectEvent::placeMetaCall (this=0x9c769c8) at qdbusintegrator.cpp:1490
#29 0xb629cac2 in QObject::event (this=0xbfb0c7a4, e=0x16807b) at kernel/qobject.cpp:1219
#30 0xb6289e8b in QCoreApplication::event (this=0xbfb0c7a4, e=0x9c769c8) at kernel/qcoreapplication.cpp:1561
#31 0xb678ec54 in QApplication::event (this=0xbfb0c7a4, e=0x9c769c8) at kernel/qapplication.cpp:2439
#32 0xb678b77c in QApplicationPrivate::notify_helper (this=0x9b75178, receiver=0xbfb0c7a4, e=0x9c769c8) at kernel/qapplication.cpp:4396
#33 0xb67917ce in QApplication::notify (this=0xbfb0c7a4, receiver=0xbfb0c7a4, e=0x9c769c8) at kernel/qapplication.cpp:3798
#34 0xb730ea9a in KApplication::notify (this=0xbfb0c7a4, receiver=0xbfb0c7a4, event=0x9c769c8) at ../../kdeui/kernel/kapplication.cpp:310
#35 0xb6289feb in QCoreApplication::notifyInternal (this=0xbfb0c7a4, receiver=0xbfb0c7a4, event=0x9c769c8) at kernel/qcoreapplication.cpp:732
#36 0xb628d24b in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9b4f218) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#37 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9b4f218) at kernel/qcoreapplication.cpp:1373
#38 0xb628d40d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#39 0xb62b8d04 in QCoreApplication::sendPostedEvents (s=0x9b720f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#40 postEventSourceDispatch (s=0x9b720f0) at kernel/qeventdispatcher_glib.cpp:277
#41 0xb46445e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0xb46482d8 in ?? () from /lib/libglib-2.0.so.0
#43 0xb46484b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0xb62b87f5 in QEventDispatcherGlib::processEvents (this=0x9b4f3f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#45 0xb684cde5 in QGuiEventDispatcherGlib::processEvents (this=0x9b4f3f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0xb6288a99 in QEventLoop::processEvents (this=0xbfb0c724, flags=) at kernel/qeventloop.cpp:149
#47 0xb6288f1a in QEventLoop::exec (this=0xbfb0c724, flags=...) at kernel/qeventloop.cpp:201
#48 0xb628d4cf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#49 0xb678a5a7 in QApplication::exec () at kernel/qapplication.cpp:3672
#50 0x0804fa61 in main (argc=5, argv=0xbfb0c904) at ../../../akregator/src/main.cpp:103

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-09-14 22:28:44 UTC

*** This bug has been marked as a duplicate of bug 116485 ***
Comment 2 Christophe Giboudeaux 2010-09-14 22:28:53 UTC

*** This bug has been marked as a duplicate of bug 116482 ***