Bug 116485 - Mimimize button missing on "Compaq Flash Reader" camera window
Summary: Mimimize button missing on "Compaq Flash Reader" camera window
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-MainView (show other bugs)
Version: 0.7.4
Platform: Debian testing Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-16 11:10 UTC by David Phillips
Modified: 2017-07-19 09:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Phillips 2005-11-16 11:10:44 UTC
Version:           0.7.4 (using KDE KDE 3.4.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

While importing my photos from the Compaq Flash Reader, I would like to minimize this window.  It is missing the little _ button in the top right, because this window is a non-modal dialog.
Comment 1 caulier.gilles 2006-04-04 13:19:31 UTC
*** Bug 98462 has been marked as a duplicate of this bug. ***
Comment 2 caulier.gilles 2006-05-17 16:58:23 UTC
SVN commit 541885 by cgilles:

digikam from stable : no need to use parent widget to create the cameragui instance like a real modal dialog. Now, you can minimize the camera dialog during pictures download.
CCMAIL: digikam-devel@kde.org
BUG: 116485

 M  +3 -2      cameraui.cpp  


--- branches/stable/extragear/graphics/digikam/utilities/cameragui/cameraui.cpp #541884:541885
@@ -70,10 +70,11 @@
 #include "cameraui.h"
 #include "scanlib.h"
 
-CameraUI::CameraUI(QWidget* parent, const QString& title,
+CameraUI::CameraUI(QWidget* /*parent*/, const QString& title,
                    const QString& model, const QString& port,
                    const QString& path)
-    : QDialog(parent, 0, false, WDestructiveClose)    
+    : QDialog(0, // B.K.O # 116485: no parent for this modal dialog.
+              0, false, WDestructiveClose)    
 {
     // -- setup view -----------------------------------------
 
Comment 3 caulier.gilles 2006-05-17 17:05:50 UTC
SVN commit 541880 by cgilles:

digikam from trunk : no need to use parent widget to create the cameragui instance like a real modal dialog. Now, you can minimize the camera dialog during pictures download.
CCMAIL: digikam-devel@kde.org
CCBUGS: 116485

 M  +3 -2      cameraui.cpp  


--- trunk/extragear/graphics/digikam/utilities/cameragui/cameraui.cpp #541879:541880
@@ -153,12 +153,13 @@
     ImagePropertiesSideBarCamGui *rightSidebar;
 };    
 
-CameraUI::CameraUI(QWidget* parent, const QString& cameraTitle,
+CameraUI::CameraUI(QWidget* /*parent*/, const QString& cameraTitle,
                    const QString& model, const QString& port,
                    const QString& path)
         : KDialogBase(Plain, cameraTitle,
                       Help|User1|User2|User3|Close, Close,
-                      parent, 0, false, true,
+                      0, // B.K.O # 116485: no parent for this modal dialog.
+                      0, false, true,
                       i18n("D&elete"),
                       i18n("&Download"),
                       i18n("&Select"))
Comment 4 Christophe Giboudeaux 2010-09-14 22:28:44 UTC
*** Bug 250299 has been marked as a duplicate of this bug. ***