Bug 246960 - Kwin crash after playing fullscreen embedded online flash video (youtube)
Summary: Kwin crash after playing fullscreen embedded online flash video (youtube)
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 253713 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-07 04:42 UTC by Drew Adams
Modified: 2011-01-27 18:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.23 KB, text/plain)
2010-08-07 05:00 UTC, Drew Adams
Details
New crash information added by DrKonqi (10.27 KB, text/plain)
2010-08-10 13:47 UTC, Drew Adams
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Adams 2010-08-07 04:42:19 UTC
Application: kwin (4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723)))
KDE Platform Version: 4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723))
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

after fullscreening any web embedded flash, the video starts to strobe and if left as full screened it will freeze the entire system. However if fullscreen is exited before the system freezes, upon exit from fullscreen Kwin will crash.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#7  0xb004b3d0 in ?? () from /usr/lib/dri/i965_dri.so
#8  0xb003ece2 in ?? () from /usr/lib/dri/i965_dri.so
#9  0xb0040fe8 in ?? () from /usr/lib/dri/i965_dri.so
#10 0xb0096216 in ?? () from /usr/lib/dri/i965_dri.so
#11 0xb77572db in KWin::SceneOpenGL::paintBackground (this=0x812e210, region=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene_opengl.cpp:892
#12 0xb77be744 in KWin::Scene::paintGenericScreen (this=0x812e210, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:187
#13 0xb778b490 in KWin::Scene::finalPaintScreen (this=0x812e210, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:177
#14 0xb77c1b03 in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:172
#15 0xafb08862 in KWin::LogoutEffect::paintScreen (this=0x8752940, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/logout/logout.cpp:207
#16 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#17 0xafb247ef in KWin::ShadowEffect::paintScreen (this=0x873c370, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/shadow/shadow.cpp:189
#18 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#19 0xafb34401 in KWin::BlurEffect::paintScreen (this=0x8713470, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/blur/blur.cpp:219
#20 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#21 0xafb0d834 in KWin::PresentWindowsEffect::paintScreen (this=0x8740238, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/presentwindows/presentwindows.cpp:196
#22 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#23 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x8713fa0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#24 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#25 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x874d2d8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#26 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#27 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x87547e0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#28 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#29 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x872dfe8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#30 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#31 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x8719e78, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#32 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#33 0xafb538aa in KWin::FlipSwitchEffect::paintScreen (this=0x8718750, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/flipswitch/flipswitch.cpp:146
#34 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#35 0xafaf3c36 in KWin::DesktopGridEffect::paintScreen (this=0x871bda8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/desktopgrid/desktopgrid.cpp:155
#36 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#37 0xafb2b7ad in KWin::SlideEffect::paintScreen (this=0x8724ea0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/slide/slide.cpp:86
#38 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#39 0xafaec71a in KWin::BoxSwitchEffect::paintScreen (this=0x87481a0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/boxswitch/boxswitch.cpp:142
#40 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#41 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x873c5f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#42 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#43 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x8742e80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#44 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#45 0xafb3bc3a in KWin::CoverSwitchEffect::paintScreen (this=0x8742818, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/coverswitch/coverswitch.cpp:124
#46 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#47 0xb6e3c2ca in KWin::Effect::paintScreen (this=0x8739868, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#48 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#49 0xafb33caa in KWin::ZoomEffect::paintScreen (this=0x874f648, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/zoom/zoom.cpp:73
#50 0xb77c1b7f in KWin::EffectsHandlerImpl::paintScreen (this=0x84538f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#51 0xb77bd591 in KWin::Scene::paintScreen (this=0x812e210, mask=0xbfad1914, region=0xbfad19d4) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:137
#52 0xb77f683a in KWin::SceneOpenGL::paint (this=0x812e210, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene_opengl.cpp:748
#53 0xb77d3794 in KWin::Workspace::performCompositing (this=0x815ee60) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/composite.cpp:454
#54 0xb7806a5b in KWin::Workspace::qt_metacall (this=0x815ee60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfad1aec)
    at /usr/src/debug/kdebase-workspace-4.4.95/build/kwin/workspace.moc:583
#55 0xb680defd in QMetaObject::metacall (object=0x815ee60, cl=QMetaObject::InvokeMetaMethod, idx=190, argv=0xbfad1aec) at kernel/qmetaobject.cpp:237
#56 0xb681cfe8 in QMetaObject::activate (sender=0x815f110, m=0xb69245a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#57 0xb6869a35 in QTimer::timeout (this=0x815f110) at .moc/release-shared/moc_qtimer.cpp:134
#58 0xb68228e6 in QTimer::timerEvent (this=0x815f110, e=0xbfad2040) at kernel/qtimer.cpp:271
#59 0xb681a774 in QObject::event (this=0x815f110, e=0xbfad2040) at kernel/qobject.cpp:1212
#60 0xb5d41c64 in QApplicationPrivate::notify_helper (this=0x80701b8, receiver=0x815f110, e=0xbfad2040) at kernel/qapplication.cpp:4302
#61 0xb5d49bf7 in QApplication::notify (this=0xbfad2374, receiver=0x815f110, e=0xbfad2040) at kernel/qapplication.cpp:3706
#62 0xb730c2b1 in KApplication::notify (this=0xbfad2374, receiver=0x815f110, event=0xbfad2040) at /usr/src/debug/kdelibs-4.4.95/kdeui/kernel/kapplication.cpp:309
#63 0xb7768c4f in KWin::Application::notify (this=0xbfad2374, o=0x815f110, e=0xbfad2040) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/main.cpp:372
#64 0xb6807e0e in QCoreApplication::notifyInternal (this=0xbfad2374, receiver=0x815f110, event=0xbfad2040) at kernel/qcoreapplication.cpp:726
#65 0xb683670e in sendEvent (this=0x8070b00) at kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0x8070b00) at kernel/qeventdispatcher_unix.cpp:618
#67 0xb6836ffd in QEventDispatcherUNIX::processEvents (this=0x806fe08, flags=...) at kernel/qeventdispatcher_unix.cpp:939
#68 0xb5df2f5a in QEventDispatcherX11::processEvents (this=0x806fe08, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0xb680711d in QEventLoop::processEvents (this=0xbfad22c4, flags=...) at kernel/qeventloop.cpp:149
#70 0xb6807319 in QEventLoop::exec (this=0xbfad22c4, flags=...) at kernel/qeventloop.cpp:201
#71 0xb680bc70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#72 0xb5d3f164 in QApplication::exec () at kernel/qapplication.cpp:3581
#73 0xb7804fab in kdemain (argc=1, argv=0xbfad25c4) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/main.cpp:531
#74 0x0804860b in main (argc=1, argv=0xbfad25c4) at /usr/src/debug/kdebase-workspace-4.4.95/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 246892, bug 244005.

Reported using DrKonqi
Comment 1 Drew Adams 2010-08-07 05:00:10 UTC
Created attachment 49895 [details]
New crash information added by DrKonqi

kwin (4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723))) on KDE Platform 4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723)) using Qt 4.6.3

- What I was doing when the application crashed:

online flash video can't be full screened without crashing Kwin

-- Backtrace (Reduced):
#11 0xb77702db in KWin::SceneOpenGL::paintBackground (this=0x813fc60, region=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene_opengl.cpp:892
#12 0xb77d7744 in KWin::Scene::paintGenericScreen (this=0x813fc60, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:187
#13 0xb77a4490 in KWin::Scene::finalPaintScreen (this=0x813fc60, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:177
#14 0xb77dab03 in KWin::EffectsHandlerImpl::paintScreen (this=0x8466b90, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:172
#15 0xafb21862 in KWin::LogoutEffect::paintScreen (this=0x87563d0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/logout/logout.cpp:207
Comment 2 Martin Flöser 2010-08-07 08:02:35 UTC
(In reply to comment #0)
> #7  0xb004b3d0 in ?? () from /usr/lib/dri/i965_dri.so
> #8  0xb003ece2 in ?? () from /usr/lib/dri/i965_dri.so
> #9  0xb0040fe8 in ?? () from /usr/lib/dri/i965_dri.so
> #10 0xb0096216 in ?? () from /usr/lib/dri/i965_dri.so
> #11 0xb77572db in KWin::SceneOpenGL::paintBackground (this=0x812e210,
> region=...) at
> /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene_opengl.cpp:892

I'm sorry to say, but it is crashing in the OpenGL graphics driver. There is nothing we can do about it. Feel free to report the crash to the Intel developers (please install additional debugging symbols first).
Comment 3 Drew Adams 2010-08-10 13:47:57 UTC
Created attachment 49969 [details]
New crash information added by DrKonqi

kwin (4.5.00 (KDE 4.5.0)) on KDE Platform 4.5.00 (KDE 4.5.0) using Qt 4.6.3

- What I was doing when the application crashed:

I have now upgraded to KDE 4.5 (very nice by the way) but this bug is still accuring. It is also causing my jfs /home partition to not mount until root runs fsck... this is very frustrating when this happens. I hope this gets mended soon.

-- Backtrace (Reduced):
#11 0xb77ac2db in KWin::SceneOpenGL::paintBackground (this=0x815c748, region=...) at /usr/src/debug/kdebase-workspace-4.5.0/kwin/scene_opengl.cpp:892
#12 0xb7813744 in KWin::Scene::paintGenericScreen (this=0x815c748, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.5.0/kwin/scene.cpp:187
#13 0xb77e0490 in KWin::Scene::finalPaintScreen (this=0x815c748, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.0/kwin/scene.cpp:177
#14 0xb7816b03 in KWin::EffectsHandlerImpl::paintScreen (this=0x8456160, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.0/kwin/effects.cpp:172
#15 0xafb5a862 in KWin::LogoutEffect::paintScreen (this=0x8748b50, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.0/kwin/effects/logout/logout.cpp:207
Comment 4 Thomas Lübking 2010-08-10 14:39:16 UTC
the bug is in your driver, kwin just happens to acces an incredibly harmless OpenGL routine (mesa), that makes some driver calls (x11) and one of them is buggy (or rather the driver is buggy since it seems to mess up internal states)

-> this will NOT fix by updating KDE ever!
You either need a fixed driver (x11) or have to disable (opengl) compositing


The mount thing is normal if you hard reset your system and prevents you from severe data loss, this is certainly not related to this issue.
Comment 5 Christoph Feck 2010-10-10 01:57:06 UTC
*** Bug 253713 has been marked as a duplicate of this bug. ***
Comment 6 Anders Lund 2010-12-13 21:54:51 UTC
I have this problem as well, with same driver (intel). It should be reported upstream or is it alrady?
Comment 7 Thomas Lübking 2011-01-27 18:56:47 UTC
dupe has a better backtrace

*** This bug has been marked as a duplicate of bug 252817 ***