Bug 246892 - Kwin crash when trying to play glest
Summary: Kwin crash when trying to play glest
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-06 11:51 UTC by Drew Adams
Modified: 2011-01-27 18:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Adams 2010-08-06 11:51:40 UTC
Application: kwin (4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723)))
KDE Platform Version: 4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723))
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

I started Glest and my system slowed so I exited Glest and then Kwin crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#7  0xb00163d0 in ?? () from /usr/lib/dri/i965_dri.so
#8  0xb0009ce2 in ?? () from /usr/lib/dri/i965_dri.so
#9  0xb000bfe8 in ?? () from /usr/lib/dri/i965_dri.so
#10 0xb0061216 in ?? () from /usr/lib/dri/i965_dri.so
#11 0xb77222db in KWin::SceneOpenGL::paintBackground (this=0x8157450, region=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene_opengl.cpp:892
#12 0xb7789744 in KWin::Scene::paintGenericScreen (this=0x8157450, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:187
#13 0xb7756490 in KWin::Scene::finalPaintScreen (this=0x8157450, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:177
#14 0xb778cb03 in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:172
#15 0xafad4862 in KWin::LogoutEffect::paintScreen (this=0x8753910, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/logout/logout.cpp:207
#16 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#17 0xafaf07ef in KWin::ShadowEffect::paintScreen (this=0x8746b10, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/shadow/shadow.cpp:189
#18 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#19 0xafb00401 in KWin::BlurEffect::paintScreen (this=0x8716e08, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/blur/blur.cpp:219
#20 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#21 0xafad9834 in KWin::PresentWindowsEffect::paintScreen (this=0x8747e38, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/presentwindows/presentwindows.cpp:196
#22 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#23 0xb6e072ca in KWin::Effect::paintScreen (this=0x876caa0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#24 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#25 0xb6e072ca in KWin::Effect::paintScreen (this=0x874e168, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#26 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#27 0xb6e072ca in KWin::Effect::paintScreen (this=0x876ae88, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#28 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#29 0xb6e072ca in KWin::Effect::paintScreen (this=0x872af90, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#30 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#31 0xb6e072ca in KWin::Effect::paintScreen (this=0x86f6ca8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#32 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#33 0xafb1f8aa in KWin::FlipSwitchEffect::paintScreen (this=0x8714f78, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/flipswitch/flipswitch.cpp:146
#34 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#35 0xafabfc36 in KWin::DesktopGridEffect::paintScreen (this=0x8709488, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/desktopgrid/desktopgrid.cpp:155
#36 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#37 0xafaf77ad in KWin::SlideEffect::paintScreen (this=0x8751278, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/slide/slide.cpp:86
#38 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#39 0xafab871a in KWin::BoxSwitchEffect::paintScreen (this=0x875efe8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/boxswitch/boxswitch.cpp:142
#40 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#41 0xb6e072ca in KWin::Effect::paintScreen (this=0x8753348, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#42 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#43 0xb6e072ca in KWin::Effect::paintScreen (this=0x8752918, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#44 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#45 0xafb07c3a in KWin::CoverSwitchEffect::paintScreen (this=0x8751c48, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/coverswitch/coverswitch.cpp:124
#46 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#47 0xb6e072ca in KWin::Effect::paintScreen (this=0x873f588, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/lib/kwineffects.cpp:227
#48 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#49 0xafaffcaa in KWin::ZoomEffect::paintScreen (this=0x8769b98, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects/zoom/zoom.cpp:73
#50 0xb778cb7f in KWin::EffectsHandlerImpl::paintScreen (this=0x86c6638, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/effects.cpp:168
#51 0xb7788591 in KWin::Scene::paintScreen (this=0x8157450, mask=0xbf97ed04, region=0xbf97edc4) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene.cpp:137
#52 0xb77c183a in KWin::SceneOpenGL::paint (this=0x8157450, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/scene_opengl.cpp:748
#53 0xb779e794 in KWin::Workspace::performCompositing (this=0x815b7d0) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/composite.cpp:454
#54 0xb77d1a5b in KWin::Workspace::qt_metacall (this=0x815b7d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf97eedc)
    at /usr/src/debug/kdebase-workspace-4.4.95/build/kwin/workspace.moc:583
#55 0xb67d8efd in QMetaObject::metacall (object=0x815b7d0, cl=QMetaObject::InvokeMetaMethod, idx=190, argv=0xbf97eedc) at kernel/qmetaobject.cpp:237
#56 0xb67e7fe8 in QMetaObject::activate (sender=0x815ba80, m=0xb68ef5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#57 0xb6834a35 in QTimer::timeout (this=0x815ba80) at .moc/release-shared/moc_qtimer.cpp:134
#58 0xb67ed8e6 in QTimer::timerEvent (this=0x815ba80, e=0xbf97f430) at kernel/qtimer.cpp:271
#59 0xb67e5774 in QObject::event (this=0x815ba80, e=0xbf97f430) at kernel/qobject.cpp:1212
#60 0xb5d0cc64 in QApplicationPrivate::notify_helper (this=0x80701b8, receiver=0x815ba80, e=0xbf97f430) at kernel/qapplication.cpp:4302
#61 0xb5d14bf7 in QApplication::notify (this=0xbf97f764, receiver=0x815ba80, e=0xbf97f430) at kernel/qapplication.cpp:3706
#62 0xb72d72b1 in KApplication::notify (this=0xbf97f764, receiver=0x815ba80, event=0xbf97f430) at /usr/src/debug/kdelibs-4.4.95/kdeui/kernel/kapplication.cpp:309
#63 0xb7733c4f in KWin::Application::notify (this=0xbf97f764, o=0x815ba80, e=0xbf97f430) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/main.cpp:372
#64 0xb67d2e0e in QCoreApplication::notifyInternal (this=0xbf97f764, receiver=0x815ba80, event=0xbf97f430) at kernel/qcoreapplication.cpp:726
#65 0xb680170e in sendEvent (this=0x8070b00) at kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0x8070b00) at kernel/qeventdispatcher_unix.cpp:618
#67 0xb6801ffd in QEventDispatcherUNIX::processEvents (this=0x806fe08, flags=...) at kernel/qeventdispatcher_unix.cpp:939
#68 0xb5dbdf5a in QEventDispatcherX11::processEvents (this=0x806fe08, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0xb67d211d in QEventLoop::processEvents (this=0xbf97f6b4, flags=...) at kernel/qeventloop.cpp:149
#70 0xb67d2319 in QEventLoop::exec (this=0xbf97f6b4, flags=...) at kernel/qeventloop.cpp:201
#71 0xb67d6c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#72 0xb5d0a164 in QApplication::exec () at kernel/qapplication.cpp:3581
#73 0xb77cffab in kdemain (argc=1, argv=0xbf97f9b4) at /usr/src/debug/kdebase-workspace-4.4.95/kwin/main.cpp:531
#74 0x0804860b in main (argc=1, argv=0xbf97f9b4) at /usr/src/debug/kdebase-workspace-4.4.95/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 244005.

Reported using DrKonqi
Comment 1 Thomas Lübking 2010-08-06 13:20:39 UTC
it's not really a dupe of 244005 (different context), but

a) segfaults in "glClear( GL_COLOR_BUFFER_BIT );" as well ... (thus upstream, intels fault)

b) given this and some other bug reports about kwin crashing when applying changes i start to fear the intel gen3 drvier pollutes itself and can not really handle more than one GL context in a short timeframe =\

Try to suspend* kwin before running GL applications and wait a short moment before resuming it after the GL app has exited ... then pray :(

* SHIFT+Alt+F12
Comment 2 Thomas Lübking 2011-01-27 18:56:13 UTC

*** This bug has been marked as a duplicate of bug 252817 ***