Bug 243887 - knetworkmanager crashs when yast starting the service
Summary: knetworkmanager crashs when yast starting the service
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-07 21:40 UTC by Jan Krings
Modified: 2010-08-06 11:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Krings 2010-07-07 21:40:27 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I changed the configuration in yast to networkmanager. when yast wanted to start the service knetwormanager crashed.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0xb6fede5d in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0xb6fb699b in ?? () from /usr/lib/libknmservice.so.4
#8  0xb6fb6cd2 in ?? () from /usr/lib/libknmservice.so.4
#9  0xb6fb7795 in ?? () from /usr/lib/libknmservice.so.4
#10 0xb6fb75f3 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb6fa61d4 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb6fa6253 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0xb6faa126 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0xb6fa78e9 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#15 0xb6fa6ccd in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0xb6fa1b65 in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0xb6d84efd in QMetaObject::metacall (object=0x8150148, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbffb5558) at kernel/qmetaobject.cpp:237
#18 0xb6d93fe8 in QMetaObject::activate (sender=0x8145888, m=0xb6f4a560, local_signal_index=1, argv=0xbffb5558) at kernel/qobject.cpp:3295
#19 0xb6f2b195 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x8145888, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#20 0xb6f2b7cc in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x8145888, uni=...) at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/networkmanager.cpp:197
#21 0xb6f2b84e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8145888, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbffb56b8)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#22 0xb6d84efd in QMetaObject::metacall (object=0x8145888, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbffb56b8) at kernel/qmetaobject.cpp:237
#23 0xb6d93fe8 in QMetaObject::activate (sender=0x81416f8, m=0xb39e8618, local_signal_index=1, argv=0xbffb56b8) at kernel/qobject.cpp:3295
#24 0xb39ce135 in NMNetworkManager::networkInterfaceAdded (this=0x81416f8, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#25 0xb39d372a in NMNetworkManager::deviceAdded (this=0x81416f8, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#26 0xb39ddf73 in NMNetworkManager::qt_metacall (this=0x81416f8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbffb5838)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#27 0xb6d84efd in QMetaObject::metacall (object=0x81416f8, cl=QMetaObject::InvokeMetaMethod, idx=20, argv=0xbffb5838) at kernel/qmetaobject.cpp:237
#28 0xb6d93fe8 in QMetaObject::activate (sender=0x814e730, m=0xb39e8678, local_signal_index=0, argv=0xbffb5838) at kernel/qobject.cpp:3295
#29 0xb39cf745 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x814e730, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#30 0xb39d8b7f in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x814e730, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbffb5a6c)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#31 0xb6eb9a37 in QDBusConnectionPrivate::deliverCall (this=0x8128938, object=0x814e730, msg=..., metaTypes=..., slotIdx=-1074048840) at qdbusintegrator.cpp:904
#32 0xb6ec7536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x81597a8, object=0x814e730) at qdbusintegrator_p.h:101
#33 0xb6d9193f in QObject::event (this=0x814e730, e=0x81597a8) at kernel/qobject.cpp:1248
#34 0xb62d3c64 in QApplicationPrivate::notify_helper (this=0x8096538, receiver=0x814e730, e=0x81597a8) at kernel/qapplication.cpp:4302
#35 0xb62dbbf7 in QApplication::notify (this=0xbffb62d0, receiver=0x814e730, e=0x81597a8) at kernel/qapplication.cpp:3706
#36 0xb72489d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#37 0xb6d7ee0e in QCoreApplication::notifyInternal (this=0xbffb62d0, receiver=0x814e730, event=0x81597a8) at kernel/qcoreapplication.cpp:726
#38 0xb6d829b4 in sendEvent (receiver=0x0, event_type=0, data=0x8074e10) at kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8074e10) at kernel/qcoreapplication.cpp:1367
#40 0xb6d82b9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#41 0xb6daa83d in sendPostedEvents (s=0x8098910) at kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=0x8098910) at kernel/qeventdispatcher_glib.cpp:276
#43 0xb5a72b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#44 0xb5a73350 in ?? () from /usr/lib/libglib-2.0.so.0
#45 0xb5a7360e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#46 0xb6daad4b in QEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#47 0xb638419a in QGuiEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0xb6d7e11d in QEventLoop::processEvents (this=0xbffb6234, flags=...) at kernel/qeventloop.cpp:149
#49 0xb6d7e319 in QEventLoop::exec (this=0xbffb6234, flags=...) at kernel/qeventloop.cpp:201
#50 0xb6d82c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#51 0xb62d1164 in QApplication::exec () at kernel/qapplication.cpp:3581
#52 0x08053e59 in _start ()

This bug may be a duplicate of or related to bug 210878.

Possible duplicates by query: bug 241678.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-08-06 11:48:03 UTC

*** This bug has been marked as a duplicate of bug 210878 ***