Bug 244220 - Kpat spider hints does not always highlight all legal moves.
Summary: Kpat spider hints does not always highlight all legal moves.
Status: RESOLVED DUPLICATE of bug 185211
Alias: None
Product: kpat
Classification: Applications
Component: general (show other bugs)
Version: 0.7.4
Platform: Slackware Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-11 14:32 UTC by Jeff Barry
Modified: 2011-01-26 15:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
It is legal to move the black 9 on the rightmost pile, but that card is not highlighted. (150.08 KB, image/png)
2010-07-11 14:32 UTC, Jeff Barry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Barry 2010-07-11 14:32:10 UTC
Created attachment 48780 [details]
It is legal to move the black 9 on the rightmost pile, but that card is not highlighted.

Version:           0.7.4 (using KDE 4.2.4) 
OS:                Linux

Sometimes while playing spider (spider2, actually) I ask for hints and notice that not all the cards which can legally be moved are highlighted.


Reproducible: Sometimes

Steps to Reproduce:
Play another game, ask for hints, and check results.

The attached image shows a game where the mistake shows up in the initial layout of the cards.  If you can start that particular game, 1202737896, you might (?) see the error right away.  Sorry, but I did not think to save that particular game to send; I just got the screen shot.


Actual Results:  
A few cards which can be legally be moved are not highlighted.  This is frequent enough to be noticed but is still rare.

Expected Results:  
All cards which can legally be moved are highlighted.

OS: Linux (i686) release 2.6.29.6-smp
Compiler: gcc
Comment 1 Janet 2010-11-20 21:00:52 UTC
I can confirm this with KDE SC 4.5.3, sometimes possible moves are not proposed.  Or is this a feature that spider "thinks" those move is not good and makes the game unwinnable?
Comment 2 Jeff Barry 2010-11-21 00:13:12 UTC
>> I can confirm this with KDE SC 4.5.3, sometimes possible moves are not
>> proposed.

OK, between the above and the 15 votes for this bug, how do we get this bug changed to CONFIRMED?  This web page is not letting me make that change.

Speaking of CONFIRMED, I apologize that I did not make my original note clear enough.  Starting Spider 2 with "deal number" 1202737896 and then asking for hints ALWAYS shows an example of the bug, ie the rightmost face-up card, a black 9, is not highlighted tho it should be highlighted because it can obviously go on the black 10.  It's a hard error which happens all the time right at the beginning of a game, and that should make it easy to find the bug.



>> Or is this a feature that spider "thinks" those move is not good and
>> makes the game unwinnable?

If that was supposed to be the case then there would be another bug to report.  In one of my examples the card which was supposed to be highlighted but was not highlighted turned out to be the winning move at that point in the game.  Besides, why highlight only winning moves?  That would take all the fun away!
Comment 3 Stephan Kulow 2011-01-26 15:46:15 UTC

*** This bug has been marked as a duplicate of bug 185211 ***