Bug 185211 - Spider shown unsolvable game as solvable
Summary: Spider shown unsolvable game as solvable
Status: RESOLVED FIXED
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
: 228850 244220 265136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-22 11:53 UTC by martin.ketzer
Modified: 2011-02-02 00:47 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
spider claims that the game cannot be won anymore (second savegame follows) (5.72 KB, application/octet-stream)
2009-06-05 19:21 UTC, martin.ketzer
Details
after moving one card the game is shown as winnable again (which is correct) (5.72 KB, application/octet-stream)
2009-06-05 19:23 UTC, martin.ketzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description martin.ketzer 2009-02-22 11:53:47 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Debian testing/unstable Packages

From time to time spider shows a game as solvable when this is certainly not true. Every possible move results in the status changing to unsolvable. (i will try to attach a save game)
Comment 1 martin.ketzer 2009-02-22 12:00:20 UTC
The save game functionality does not work, so i cannot attach the game.
Comment 2 Stephan Kulow 2009-02-22 13:29:24 UTC
why is save game broken?
Comment 3 martin.ketzer 2009-02-22 13:42:29 UTC
good question. i guess another bug. i use the "save" menu entry, everything seems to work fine, even the "load recently" menu will be filled with the new entry - only no file has been created
Comment 4 Stephan Kulow 2009-02-22 14:18:26 UTC
wow, here too. I'm not aware of changes I've done
Comment 5 Parker Coates 2009-02-22 20:04:26 UTC
See https://bugs.kde.org/show_bug.cgi?id=184274 .
Comment 6 Stephan Kulow 2009-02-24 16:24:38 UTC
ok, that bug is fixed
Comment 7 Stephan Kulow 2009-02-24 16:25:50 UTC
you will have the save game in /tmp somewhere. Check this: find /tmp/kde-$USER -name kpat*
Comment 8 martin.ketzer 2009-06-05 19:21:14 UTC
Created attachment 34303 [details]
spider claims that the game cannot be won anymore (second savegame follows)

my kpat (kde 4.2.4, debian unstable) crashes when trying to load this file without selecting spider as the game - is this a bug?
Comment 9 martin.ketzer 2009-06-05 19:23:12 UTC
Created attachment 34304 [details]
after moving one card the game is shown as winnable again (which is correct)
Comment 10 Parker Coates 2009-06-06 00:11:09 UTC
Yes, that crash is a bug in KDE4.2. I've just fixed it for 4.3, but I don't think it's easily backportable. See http://websvn.kde.org/?view=rev&revision=978067
Comment 11 Parker Coates 2009-11-19 07:57:16 UTC
Martin, the bug title and description describe a different issue than the examples you've provided. Is the issue that it falsely reports winnable games as unwinnable, or that it reports unwinnable games as winnable? If it's both, then this should be split into separate reports, as it's likely separate issues.
Comment 12 Stephan Kulow 2011-01-26 11:13:12 UTC
SVN commit 1217190 by coolo:

find more hints to solve more games
BUG: 185211


 M  +3 -3      patsolve.cpp  
 M  +8 -6      spidersolver.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217190
Comment 13 Stephan Kulow 2011-01-26 11:59:31 UTC
*** Bug 228850 has been marked as a duplicate of this bug. ***
Comment 14 Stephan Kulow 2011-01-26 15:46:15 UTC
*** Bug 244220 has been marked as a duplicate of this bug. ***
Comment 15 Parker Coates 2011-02-02 00:47:23 UTC
*** Bug 265136 has been marked as a duplicate of this bug. ***