Bug 243807 - kdm_greet puts login panel on non-primary LVDS screen
Summary: kdm_greet puts login panel on non-primary LVDS screen
Status: RESOLVED DUPLICATE of bug 48602
Alias: None
Product: kdm
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-07 00:40 UTC by Orion Poplawski
Modified: 2010-07-31 23:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2010-07-07 00:40:48 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

Have system with the following displays:

Screen 0: minimum 320 x 200, current 2944 x 1080, maximum 4096 x 4096
VGA-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
LVDS connected 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.4*+   60.0  
   800x600        60.3     59.9     56.2  
   848x480        59.7  
   720x480        59.7  
   640x480        59.9     59.4  
S-video disconnected (normal left inverted right x axis y axis)

kdm_greet puts the login screen on the LVDS even though it is not primary (and in fact is closed).

Reproducible: Always
Comment 1 Orion Poplawski 2010-07-07 00:48:21 UTC
According to https://bugs.freedesktop.org/show_bug.cgi?id=28936, it is kdm that should disable the LVDS display if the lid is closed.
Comment 2 Orion Poplawski 2010-07-14 22:51:02 UTC
After some more research, this may be a Qt issue.  Apparently for this system, screen 0 is the right side screen and screen 1 is on the left.  kdm_greet places the login panel on screen 0 by default.  Setting GreeterScreen to -1 in /etc/kde/kdm/kdmrc gets it to appear on the left screen.
Comment 3 Orion Poplawski 2010-07-14 23:57:25 UTC
Filed http://bugreports.qt.nokia.com/browse/QTBUG-12198
Comment 4 Oswald Buddenhagen 2010-07-31 23:52:16 UTC
in a broader sense ...

*** This bug has been marked as a duplicate of bug 48602 ***