Bug 48602 - X RandR support needed
Summary: X RandR support needed
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kdm
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Other
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
: 136166 243807 243977 251197 253409 276508 309872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-10-02 20:40 UTC by Jim Gettys
Modified: 2018-04-16 20:22 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Gettys 2002-10-02 20:40:32 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:          Other

The X Resize and Rotate extension just went into the XFree86
CVS in the main server.

This allows the screen size to be changed dynamically,
and optionally, the screen rotated and reflected. (at
long last!).

You may want to allow users to set an initial screen size.
                   - Jim
Comment 1 Ilya Konstantinov 2004-03-13 15:16:49 UTC
Nowadays, the 'krandr' Control Center Module sets the XRANDR setting to whatever the user configured in KDE's Control Center upon the KDE session startup. Thus, the screen size and orientation are per-user.

I suggest marking this bug WONTFIX, since the issue is already solved elsewhere.
Comment 2 Oswald Buddenhagen 2004-03-13 17:19:22 UTC
there is a world beyond kde, so i will not close this.
Comment 3 Steven Roberts 2004-12-07 07:46:27 UTC
BTW, I think this is the same as bug 4860[0,1,3]
Comment 4 Oswald Buddenhagen 2006-10-23 07:51:49 UTC
*** Bug 136166 has been marked as a duplicate of this bug. ***
Comment 5 Oswald Buddenhagen 2010-07-31 23:52:16 UTC
*** Bug 243807 has been marked as a duplicate of this bug. ***
Comment 6 Oswald Buddenhagen 2010-10-06 22:30:09 UTC
*** Bug 253409 has been marked as a duplicate of this bug. ***
Comment 7 Oswald Buddenhagen 2010-10-23 14:53:00 UTC
*** Bug 243977 has been marked as a duplicate of this bug. ***
Comment 8 Oswald Buddenhagen 2010-10-24 00:39:28 UTC
*** Bug 251197 has been marked as a duplicate of this bug. ***
Comment 9 Oswald Buddenhagen 2011-06-26 11:30:44 UTC
*** Bug 276508 has been marked as a duplicate of this bug. ***
Comment 10 Christopher Yeleighton 2011-07-01 10:21:56 UTC
Even in KDE, the operator may be unable to use the desktop in the first session because the default resolution is too high or because the screen flickers (note that KDE does not auto-adjust font resolution to monitor resolution).
Comment 11 COKEDUDE 2011-08-10 21:56:27 UTC
/etc/profile.d/xrandr.sh
/etc/X11/xinit/xinitrc.d/xrandr.sh

You can try something similar to this. I have this shellscript in both of these files and it sets the way I want it. I use fedora by the way. If you use Ubuntu the you can put this in your .xprofile and put this file in your home directory, 

#!/bin/sh
xrandr --output VGA1 --mode 1024x768 --rate 60

#Laptop right extra Monitor Left
#xrandr --output VGA1 --left-of LVDS1

#Laptop left extra Monitor right
xrandr --output LVDS1 --left-of VGA1

#This is to set your primary monitor.

#This sets your laptop monitor as your primary monitor. 
xrandr --output LVDS1 --primary

#This sets your VGA monitor as your primary monitor. 
#xrandr --output VGA1 --primary
Comment 12 Oswald Buddenhagen 2012-11-10 20:10:42 UTC
*** Bug 309872 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2018-04-16 20:22:33 UTC
KDM is unmaintained and not used in KDE Plasma 5.

SDDM is the login manager used in KDE Plasma 5. If you still have this same issue with SDDM, please file an issue on the SDDM bugtracker (after doing a search for existing issues first!): https://github.com/sddm/sddm/issues/