Bug 243364 - Display twilights int Alt vs time tool.
Summary: Display twilights int Alt vs time tool.
Status: RESOLVED FIXED
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-01 18:06 UTC by Alexey Khudiakov
Modified: 2011-07-26 09:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Khudiakov 2010-07-01 18:06:55 UTC
Version:           unspecified
OS:                Linux

Display twilights in the alt vs time tool. Currently gradients between day night are displayed but they misleading since they have fixed width and in no way connected to Sun altitude.

This is especially important for high latitudes where twilights could easily last all night.

Related bugs:

bug 179389 - Daylight indication error polewise of the polar circles in the Altitude vs. Time window
bug 211772 - Moon rise and set information wrong 

Reproducible: Didn't try
Comment 1 Jérôme SONRIER 2011-04-26 03:19:49 UTC
Git commit 8bd09a9d1a25baa1c18524423f26d1d1b01f9a2f by Jérome SONRIER.
Committed on 26/04/2011 at 03:27.
Pushed by jsonrier into branch 'master'.

Display more realistics twilights in Alt vs time tool.
This should also fix bug 179389.

CCMAIL: kstars-devel@kde.org
CCBUG: 243364
CCBUG: 179389

M  +61   -0    kstars/tools/altvstime.cpp     
M  +3    -0    kstars/tools/altvstime.h     
M  +63   -22   kstars/tools/avtplotwidget.cpp     
M  +5    -1    kstars/tools/avtplotwidget.h     

http://commits.kde.org/kstars/8bd09a9d1a25baa1c18524423f26d1d1b01f9a2f