Bug 179389 - Daylight indication error polewise of the polar circles in the Altitude vs. Time window
Summary: Daylight indication error polewise of the polar circles in the Altitude vs. T...
Status: RESOLVED FIXED
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Prakash
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-02 17:21 UTC by Johan Eidenvall
Modified: 2015-02-01 07:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Eidenvall 2009-01-02 17:21:56 UTC
Version:           1.4.1 (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

When selecting a location above the arctic circle (66d33'38"N) the day/night indication (background color) in the Altitude vs. Time window renders completely wrong.

To replicate the error:
* Open the Altitude vs. Time window.
* Add the Sun to the list, to have as a refference.
* Select an apropriate location, such as Kiruna, Sweden.
* Check the plot at midwinter, midsummer and around the middle of spring and fall.

My test results for Kurina: (ISO dates)
2009-01-01 Looks OK, is all black as it should be
2009-04-01 Wrong: Is black to the left and blue to the right. Should be blach in the middle and blue at the edges.
2009-07-01 Wrong: Is all black, should be all blue.
2009-10-01 Wrong: same error as 2009-04-01

I tested other locations with similar results
(Thule, Greenland; Point Hope, Alaska, USA)

I also tested a location south of 66d33'38"S with similar result.

/Johan
Comment 1 Akarsh Simha 2009-01-09 21:56:31 UTC
Thanks for the bug report. This seems like a hard one.

I'm finding the behaviour rather sporadic. Are you able to consistently reproduce the problems? I find it behaving correctly at times (especially when I step through, so it looks like one of these: http://en.wikipedia.org/wiki/Heisenbug##Heisenbug :-D). It would be nice if we could find out under what conditions it works and under what it does not.
Comment 2 Akarsh Simha 2009-11-01 23:58:06 UTC
Prakash said he'd do something about this.
Comment 3 Jérôme SONRIER 2011-04-26 03:19:49 UTC
Git commit 8bd09a9d1a25baa1c18524423f26d1d1b01f9a2f by Jérome SONRIER.
Committed on 26/04/2011 at 03:27.
Pushed by jsonrier into branch 'master'.

Display more realistics twilights in Alt vs time tool.
This should also fix bug 179389.

CCMAIL: kstars-devel@kde.org
CCBUG: 243364
CCBUG: 179389

M  +61   -0    kstars/tools/altvstime.cpp     
M  +3    -0    kstars/tools/altvstime.h     
M  +63   -22   kstars/tools/avtplotwidget.cpp     
M  +5    -1    kstars/tools/avtplotwidget.h     

http://commits.kde.org/kstars/8bd09a9d1a25baa1c18524423f26d1d1b01f9a2f