Bug 243035 - Dragon needs ability to disable screen saver and screen power management
Summary: Dragon needs ability to disable screen saver and screen power management
Status: RESOLVED FIXED
Alias: None
Product: dragonplayer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 244695 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-28 15:35 UTC by Jon Skanes
Modified: 2012-04-15 19:18 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Skanes 2010-06-28 15:35:36 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Please add an option to disable screen saver and screen power management while playing a video.

Reproducible: Always
Comment 1 Jon Skanes 2010-06-28 15:37:00 UTC
Running KDE 4.4.90
Comment 2 Stefan Böhmann 2010-09-06 22:47:31 UTC
*** Bug 244695 has been marked as a duplicate of this bug. ***
Comment 3 Chris 2010-10-06 20:10:11 UTC
Yes, this is really an annoying issue.
Comment 4 Testor 2010-11-05 12:05:40 UTC
Same problem using KDE SC 4.5.3
For my part, the black screen is not due to the screensaver but to the screen power management.

I performed the following tests :
1. Forcing screensaver to activate after 1 minute => No black screen problem
2. Forcing power manager to activate after 1 minute => Black screen appears after 1 minute.
3. Disabling power management => No black screen problem

Reproducible: Always


Is it possible to allow futur versions of Dragon Player to force the power manager to disable when a film is playing ?

Meanwhile it is possible to disable manually the power management in "System Settings/Power Management/Modify the profile" by unchecking the following option : "Activate the screen power management"
Comment 5 Harald Sitter 2011-01-28 01:28:07 UTC
SVN commit 1217597 by sitter:

Also supress screen power management when watching a film.
Please note that this currently does not seem to work on 4.6 as powerdevil does not seem to actually trigger the appropriate action.

CCBUG: 243035
CCMAIL: drf@kde.org


 M  +1 -0      mainWindow.cpp  
 M  +1 -0      mainWindow.h  
 M  +5 -1      stateChange.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217597
Comment 6 Harald Sitter 2011-01-28 01:30:40 UTC
SVN commit 1217599 by sitter:

Forward port r1217597.
Also supress screen power management when watching a film.
Please note that this currently does not seem to work on 4.6 as powerdevil does not seem to actually trigger the appropriate action.

CCBUG: 243035
CCMAIL: drf@kde.org



 M  +1 -0      mainWindow.cpp  
 M  +1 -0      mainWindow.h  
 M  +5 -1      stateChange.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217599
Comment 7 dE 2012-02-05 14:45:10 UTC
This bug is still unconfirmed?
Comment 8 Frederik Schwarzer 2012-02-05 15:15:25 UTC
Maybe someone can confirm that the commits above fixed the issue?
Comment 9 dE 2012-02-08 12:57:05 UTC
Will they be in version 4.7.4?
Comment 10 Jon Skanes 2012-04-15 00:52:07 UTC
Seems fine as of KDE 4.8.2 from official Kubuntu PPA for Oneric.  Thanks!
Comment 11 Jon Skanes 2012-04-15 16:00:03 UTC
Marking as resolved.
Comment 12 dE 2012-04-15 16:26:58 UTC
This should be resolved fixed.
Comment 13 Jon Skanes 2012-04-15 19:18:33 UTC
Thanks for pointing that out, dE.