Bug 242772 - animation does not minimize to the task bar
Summary: animation does not minimize to the task bar
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.9.0
Platform: FreeBSD Ports FreeBSD
: NOR normal with 90 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 243132 252446 264472 296902 302216 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-25 12:08 UTC by vans9
Modified: 2018-06-08 19:42 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vans9 2010-06-25 12:08:25 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                FreeBSD

Minimize animation: magic lamp.
No other effects for minimize animation. Custom duration - 1000 msec.
When I click minimize button of the window, it animates minimize directly to the mouse cursor, not to the task bar. (Possibly it's a feature?). If u move cursor, the direction of animation changes to the nearest screen edge, where the cursor is. Sometimes windows minimize to the task bar, sometimes not. As for me, this behavior occurs more often when the window is maximized, but possibly it has no sense.

Reproducible: Sometimes

Steps to Reproduce:
1. Have magic lamp minimize effect turned on, with duration > 500msec.
2. Click the minimize button, watch the windows minimize to the cursor.
3. Move the cursor while the animation goes, watch the charming minimization to any edge.

Actual Results:  
Minimization goes to the screen edge next to the cursor.

Expected Results:  
Minimization goes to the task bar.

I have PC-BSD 8.1-RC1. KDE 4.4.4.
Comment 1 Thomas Lübking 2010-06-25 14:56:07 UTC
plasma issue.
the direction is wrong as the taskbar doesn't set an icon rect, either because
a) you only show minimized tasks (the taskbar needs to predict the future position)
b) tasks are stacked (dupe of bug #207258, but should be fixed)
Comment 2 vans9 2010-06-25 15:21:47 UTC
Thank u for your reply.
The settings for the taskbar are:
Show windows from the current desktop (On)
Show windows from the current screen (On)
Show only minimized (Off).

Additionally, I've turned off stacking, but the problem persists.
And additionally, when restoring window, it restores in the same way, that is, from the position of cursor.
Comment 3 Aaron J. Seigo 2010-09-27 19:31:05 UTC
a method to reproduce will be necessary; some fixes have been made to this code, so maybe it's already been caught. but without a method to reproduce we can't do much, and there are no other duplicates of this bug outstanding.
Comment 4 Thomas Lübking 2010-10-23 18:17:53 UTC
*** Bug 252446 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Lübking 2010-10-23 18:18:41 UTC
from bug #252446

Problem still there in KDE 4.5.2.

I found one application that virtually reproduces this bug 99% of the time: Qt
Creator.
Comment 6 Nikos Chantziaras 2010-10-23 18:22:48 UTC
The OP mentioned FreeBSD. I also have this problem on Linux. Qt Creator almost always triggers it.
Comment 7 Thomas Zell 2010-10-26 23:46:14 UTC
Another application that occasionally triggers it (haven't found a way to reproduce it reliably) is Firefox.

When the animation is broken and another window is opened subsequently (shifting the position in the taskbar), Firefox will be minimized to it's old location in the taskbar.
Comment 8 Nikos Chantziaras 2011-01-06 02:10:35 UTC
Problem persists in 4.6 RC2.
Comment 9 Nikos Chantziaras 2011-01-06 02:14:06 UTC
Btw, another application that triggers this for me is tvtime.
Comment 10 Thomas Lübking 2011-01-27 19:17:52 UTC
*** Bug 264472 has been marked as a duplicate of this bug. ***
Comment 11 Nikos Chantziaras 2011-01-28 17:09:21 UTC
Issue persists in KDE 4.6.0.

Btw, the bug is marked "WAITINGFORINFO". What info are we actually waiting for?
Comment 12 Martin Flöser 2011-01-28 17:33:15 UTC
(In reply to comment #11)
> What info are we actually waiting for?
A way how to reproduce it. I am using for example MagicLamp on all my systems and have never been able to reproduce it. What we need is a reliable way, like 
1. do foo
2. do bar
3. do foobar
4. see the error
Comment 13 Nikos Chantziaras 2011-01-28 17:43:47 UTC
Hmm, for me, this works:

1. Install tvtime or Qt Creator.
2. Launch it.
3. Minimize it.
4. If it minimizes correctly, quit and go back to 2 until it triggers the bug.
Comment 14 Martin Flöser 2011-01-29 14:38:50 UTC
I just hit the issue with Qt Designer and rather think that the problem lies in Qt and not in KDE. The icon geometry was not set on the window, so I assume that something causes either Plasma to not set the property or Qt removes it again.
Comment 15 vans9 2011-02-02 19:41:30 UTC
And I can add that, for me, opera triggers such behavior. Persist in FreeBSD/KDE 4.5.4, PCBSD 8.2 RC1/KDE 4.5.4. But occurs rarely.
May be, this info will be useful.

Regards,
Vans.

29.01.2011, 16:38, "Martin Gräßlin" <kde@martin-graesslin.com>:
> https://bugs.kde.org/show_bug.cgi?id=242772
>
> Martin Gräßlin <kde@martin-graesslin.com>; changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|NEEDSINFO                   |NEW
>          Resolution|WAITINGFORINFO              |
>      Ever Confirmed|0                           |1
>
> --- Comment #14 from Martin Gräßlin <kde martin-graesslin com>  2011-01-29 14:38:50 ---
> I just hit the issue with Qt Designer and rather think that the problem lies in
> Qt and not in KDE. The icon geometry was not set on the window, so I assume
> that something causes either Plasma to not set the property or Qt removes it
> again.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 16 Nikos Chantziaras 2011-06-11 19:01:35 UTC
Issue still there in 4.6.4.
Comment 17 Kai Uwe Broulik 2011-07-16 12:59:58 UTC
I *never* experienced that bug but now I do in 4.7 :(
Sometimes windows are minimized to somewhere on the screen (affects both Magic Lamp and Minimize effect) and sometimes (or if I drag the panel around) the windows minimize just fine.
Comment 18 Bernhard Beschow 2011-08-23 18:12:14 UTC
*** Bug 243132 has been marked as a duplicate of this bug. ***
Comment 19 Nikos Chantziaras 2011-08-23 18:26:04 UTC
Btw, this only happens when starting applications through icons that have launch feedback enabled (which is the default).  If you disable launch feedback or start the app in a terminal, then this bug never happens.

It happens at the point where KDE deletes the old taskbar widget (the one created by lauch feedback) and replaces it with the final one.  That final one is sometimes broken somehow.  It minimizes to the wrong place, but sometimes it also doesn't do anything.  You click on it and it does nothing; it neither minimizes nor restores its app window.
Comment 20 Jorge Adriano 2011-12-14 20:56:35 UTC
I've been experiencing this also, using the magic lamp effect, on KDE 4.8 Beta 2. 

One thing I noticed is that these windows do seem to minimise towards the cursor regardless of the chosen minimisation method, and not only if you opt to click on the minimise button. E.g., 

- place your cursor somewhere on the screen
- press Alt+F3 to access the window decoration menu
- select minimise from this menu

The window will still minimise towards the cursor, wherever it may be.
Comment 21 Johannes Schmidt 2012-01-27 21:44:23 UTC
My various problems with the magic lamp effect seem to be fixed in the KDE SC 4.8.0 release. Can anyone else verify this?
Comment 22 Nikos Chantziaras 2012-01-27 23:37:51 UTC
I don't use magic lamp, but the windows still minimize towards the center of the screen and not towards the task bar.

I guess this annoying bug will never be fixed :-(
Comment 23 Jorge Adriano 2012-01-28 00:58:50 UTC
(In reply to comment #21)
> My various problems with the magic lamp effect seem to be fixed in the KDE SC
> 4.8.0 release. Can anyone else verify this?

Still minimizes towards the cursor most of the time here.
Comment 24 Nikos Chantziaras 2012-04-22 15:18:32 UTC
Still there in 4.8.2.

Sigh. This is glitch is seriously annoying. Why no interest in fixing this?
Comment 25 Martin Flöser 2012-04-22 16:10:51 UTC
(In reply to comment #24)
> Sigh. This is glitch is seriously annoying. Why no interest in fixing this?
Because it is not trivial to fix or even reproduce reliable. Multiple applications are involved (Plasma, KWin) and that makes it difficult to properly identify the faulty component. Furthermore MagicLamp is not a default effect and there is much more important things to fix. Just consider that Plasma has at the time of this writing 1193 open bug reports.
Comment 26 Nikos Chantziaras 2012-04-22 16:14:44 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > Sigh. This is glitch is seriously annoying. Why no interest in fixing this?
> Because it is not trivial to fix or even reproduce reliable. Multiple
> applications are involved (Plasma, KWin) and that makes it difficult to
> properly identify the faulty component. Furthermore MagicLamp is not a
> default effect and there is much more important things to fix. Just consider
> that Plasma has at the time of this writing 1193 open bug reports.

I'm not using MagicLamp at all. I have it disabled.
Comment 27 Marco Martin 2012-06-27 10:59:34 UTC
*** Bug 302216 has been marked as a duplicate of this bug. ***
Comment 28 Marco Martin 2012-06-27 10:59:53 UTC
*** Bug 296902 has been marked as a duplicate of this bug. ***
Comment 29 Nikos Chantziaras 2012-08-14 20:29:55 UTC
Issue still there in KDE 4.9.0.

The title of the bug should be fixed. It's not a "MagicLamp" problem.
Comment 30 Myriam Schweingruber 2012-09-08 09:14:46 UTC
Feel free to suggest a better bug title
Comment 31 Fabian Henze 2012-09-11 23:34:17 UTC
I am having this problem with the default minimize animation (kwin4_effect_minimizeanimation) since ages. It destroys all the sexyness kwin compositing once introduced ...

The theory in comment 19 sounds reasonable, maybe the developers should start digging there?
Also, my taskbar is on the top edge of the screen, maybe that matters?
If I move it to the bottom edge and then up again, the animations work fine till I open one or two applications and close them again.

Feel free to contact me to debug the problem via IRC or similar. I am using Gentoo, so I can quickly test patches and get debugging informations.
Comment 32 vans9 2012-09-12 08:07:08 UTC
I can add that most frequently Opera triggers such behavior. May be this can help tracing the bug. May be this due to the fact that Opera uses it's own framework (afaik), may be not... Btw, if the bug occurs even without Opera, switching desktops restores normal minimize behavior.
Comment 33 Jorge Adriano 2012-09-12 08:44:21 UTC
> Also, my taskbar is on the top edge of the screen, maybe that matters?
> If I move it to the bottom edge and then up again, the animations work fine
> till I open one or two applications and close them again.

This is consistent with my experience. My taskbar is on the left edge and the behaviour seemed to be reproducible 100% of the time. I moved it back to the bottom edge to test if that was the cause, and indeed windows minimised properly. However when I moved the taskbar back to the left edge windows kept on minimising correctly. After some time however, I noticed more and more windows exhibiting the same incorrect behaviour again (maybe the were the newly opened ones, I can test it again).
Comment 34 alien321 2012-09-12 13:59:54 UTC
If you have 2 monitor on dual head configuration this bug is very common.
If you move a window on monitor 1 to monitor 2 the taskbar dont  refresh the status of open windows on monitor 2, and the minimization go crazy

In the taskbar options section filters  of Monitor 1 and Monitor 2 you must have only this option selected no other

"Show only applications on the current screen"
Comment 35 Nikos Chantziaras 2012-09-12 18:28:39 UTC
This is with one monitor only.

Also, Chrome is one of the applications that triggers this sometimes. So now:

tvtime (almost every time)
Qt Creator (almost every time)
Chrome (or Chromium) (1 out of 5 times)
Comment 36 Ariel Loyarte 2012-09-22 14:14:06 UTC
Using KDE 4.8.4 in Kubuntu 12.04 (2012)...

I found a temporary solution. I don't know exactly the names in english, because I have my system in spanish.
You need to go to System Settings. Into the notifications options there is a category called "Startup Notification" or "Launch Feedback" (I don't know the correct name in english, but in spanish is "Notificación de lanzamiento"). You have to uncheck the last item; in spanish: "Activar notificación de la barra de tareas" (in english is maybe: "Enable taskbar notifications" or something like that).

Please, verify this temporary solution. I haven't reported the problem since several minutes.
Comment 37 Nikos Chantziaras 2012-09-22 14:21:37 UTC
Yes, that seems to work. So the initial start-up notification icon placed in the task bar screws with the real icon that comes later on, after the application has fully started.
Comment 38 Ariel Loyarte 2012-09-22 14:39:38 UTC
I found out that sometimes the problem occurs when more than one instances of the same program is opend. But only if grouping windows on taskbar is enabled (default). So if we disable grouping windows (and uncheck the option mentioned in Comment 36) the problem seems to be solved (at least temporary).
Comment 39 Ariel Loyarte 2012-09-22 16:22:08 UTC
According to Comment 38, the grouping option on "Icon Tasks" plasmoid (instead of the traditional taskbar form) seems to be working without those problems.
Comment 40 Ragnar Thomsen 2013-04-30 20:02:07 UTC
This bug affects me with KDE 4.10.2 with the default task manager and the minimize animation. Sometimes windows minimize to the center of screen instead of the taskbar. I tried the solution in comment 36 and also tried disabling grouping. This does NOT solve the problem. I have not been able to see a pattern in which windows are affected and when. I have observed the phenomenon for several applications including firefox, ktorrent and kmail.
I hope this bug gets fixed soon as it really makes KDE appear immature...
Comment 41 Nate Graham 2018-06-08 19:42:02 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham