Bug 242765 - Archive extraction through Dolphin drag & drop popup menu to a SFTP folder fails, writes on local directory instead
Summary: Archive extraction through Dolphin drag & drop popup menu to a SFTP folder fa...
Status: RESOLVED DUPLICATE of bug 240716
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-25 11:22 UTC by Alvaro Manuel Recio Perez
Modified: 2012-01-09 03:15 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alvaro Manuel Recio Perez 2010-06-25 11:22:00 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Dolphin shows an option on a popup menu when the user drags a compressed archive with the option to decompress it. This menu is also shown when dropping an archive to a remote SFTP folder. However, in this case, when Dolphin decompress the archive it does it into the local folder where the archive is present not into the remote folder as expected.

Reproducible: Always

Steps to Reproduce:
- Open two Dolphin windows.
- On the first window, open a folder with an archive file (tested with a tar.bz2 file).
- On the second window, open a remote folder through SFTP.
- Drag the archive from the first window to the second.
- Select "Extract here" in the popup menu.

Actual Results:  
Dolphin extracts the contents of the archive into the local folder (first window) instead of into the remote folder.

Expected Results:  
Dolphin should have extracted the archive on the remote folder.

OS: Linux (x86_64) release 2.6.32-22-generic
Compiler: cc
Comment 1 FiNeX 2010-08-29 21:34:55 UTC
I've reproduced the bug but the final result is a bit different: the file is uncompressed in my home directory even if the source file is in a subdirectory of ~/.
Comment 2 Jekyll Wu 2011-12-31 02:03:04 UTC
maybe related with bug 263533
Comment 3 Jekyll Wu 2012-01-09 02:25:09 UTC

*** This bug has been marked as a duplicate of bug 240716 ***