Bug 242555 - Effects switch current activity
Summary: Effects switch current activity
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: git master
Platform: Compiled Sources Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 244214 262751 263776 265571 269153 275964 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-23 05:03 UTC by David Palacio
Modified: 2011-08-04 21:11 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Palacio 2010-06-23 05:03:48 UTC
Version:           SVN (using Devel) 
OS:                Linux

There are two issues with the present windows kwin effect:

1. It hides windows not on current activity but, they still affect the layout, leaving big empty spaces .

2. Clicking where the hidden windows should appear does switch to that window and activity that window resides on.

Reproducible: Always
Comment 1 Martin Flöser 2010-07-11 13:44:15 UTC
*** Bug 244214 has been marked as a duplicate of this bug. ***
Comment 2 Martin Flöser 2010-07-11 13:45:03 UTC
same issue exists for desktop grid and possibly other effects.
Comment 3 FiNeX 2010-08-15 16:43:35 UTC
Bug confirmed in KDE 4.5.0 too
Comment 4 Maxime Corteel 2010-12-18 18:18:30 UTC
Bug confirmed in KDE 4.5.85 with desktop grid, when clicking on a desktop in desktop grid, I get sent back to another activity.
Comment 5 Martin Flöser 2011-01-20 19:02:15 UTC
*** Bug 263776 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2011-01-20 19:02:35 UTC
*** Bug 262751 has been marked as a duplicate of this bug. ***
Comment 7 Paulo Neves 2011-01-27 18:31:19 UTC
KDE 4.6 have the empty spaces for other activities windows and now with a close button.
Comment 8 FiNeX 2011-01-28 13:48:15 UTC
I can confirm the bug. I like very much activites, but with this bug activites are not convenient to use :-(
Comment 9 FiNeX 2011-01-28 13:49:02 UTC
P.S: I've forget to say that I confirm it in KDE 4.6 :-)
Comment 10 Nitro Nexus 2011-02-12 17:56:35 UTC
I can confirm the bug for KDE 4.6 from kubuntu backoprts ppa repository. With this bug activities lose all their effectiveness and working with them begin too much chaotic.
Comment 11 Martin Flöser 2011-03-22 17:58:00 UTC
*** Bug 269153 has been marked as a duplicate of this bug. ***
Comment 12 Martin Flöser 2011-03-25 23:39:47 UTC
*** Bug 265571 has been marked as a duplicate of this bug. ***
Comment 13 Jan Gerrit Marker 2011-04-24 14:31:08 UTC
Git commit 888d34eb7a278c7284080c748304308f6f958347 by Jan Gerrit Marker.
Committed on 24/04/2011 at 14:20.
Pushed by jangmarker into branch 'master'.

Make present windows effect not preserve space for windows from other activities
REVIEW:101180
CCBUG:242555

M  +14   -0    kwin/effects.cpp     
M  +4    -0    kwin/effects.h     
M  +2    -0    kwin/effects/presentwindows/presentwindows.cpp     
M  +5    -0    kwin/libkwineffects/kwineffects.cpp     
M  +10   -0    kwin/libkwineffects/kwineffects.h     

http://commits.kde.org/kde-workspace/888d34eb7a278c7284080c748304308f6f958347
Comment 14 Jan Gerrit Marker 2011-04-24 17:50:08 UTC
Git commit e9410ba51e4674819fc8c37c8f122f1233a8c78a by Jan Gerrit Marker.
Committed on 24/04/2011 at 17:44.
Pushed by jangmarker into branch 'master'.

Desktop grid effect now does not preserve space for windows from
other activities.
BUG:242555

M  +1    -1    kwin/effects/desktopgrid/desktopgrid.cpp     

http://commits.kde.org/kde-workspace/e9410ba51e4674819fc8c37c8f122f1233a8c78a
Comment 15 Martin Flöser 2011-06-18 11:10:35 UTC
*** Bug 275964 has been marked as a duplicate of this bug. ***
Comment 16 FiNeX 2011-08-04 21:11:32 UTC
Thanks, this is a great improvement!!! :-)