Bug 239469 - Picture bullets not displaying in doc files
Summary: Picture bullets not displaying in doc files
Status: VERIFIED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR normal (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords: reproducible
: 239100 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-12 10:47 UTC by Lassi Nieminen
Modified: 2012-10-23 09:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
msword test document used to open in kword (24.00 KB, application/msword)
2009-08-12 10:47 UTC, Lassi Nieminen
Details
screenshot of the document in kword (134.50 KB, image/png)
2009-08-12 10:48 UTC, Lassi Nieminen
Details
screenshot of the document in MS Word 2003 (82.88 KB, image/png)
2009-08-12 10:49 UTC, Lassi Nieminen
Details
msword 2007 test document to be opened in kword (14.80 KB, application/x-zip-compressed)
2009-09-17 16:13 UTC, Lassi Nieminen
Details
pyodconverter converted testdata (12.42 KB, application/x-zip-compressed)
2010-03-03 16:39 UTC, Lassi Nieminen
Details
koconverter converted testdata (4.63 KB, application/x-zip-compressed)
2010-03-03 16:40 UTC, Lassi Nieminen
Details
pyodconverter converted testdata opened in koffice screenshot (173.85 KB, image/png)
2010-03-03 16:40 UTC, Lassi Nieminen
Details
koconverter converted testdata opened in openoffice screenshot (102.34 KB, image/png)
2010-03-03 16:41 UTC, Lassi Nieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-05-28 03:20:44 UTC


---- Reported by lassi.ta.nieminen@nokia.com 2009-08-12 11:47:41 +0300 ----

Created an attachment
msword test document used to open in kword

SOFTWARE VERSION:
  Kubuntu 9.04
  Koffice (svn version 1007302)
  Test document (MS Word 2003): normal_bullets_pictures.doc

STEPS LEADING TO THE PROBLEM:
  1. Open the attached document in MS Word 2003.
  2. Open the same document in KOffice.
  3. Observe the picture bullets in first page of the document.

EXPECTED OUTCOME:
  Picture bullets should be shown properly in the document.
  see attachment normal_bullets_pictures_msword_2003.png

ACTUAL OUTCOME:
  Pictures for bullets are not shown in the document.
  A filled circle is shown for each bullet instead of the picture.
  Some of the pictures used for the bullets are shown separately in
  the document.
  see attachment normal_bullets_pictures_kword_svn_1007302.png

FREQUENCY:
  Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-12 11:48:50 +0300 ----

Created an attachment
screenshot of the document in kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-12 11:49:25 +0300 ----

Created an attachment
screenshot of the document in MS Word 2003



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-09-17 17:13:27 +0300 ----

Created an attachment
msword 2007 test document to be opened in kword

ACTUAL OUTCOME FOR TESTDATA CREATED IN MSWORD 2007: rev 1021093

Pictures bullets are not displayed at all.
Attaching the testdata.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-04 10:35:08 +0200 ----

Reassigning bugs from Thomas to Lassi



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-22 20:07:06 +0200 ----

hmm are you sure this is the correct test doc - when opened in ooo it doesn't look like the screenshot either



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-03 17:39:50 +0200 ----

Created an attachment
pyodconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-03 17:40:05 +0200 ----

Created an attachment
koconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-03 17:40:26 +0200 ----

Created an attachment
pyodconverter converted testdata opened in koffice screenshot



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-03-03 17:41:02 +0200 ----

Created an attachment
koconverter converted testdata opened in openoffice screenshot

Observation (rev: 1096327) : None of the converted testdata works properly.



--- Bug imported by faure@kde.org 2010-05-28 03:20  ---

This bug was previously known as _bug_ 132586.

Imported an attachment (id=45705)
Imported an attachment (id=45706)
Imported an attachment (id=45707)
Imported an attachment (id=45708)
Imported an attachment (id=45709)
Imported an attachment (id=45710)
Imported an attachment (id=45711)
Imported an attachment (id=45712)

Unknown bug field "example" encountered while moving bug
   <example>2010-03-03 17:41:02</example>

Comment 1 swathi 2010-12-04 10:46:18 UTC
*** Bug 239100 has been marked as a duplicate of this bug. ***
Comment 2 Matus Uzak 2011-12-06 18:40:56 UTC
Git commit ec8f8b96dd05691ee35a21f2fd683b557a293644 by Matus Uzak.
Committed on 06/12/2011 at 19:35.
Pushed by uzak into branch 'master'.

docx: picture bullets - update bulletSizePt in order to have correct picture size.

* In case only bulletRelativeSize is provided then use the default font-size
  or the font-size of the text chunk (if provided) to set bulletSizePt.
  The absolute font-size specifies fo:width and fo:height for the picture bullet.

CCBUG:239469

M  +1    -0    filters/words/docx/DocxImport.cpp
M  +22   -0    filters/words/docx/DocxXmlDocumentReader.cpp
M  +2    -0    filters/words/docx/DocxXmlDocumentReader.h
M  +4    -0    filters/words/docx/DocxXmlStylesReader.cpp

http://commits.kde.org/calligra/ec8f8b96dd05691ee35a21f2fd683b557a293644
Comment 3 Matus Uzak 2012-01-26 15:53:57 UTC
Git commit e82e0acdcd366335b3ed6d97d12d538e3ebddfb7 by Matus Uzak.
Committed on 26/01/2012 at 16:50.
Pushed by uzak into branch 'master'.

doc: Added support for Bullet Pictures.

M  +19   -10   filters/words/msword-odf/graphicshandler.cpp
M  +1    -1    filters/words/msword-odf/graphicshandler.h
M  +30   -23   filters/words/msword-odf/texthandler.cpp
A  +53   -0    filters/words/msword-odf/wv2/src/SPRMS
M  +39   -6    filters/words/msword-odf/wv2/src/bookmark.cpp
M  +9    -1    filters/words/msword-odf/wv2/src/bookmark.h
M  +2    -2    filters/words/msword-odf/wv2/src/handlers.cpp
M  +10   -10   filters/words/msword-odf/wv2/src/handlers.h
M  +10   -1    filters/words/msword-odf/wv2/src/lists.cpp
M  +27   -0    filters/words/msword-odf/wv2/src/lists.h
M  +5    -0    filters/words/msword-odf/wv2/src/paragraphproperties.cpp
M  +5    -0    filters/words/msword-odf/wv2/src/paragraphproperties.h
M  +56   -9    filters/words/msword-odf/wv2/src/parser9x.cpp
M  +11   -3    filters/words/msword-odf/wv2/src/parser9x.h
M  +13   -13   filters/words/msword-odf/wv2/src/parserfactory.cpp
M  +10   -1    filters/words/msword-odf/wv2/src/word97_generated.cpp
M  +24   -4    filters/words/msword-odf/wv2/src/word97_generated.h
M  +11   -0    filters/words/msword-odf/wv2/src/word97_helper.cpp

http://commits.kde.org/calligra/e82e0acdcd366335b3ed6d97d12d538e3ebddfb7
Comment 4 swathi 2012-10-23 09:10:50 UTC
Verified in git commit ad0416095c417a8cfa55306ea8959ac0ef4460bb.