Bug 239458 - kword:msoffice2003: KWord does not show autoshapes
Summary: kword:msoffice2003: KWord does not show autoshapes
Status: VERIFIED WORKSFORME
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR normal (vote)
Target Milestone: ---
Assignee: LukasT
URL:
Keywords: reproducible
: 239081 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-07 11:34 UTC by Lassi Nieminen
Modified: 2011-09-29 06:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
msword test document used to open in kword (23.50 KB, application/msword)
2009-08-07 11:38 UTC, Lassi Nieminen
Details
screenshot of the document in kword (126.03 KB, image/png)
2009-08-07 11:39 UTC, Lassi Nieminen
Details
screenshot of the document in MS Word 2003 (104.82 KB, image/png)
2009-08-07 11:39 UTC, Lassi Nieminen
Details
msword 2000 test document to be opened in kword (19.50 KB, application/msword)
2009-09-01 12:14 UTC, Lassi Nieminen
Details
pyodconverter converted testdata (9.99 KB, application/x-zip-compressed)
2010-02-27 17:58 UTC, Lassi Nieminen
Details
koconverter converted testdata (2.67 KB, application/x-zip-compressed)
2010-02-27 17:59 UTC, Lassi Nieminen
Details
pyodconverter converted testdata opened in koffice (134.67 KB, image/png)
2010-02-27 17:59 UTC, Lassi Nieminen
Details
koconverter converted testdata opened in openoffice (86.87 KB, image/png)
2010-02-27 18:01 UTC, Lassi Nieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-05-28 03:20:27 UTC


---- Reported by lassi.ta.nieminen@nokia.com 2009-08-07 12:34:48 +0300 ----

SOFTWARE VERSION:
  Kubuntu 9.04
  Koffice (svn version 1007302)
  Test document (MS Word 2003): picture_autoshape.doc

STEPS LEADING TO THE PROBLEM:
  1. Open the attached document in MS Word 2003.
  2. Open the same document in KOffice.
  3. Observe the auto shape in page 1.

EXPECTED OUTCOME:
  Figure with auto shapes should be shown.

ACTUAL OUTCOME:
  Figure with auto shapes is not shown. 
  (see attachment picture_autoshape_kword_svn_1007302.png)

FREQUENCY:
  Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 12:38:19 +0300 ----

Created an attachment
msword test document used to open in kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 12:39:13 +0300 ----

Created an attachment
screenshot of the document in kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 12:39:42 +0300 ----

Created an attachment
screenshot of the document in MS Word 2003



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 14:17:56 +0300 ----

changing the priority



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-12 17:44:37 +0300 ----

Correcting assignee for old bugs that were assigned to Sergey and Jos.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-09-01 13:14:55 +0300 ----

Created an attachment
msword 2000 test document to be opened in kword

ACTUAL OUTCOME FOR TESTDATA CREATED IN MSWORD 2000: svn rev - 1017657
Autoshapes are not shown. Blank document is shown.
Attaching the test data.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-04 10:35:11 +0200 ----

Reassigning bugs from Thomas to Lassi



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-24 11:00:17 +0200 ----

missing feature in filter



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 18:58:42 +0200 ----

Created an attachment
pyodconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 18:59:06 +0200 ----

Created an attachment
koconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 18:59:48 +0200 ----

Created an attachment
pyodconverter converted testdata opened in koffice



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 19:01:31 +0200 ----

Created an attachment
koconverter converted testdata opened in openoffice

Observation (1096327) : KOffice loaded the OOo-converted document correctly.



--- Bug imported by faure@kde.org 2010-05-28 03:20  ---

This bug was previously known as _bug_ 131921.

Imported an attachment (id=45622)
Imported an attachment (id=45623)
Imported an attachment (id=45624)
Imported an attachment (id=45625)
Imported an attachment (id=45626)
Imported an attachment (id=45627)
Imported an attachment (id=45628)
Imported an attachment (id=45629)

Unknown bug field "example" encountered while moving bug
   <example>2010-02-27 19:01:31</example>

Comment 1 Halla Rempt 2010-05-31 10:31:20 UTC
Change severity from major to normal, since we usually use only crash, normal and wish.
Comment 2 Halla Rempt 2010-05-31 10:45:40 UTC
Change severity from major to normal.
Comment 3 swathi 2010-10-14 07:16:50 UTC
*** Bug 239081 has been marked as a duplicate of this bug. ***
Comment 4 LukasT 2011-03-23 12:59:22 UTC
I work on autoshapes now, so I will try to fix this one too
Comment 5 LukasT 2011-03-31 09:33:52 UTC
Git commit 70485e59be711e35a52ab9ca7acfda8d9bcd2aee by Lukáš Tvrdý.
Committed on 30/03/2011 at 12:35.
Pushed by lukast into branch 'master'.

Add support for missing autoshapes

o fixing hexagon shape
o fixing processing of the arrows
o add support for autoshape left-right-arrow

Still has to be done:
o adding support of the libmso to words (uzak)

CCBUG:239458

M  +1    -0    filters/libmso/ODrawToOdf.h     
M  +72   -1    filters/libmso/shapes.cpp     

http://commits.kde.org/calligra/70485e59be711e35a52ab9ca7acfda8d9bcd2aee
Comment 6 LukasT 2011-04-15 17:12:42 UTC
Git commit 2edc6570999096e0a778922f05470a0785ec416a by Lukáš Tvrdý.
Committed on 15/04/2011 at 17:13.
Pushed by lukast into branch 'master'.

Add missing autoshapes

o add Lightning Bolt shape
o add Flow Chart Magnetic Disk

Still to be done:
o fix positions of the shapes

CCBUG:239458

M  +3    -0    filters/libmso/ODrawToOdf.h     
M  +46   -12   filters/libmso/shapes.cpp     

http://commits.kde.org/calligra/2edc6570999096e0a778922f05470a0785ec416a
Comment 7 LukasT 2011-06-06 15:49:49 UTC
Git commit e652e2b6c4e9cf4dee7e4b359b192dee26c084df by Lukáš Tvrdý.
Committed on 06/06/2011 at 15:23.
Pushed by lukast into branch 'master'.

Fix the size of the ellipse

Use draw:ellipse tag instead of enhanced geometry
as there is probably some bug in engine when
interpreting enhanced geometry

CCBUG:239458

M  +9    -1    filters/libmso/shapes2.cpp     

http://commits.kde.org/calligra/e652e2b6c4e9cf4dee7e4b359b192dee26c084df
Comment 8 LukasT 2011-09-12 11:11:51 UTC
All missing autoshapes were added and uzak added support of libmso to words.
Comment 9 swathi 2011-09-29 06:21:02 UTC
Auto shapes are displaying in 4e79a72f29a8e0c2e4cf5b572456ef02bd415d81.

But the position of the auto shapes is not good.It will be raised as a seperate bug.