Bug 239081 - kword:msoffice2003: KWord does not show autoshapes
Summary: kword:msoffice2003: KWord does not show autoshapes
Status: VERIFIED DUPLICATE of bug 239458
Alias: None
Product: calligrawords
Classification: Applications
Component: doc (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR normal (vote)
Target Milestone: ---
Assignee: KOffice Bug Wranglers
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2009-08-07 11:34 UTC by Lassi Nieminen
Modified: 2010-12-14 00:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
msword test document used to open in kword (23.50 KB, application/msword)
2009-08-07 11:38 UTC, Lassi Nieminen
Details
screenshot of the document in kword (126.03 KB, image/png)
2009-08-07 11:39 UTC, Lassi Nieminen
Details
screenshot of the document in MS Word 2003 (104.82 KB, image/png)
2009-08-07 11:39 UTC, Lassi Nieminen
Details
msword 2000 test document to be opened in kword (19.50 KB, application/msword)
2009-09-01 12:14 UTC, Lassi Nieminen
Details
pyodconverter converted testdata (9.99 KB, application/x-zip-compressed)
2010-02-27 17:58 UTC, Lassi Nieminen
Details
koconverter converted testdata (2.67 KB, application/x-zip-compressed)
2010-02-27 17:59 UTC, Lassi Nieminen
Details
pyodconverter converted testdata opened in koffice (134.67 KB, image/png)
2010-02-27 17:59 UTC, Lassi Nieminen
Details
koconverter converted testdata opened in openoffice (86.87 KB, image/png)
2010-02-27 18:01 UTC, Lassi Nieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-05-28 02:45:40 UTC


---- Reported by lassi.ta.nieminen@nokia.com 2009-08-07 12:34:48 +0300 ----

SOFTWARE VERSION:
  Kubuntu 9.04
  Koffice (svn version 1007302)
  Test document (MS Word 2003): picture_autoshape.doc

STEPS LEADING TO THE PROBLEM:
  1. Open the attached document in MS Word 2003.
  2. Open the same document in KOffice.
  3. Observe the auto shape in page 1.

EXPECTED OUTCOME:
  Figure with auto shapes should be shown.

ACTUAL OUTCOME:
  Figure with auto shapes is not shown. 
  (see attachment picture_autoshape_kword_svn_1007302.png)

FREQUENCY:
  Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 12:38:19 +0300 ----

Created an attachment
msword test document used to open in kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 12:39:13 +0300 ----

Created an attachment
screenshot of the document in kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 12:39:42 +0300 ----

Created an attachment
screenshot of the document in MS Word 2003



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-07 14:17:56 +0300 ----

changing the priority



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-12 17:44:37 +0300 ----

Correcting assignee for old bugs that were assigned to Sergey and Jos.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-09-01 13:14:55 +0300 ----

Created an attachment
msword 2000 test document to be opened in kword

ACTUAL OUTCOME FOR TESTDATA CREATED IN MSWORD 2000: svn rev - 1017657
Autoshapes are not shown. Blank document is shown.
Attaching the test data.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-04 10:35:11 +0200 ----

Reassigning bugs from Thomas to Lassi



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-24 11:00:17 +0200 ----

missing feature in filter



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 18:58:42 +0200 ----

Created an attachment
pyodconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 18:59:06 +0200 ----

Created an attachment
koconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 18:59:48 +0200 ----

Created an attachment
pyodconverter converted testdata opened in koffice



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-27 19:01:31 +0200 ----

Created an attachment
koconverter converted testdata opened in openoffice

Observation (1096327) : KOffice loaded the OOo-converted document correctly.



--- Bug imported by faure@kde.org 2010-05-28 02:45  ---

This bug was previously known as _bug_ 131921.

Imported an attachment (id=43959)
Imported an attachment (id=43960)
Imported an attachment (id=43961)
Imported an attachment (id=43962)
Imported an attachment (id=43963)
Imported an attachment (id=43964)
Imported an attachment (id=43965)
Imported an attachment (id=43966)
Comment 1 Halla Rempt 2010-05-31 10:28:57 UTC
Change severity from major to normal, since we usually use only crash, normal and wish.
Comment 2 Halla Rempt 2010-05-31 10:40:46 UTC
Change severity from major to normal.
Comment 3 swathi 2010-10-14 07:16:49 UTC

*** This bug has been marked as a duplicate of bug 239458 ***
Comment 4 swathi 2010-10-14 07:17:22 UTC
Verified as a duplicate of bug 239458.