Bug 235930 - crash in KateSmartCursor::setPositionInternal
Summary: crash in KateSmartCursor::setPositionInternal
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: part (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-01 18:28 UTC by Andre
Modified: 2010-05-23 00:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre 2010-05-01 18:28:16 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-21-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
It happened for the second time now, I tried to copy and paste some text and it crashed.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  0x01f6ae6a in KateSmartCursor::setPositionInternal (this=0x8f4335c, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x01f6b242 in KateSmartCursor::translate (this=0x8f4335c, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x01f706af in KateSmartGroup::translateChanged (this=0x93e7d48, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0x01f73fcf in KateSmartManager::slotTextChanged (this=0x9039af8, edit=0x95e3110) at ../../kate/smart/katesmartmanager.cpp:368
#10 0x01f7438f in KateSmartManager::qt_metacall (this=0x9039af8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfa274d8) at ./katesmartmanager.moc:74
#11 0x00d93263 in QMetaObject::activate (sender=0x8f30270, from_signal_index=4, to_signal_index=4, argv=0xbfa274d8) at kernel/qobject.cpp:3113
#12 0x00d93ec2 in QMetaObject::activate (sender=0x8f30270, m=0x207fb64, local_signal_index=0, argv=0xbfa274d8) at kernel/qobject.cpp:3187
#13 0x01f42523 in KateEditHistory::editDone (this=0x8f30270, _t1=0x95e3110) at ./kateedit.moc:78
#14 0x01f2cf22 in KateDocument::editWrapLine (this=0x9059aa8, line=106, col=0, newLine=true, newLineAdded=0x0) at ../../kate/document/katedocument.cpp:1281
#15 0x01f2eb1c in KateDocument::newLine (this=0x9059aa8, v=0x9006320) at ../../kate/document/katedocument.cpp:3877
#16 0x01fc0bcc in KateViewInternal::doReturn (this=0x8f43308) at ../../kate/view/kateviewinternal.cpp:808
#17 0x01fc12f0 in KateViewInternal::keyPressEvent (this=0x8f43308, e=0xbfa27b64) at ../../kate/view/kateviewinternal.cpp:2381
#18 0x01fc04e9 in KateViewInternal::eventFilter (this=0x8f43308, obj=0x8f43308, e=0xbfa27b64) at ../../kate/view/kateviewinternal.cpp:2250
#19 0x00d7c83a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x85efab8, receiver=0x8f43308, event=0xbfa27b64) at kernel/qcoreapplication.cpp:726
#20 0x010e6f2c in QApplicationPrivate::notify_helper (this=0x85efab8, receiver=0x8f43308, e=0xbfa27b64) at kernel/qapplication.cpp:4052
#21 0x010ef778 in QApplication::notify (this=0xbfa2970c, receiver=0x8f43308, e=0xbfa27b64) at kernel/qapplication.cpp:3662
#22 0x03563bfa in KApplication::notify (this=0xbfa2970c, receiver=0x8f43308, event=0xbfa27b64) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00d7d6cb in QCoreApplication::notifyInternal (this=0xbfa2970c, receiver=0x8f43308, event=0xbfa27b64) at kernel/qcoreapplication.cpp:610
#24 0x010e7e2e in QCoreApplication::sendSpontaneousEvent (receiver=0x8f43308, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#25 qt_sendSpontaneousEvent (receiver=0x8f43308, event=0x0) at kernel/qapplication.cpp:4958
#26 0x01184440 in QKeyMapper::sendKeyEvent (keyWidget=0x8f43308, grab=false, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#27 0x01186989 in QKeyMapperPrivate::translateKeyEvent (this=0x8616e40, keyWidget=0x8f43308, event=0xbfa2934c, grab=108) at kernel/qkeymapper_x11.cpp:1831
#28 0x0115aed7 in QApplication::x11ProcessEvent (this=0xbfa2970c, event=0xbfa2934c) at kernel/qapplication_x11.cpp:3443
#29 0x01188502 in x11EventSourceDispatch (s=0x85f26a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x004b2e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x004b6730 in ?? () from /lib/libglib-2.0.so.0
#32 0x004b6863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00da802c in QEventDispatcherGlib::processEvents (this=0x85d79d8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#34 0x01187be5 in QGuiEventDispatcherGlib::processEvents (this=0x85d79d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00d7bc79 in QEventLoop::processEvents (this=0xbfa29644, flags=) at kernel/qeventloop.cpp:149
#36 0x00d7c0ca in QEventLoop::exec (this=0xbfa29644, flags=...) at kernel/qeventloop.cpp:201
#37 0x00d7e53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x010e6dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#39 0x00fc1b0d in kdemain () from /usr/lib/libkdeinit4_kate.so
#40 0x080485eb in _start ()

This bug may be a duplicate of or related to bug 209215

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-05-23 00:26:17 UTC

*** This bug has been marked as a duplicate of bug 200450 ***