Bug 209215 - kate crashed on simple cut and paste ( ctrl+x ctrl+v crash)
Summary: kate crashed on simple cut and paste ( ctrl+x ctrl+v crash)
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-02 15:00 UTC by David Rankin
Modified: 2009-10-03 19:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Rankin 2009-10-02 15:00:37 UTC
Application that crashed: kate
Version of the application: 3.3.1
KDE Version: 4.3.1 (KDE 4.3.1) "release 163"
Qt Version: 4.5.2
Operating System: Linux 2.6.25.20-0.5-default x86_64

What I was doing when the application crashed:
Guys,

I was editing a simple script and had cut about 4 lines of text to move to the bottom of the file. I scrolled down and as soon as I pressed ctrl+v kate crashed and drkonqi appeared. Nothing else remarkable about it.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x186f2f0, pos=..., internal=true) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartcursor.cpp:186
#6  0x00007f5a6c2984e0 in KateSmartCursor::translate (this=0x186f2f0, edit=...) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartcursor.cpp:305
#7  0x00007f5a6c29dbd0 in KateSmartGroup::translateChanged (this=0x185e930, edit=...) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartmanager.cpp:464
#8  0x00007f5a6c2a12f3 in KateSmartManager::slotTextChanged (this=0xb2dfb0, edit=0x18b3b90) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartmanager.cpp:368
#9  0x00007f5a6c2a16af in KateSmartManager::qt_metacall (this=0xb2dfb0, _c=InvokeMetaMethod, _id=1, _a=0x7fff830a2b30) at /usr/src/debug/kdelibs-4.3.1/build/kate/katesmartmanager.moc:74
#10 0x00007f5a7abaa2f2 in QMetaObject::activate (sender=0xaec5c0, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#11 0x00007f5a6c2736ef in KateEditHistory::editDone (this=0x7fff830a28b0, _t1=0x18b3b90) at /usr/src/debug/kdelibs-4.3.1/build/kate/kateedit.moc:78
#12 0x00007f5a6c25e3d5 in KateDocument::editWrapLine (this=0x9cd930, line=97, col=24, newLine=<value optimized out>, newLineAdded=0x0)
    at /usr/src/debug/kdelibs-4.3.1/kate/document/katedocument.cpp:1281
#13 0x00007f5a6c261cda in KateDocument::insertText (this=0x9cd930, position=..., text=..., block=false) at /usr/src/debug/kdelibs-4.3.1/kate/document/katedocument.cpp:622
#14 0x00007f5a6c260de0 in KateDocument::paste (this=0x9cd930, view=0xd75ba0, mode=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kate/document/katedocument.cpp:4038
#15 0x00007f5a6c2ca285 in KateView::paste (this=0xd75ba0) at /usr/src/debug/kdelibs-4.3.1/kate/view/kateview.cpp:2363
#16 0x00007f5a6c2d3bb5 in KateView::qt_metacall (this=0xd75ba0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff830a30d0) at /usr/src/debug/kdelibs-4.3.1/build/kate/kateview.moc:307
#17 0x00007f5a7abaa2f2 in QMetaObject::activate (sender=0xdac5c0, from_signal_index=<value optimized out>, to_signal_index=6, argv=0x0) at kernel/qobject.cpp:3113
#18 0x00007f5a77f25a77 in QAction::triggered (this=0x7fff830a28b0, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#19 0x00007f5a77f26ef0 in QAction::activate (this=0xdac5c0, event=<value optimized out>) at kernel/qaction.cpp:1160
#20 0x00007f5a77f299f7 in QAction::event (this=0x7fff830a28b0, e=<value optimized out>) at kernel/qaction.cpp:1079
#21 0x00007f5a78f46b83 in KAction::event(QEvent*) () from /usr/lib64/libkdeui.so.5
#22 0x00007f5a77f2ba9d in QApplicationPrivate::notify_helper (this=0x68a260, receiver=0xdac5c0, e=0x7fff830a3660) at kernel/qapplication.cpp:4056
#23 0x00007f5a77f33d1a in QApplication::notify (this=0x7fff830a5df0, receiver=0xdac5c0, e=0x7fff830a3660) at kernel/qapplication.cpp:4021
#24 0x00007f5a7901922b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#25 0x00007f5a7ab954fc in QCoreApplication::notifyInternal (this=0x7fff830a5df0, receiver=0xdac5c0, event=0x7fff830a3660) at kernel/qcoreapplication.cpp:610
#26 0x00007f5a77f614bd in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QShortcutMap::dispatchEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qshortcutmap.cpp:884
#28 0x00007f5a77f632ec in QShortcutMap::tryShortcutEvent (this=0x68a378, o=<value optimized out>, e=0x7fff830a3b60) at kernel/qshortcutmap.cpp:369
#29 0x00007f5a77f34d41 in QApplication::notify (this=0x7fff830a5df0, receiver=0xd7e270, e=0x7fff830a3b60) at kernel/qapplication.cpp:3645
#30 0x00007f5a7901922b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007f5a7ab954fc in QCoreApplication::notifyInternal (this=0x7fff830a5df0, receiver=0xd7e270, event=0x7fff830a3b60) at kernel/qcoreapplication.cpp:610
#32 0x00007f5a77fbff04 in QKeyMapper::sendKeyEvent (keyWidget=0xd7e270, grab=<value optimized out>, type=KeyPress, code=86, modifiers=..., text=..., autorepeat=<value optimized out>, count=1, 
    nativeScanCode=55, nativeVirtualKey=118, nativeModifiers=4) at kernel/qkeymapper_x11.cpp:1678
#33 0x00007f5a77fc226f in QKeyMapperPrivate::translateKeyEvent (this=0x6b5a10, keyWidget=0xd7e270, event=0x7fff830a59a0, grab=99) at kernel/qkeymapper_x11.cpp:1648
#34 0x00007f5a77f9bdde in QApplication::x11ProcessEvent (this=0x7fff830a5df0, event=0x7fff830a59a0) at kernel/qapplication_x11.cpp:3436
#35 0x00007f5a77fc3ccc in x11EventSourceDispatch (s=0x68d9b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007f5a76a0b95a in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f5a76a0f060 in ?? () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f5a76a0f1fc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f5a7abbe9df in QEventDispatcherGlib::processEvents (this=0x619810, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#40 0x00007f5a77fc341f in QGuiEventDispatcherGlib::processEvents (this=0x7fff830a28b0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#41 0x00007f5a7ab93d72 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f5a7ab94144 in QEventLoop::exec (this=0x7fff830a5cd0, flags=...) at kernel/qeventloop.cpp:201
#43 0x00007f5a7ab96454 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#44 0x00007f5a6fbc1dd5 in kdemain () from /usr/lib64/libkdeinit4_kate.so
#45 0x00000000004073dd in launch (argc=1, _name=0x65bc68 "/usr/bin/kate", args=<value optimized out>, cwd=0x0, envc=1, envs=0x65bc8a "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x65bc93 "alchemy;1254487046;686575;4138_TIME62968478") at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:706
#46 0x0000000000407c08 in handle_launcher_request (sock=7, who=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:1198
#47 0x00000000004081b5 in handle_requests (waitForPid=0) at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:1391
#48 0x0000000000408d60 in main (argc=4, argv=0x7fff830a7de8, envp=0x7fff830a7e10) at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:1830

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-03 19:44:17 UTC
Merging with bug 200450.
- Is this crash reproducible?
Thanks

*** This bug has been marked as a duplicate of bug 200450 ***