Bug 235680 - KNewStuff always fails to uninstall entries
Summary: KNewStuff always fails to uninstall entries
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knewstuff (show other bugs)
Version: SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jeremy Whiting
URL:
Keywords:
: 245086 305479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-04-29 00:48 UTC by Alex Richardson
Modified: 2013-08-10 22:40 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments
Proposed patch (1.49 KB, patch)
2010-05-04 15:23 UTC, Alex Richardson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Richardson 2010-04-29 00:48:25 UTC
Version:            (using Devel)
Installed from:    Compiled sources

I recently added KNewStuff3 support to Okteta and while doing so I noticed that nothing happens on the file system when I click the uninstall button.

After looking at the sources that the problem lies withing KNS3::Engine::uninstall()
here the entry from the provider is used (which does not have any installed files), so nothing gets deleted.

I created a patch which fixes this problem. Should I attach it to this Bug or upload it to ReviewBoard?
Comment 1 Alex Richardson 2010-05-04 15:23:31 UTC
Created attachment 43235 [details]
Proposed patch
Comment 2 Alex Richardson 2010-05-04 15:30:12 UTC
I just noticed that uninstalling does not always fail without this patch. It works as long as khotnewstuff4 is not restarted between installing and uninstalling. If it is restarted, and you click on uninstall it displays "install again", but if you then start khotnewstuff4 again the entry is still installed, since no files were deleted and the registry was not updated.
Comment 3 rockonthemoonfm 2012-08-14 09:33:39 UTC
2 years passe, still same problems present.

GHNS feature is REALLY buggy. It's an incredible feature exclusive to Kde, my concern is why this has been introduced if it's clearly full of problems.

Uninstalling extensions is a critrical feature that doesn't work in almost any place GHNS is used.

Waiting a replay to report more useful infos to squash these bugs once for all.
Comment 4 Christoph Feck 2012-08-20 13:08:28 UTC
*** Bug 305479 has been marked as a duplicate of this bug. ***
Comment 5 ariasuni 2013-02-08 23:25:30 UTC
It happens in KDE 4.10; and remove “things” myself cause also problems (https://bugs.kde.org/show_bug.cgi?id=176033).
Comment 6 Christoph Feck 2013-04-20 17:58:50 UTC
*** Bug 245086 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Whiting 2013-08-02 16:25:18 UTC
Ugh, 3 years ago, sorry all.  I just tested okteta and confirmed this bug and will test the patch and add it next.  I'll back port it to 4.11 also, so it should get into KDE SC 4.11.0 I believe.
Comment 8 Jeremy Whiting 2013-08-02 17:04:18 UTC
Git commit 04548d934a8e31dfa11f9ae92ae2632d30cd4d29 by Jeremy Whiting.
Committed on 02/08/2013 at 17:01.
Pushed by whiting into branch 'master'.

Fix uninstalling of knewstuff data by using registry entry for uninstall rather than provider entry.
Thanks to Alex Richardson <arichardson.kde@googlemail.com> for the patch.

M  +25   -2    knewstuff/knewstuff3/core/engine.cpp

http://commits.kde.org/kdelibs/04548d934a8e31dfa11f9ae92ae2632d30cd4d29
Comment 9 Jeremy Whiting 2013-08-02 17:05:05 UTC
Git commit dd74f97c139c493ccf18d99286cfc85700bd994a by Jeremy Whiting.
Committed on 02/08/2013 at 17:01.
Pushed by whiting into branch 'KDE/4.11'.

Fix uninstalling of knewstuff data by using registry entry for uninstall rather than provider entry.
Thanks to Alex Richardson <arichardson.kde@googlemail.com> for the patch.

(cherry picked from commit 04548d934a8e31dfa11f9ae92ae2632d30cd4d29)

M  +25   -2    knewstuff/knewstuff3/core/engine.cpp

http://commits.kde.org/kdelibs/dd74f97c139c493ccf18d99286cfc85700bd994a