Bug 219853 - Kate crashes when triple-clicking an empty textarea
Summary: Kate crashes when triple-clicking an empty textarea
Status: RESOLVED WORKSFORME
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 223985 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-23 18:06 UTC by larvid
Modified: 2010-02-11 23:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description larvid 2009-12-23 18:06:20 UTC
Application that crashed: kate
Version of the application: 3.3.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-ARCH i686

What I was doing when the application crashed:
Whenever the textarea in Kate is empty (a new session is opened, a new file is opened, the content in the textarea is deleted) and you triple-click the textarea, Kate crashes with:
Undecodable sequence: \001b(hex)[?1034h
KCrash: Application 'kate' crashing...
sock_file=/home/arvid/.kde4/socket-arvid-arch/kdeinit4__0

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  0xb37a0ec5 in KateLineLayout::viewLineCount() const () from /usr/lib/kde4/katepart.so
#7  0xb379db3c in KateLayoutCache::viewLine(KTextEditor::Cursor const&) const () from /usr/lib/kde4/katepart.so
#8  0xb379e14f in KateLayoutCache::textLayout(KTextEditor::Cursor const&) const () from /usr/lib/kde4/katepart.so
#9  0xb37fa7f9 in KateViewInternal::makeVisible(KTextEditor::Cursor const&, int, bool, bool, bool) () from /usr/lib/kde4/katepart.so
#10 0xb37fb000 in KateViewInternal::updateCursor(KTextEditor::Cursor const&, bool, bool, bool) () from /usr/lib/kde4/katepart.so
#11 0xb37ff94c in KateViewInternal::mousePressEvent(QMouseEvent*) () from /usr/lib/kde4/katepart.so
#12 0xb6dfcc36 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#13 0xb6da83a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#14 0xb6db03d0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb680e5ca in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#16 0xb64dae8b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#17 0xb6daf393 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#18 0xb6e1ce84 in ?? () from /usr/lib/libQtGui.so.4
#19 0xb6e1c365 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb6e46a52 in ?? () from /usr/lib/libQtGui.so.4
#21 0xb611b378 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb611ebf0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#23 0xb611ed23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb65055f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0xb6e46185 in ?? () from /usr/lib/libQtGui.so.4
#26 0xb64d9479 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0xb64d98ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb64dbd3f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0xb6da8227 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0xb7764a8d in kdemain () from /usr/lib/libkdeinit4_kate.so
#31 0x0804857b in _start ()

Reported using DrKonqi
Comment 1 Milian Wolff 2009-12-23 20:11:17 UTC
cannot reproduce with KDE 4.4 Beta 2 here.
Comment 2 Milian Wolff 2010-01-25 13:58:53 UTC
*** Bug 223985 has been marked as a duplicate of this bug. ***