Bug 233432 - Kate crashed collapse folding
Summary: Kate crashed collapse folding
Status: RESOLVED DUPLICATE of bug 200858
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 233429 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-04-05 23:24 UTC by gdm
Modified: 2010-04-08 00:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gdm 2010-04-05 23:24:38 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-21-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
It seems I have the same problem.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0, viewLine=-1) at ../../kate/render/katelinelayout.cpp:173
#6  KateLineLayout::viewLine (this=0x0, viewLine=-1) at ../../kate/render/katelinelayout.cpp:179
#7  0x00007fb20403261e in KateLayoutCache::textLayout (this=<value optimized out>, realLine=41149, _viewLine=-1) at ../../kate/render/katelayoutcache.cpp:346
#8  0x00007fb20407fbf0 in KateViewInternal::previousLayout (this=0x2b74700) at ../../kate/view/kateviewinternal.cpp:1282
#9  0x00007fb204087c2f in KateViewInternal::cursorUp (this=0x2b74700, sel=false) at ../../kate/view/kateviewinternal.cpp:1462
#10 0x00007fb20407228d in KateView::qt_metacall (this=0x2b711f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffaf921430) at ./kateview.moc:371
#11 0x00007fb212c8eddc in QMetaObject::activate (sender=0x2c9dc90, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3113
#12 0x00007fb210c240a7 in QAction::triggered (this=0x7fffaf921240, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#13 0x00007fb210c254ef in QAction::activate (this=0x2c9dc90, event=<value optimized out>) at kernel/qaction.cpp:1160
#14 0x00007fb210c27fa7 in QAction::event (this=0x7fffaf921240, e=<value optimized out>) at kernel/qaction.cpp:1079
#15 0x00007fb21178f17d in KAction::event (this=0x7fffaf921240, event=0x7fffaf921930) at ../../kdeui/actions/kaction.cpp:88
#16 0x00007fb210c29efc in QApplicationPrivate::notify_helper (this=0x1f54a10, receiver=0x2c9dc90, e=0x7fffaf921930) at kernel/qapplication.cpp:4056
#17 0x00007fb210c311ce in QApplication::notify (this=0x7fffaf923fd0, receiver=0x2c9dc90, e=0x7fffaf921930) at kernel/qapplication.cpp:4021
#18 0x00007fb211860ab6 in KApplication::notify (this=0x7fffaf923fd0, receiver=0x2c9dc90, event=0x7fffaf921930) at ../../kdeui/kernel/kapplication.cpp:302
#19 0x00007fb212c79c2c in QCoreApplication::notifyInternal (this=0x7fffaf923fd0, receiver=0x2c9dc90, event=0x7fffaf921930) at kernel/qcoreapplication.cpp:610
#20 0x00007fb210c5e666 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fffaf921dc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#21 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fffaf921dc0) at kernel/qshortcutmap.cpp:884
#22 0x00007fb210c604f7 in QShortcutMap::tryShortcutEvent (this=0x1f54b28, o=<value optimized out>, e=0x7fffaf921dc0) at kernel/qshortcutmap.cpp:369
#23 0x00007fb210c31e6e in QApplication::notify (this=0x7fffaf923fd0, receiver=0x2b74700, e=0x7fffaf921dc0) at kernel/qapplication.cpp:3645
#24 0x00007fb211860ab6 in KApplication::notify (this=0x7fffaf923fd0, receiver=0x2b74700, event=0x7fffaf921dc0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007fb212c79c2c in QCoreApplication::notifyInternal (this=0x7fffaf923fd0, receiver=0x2b74700, event=0x7fffaf921dc0) at kernel/qcoreapplication.cpp:610
#26 0x00007fb210cbadfa in QKeyMapper::sendKeyEvent (keyWidget=0x2b74700, grab=<value optimized out>, type=QEvent::KeyPress, code=16777235, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=111, nativeVirtualKey=65362, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#27 0x00007fb210cbd370 in QKeyMapperPrivate::translateKeyEvent (this=0x1f87df0, keyWidget=0x2b74700, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1831
#28 0x00007fb210c95493 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffaf923ba0) at kernel/qapplication_x11.cpp:3443
#29 0x00007fb210cbed0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007fb20fb5abce in g_main_dispatch (context=0x1f56430) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#31 IA__g_main_context_dispatch (context=0x1f56430) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#32 0x00007fb20fb5e598 in g_main_context_iterate (context=0x1f56430, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#33 0x00007fb20fb5e6c0 in IA__g_main_context_iteration (context=0x1f56430, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#34 0x00007fb212ca21a6 in QEventDispatcherGlib::processEvents (this=0x1f52dd0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#35 0x00007fb210cbe4be in QGuiEventDispatcherGlib::processEvents (this=0x7fffaf921240, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x00007fb212c78532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007fb212c78904 in QEventLoop::exec (this=0x7fffaf923ed0, flags=) at kernel/qeventloop.cpp:201
#38 0x00007fb212c7aab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x00007fb20703fd2d in kdemain () from /usr/lib/libkdeinit4_kate.so
#40 0x0000000000406da8 in launch (argc=4, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=32, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x1f19ab4 "dell;1270502369;465611;8331_TIME43481923") at ../../kinit/kinit.cpp:677
#41 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#42 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#43 0x0000000000408bb2 in main (argc=1, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 213328

Reported using DrKonqi
Comment 1 gdm 2010-04-07 00:26:11 UTC
*** Bug 233429 has been marked as a duplicate of this bug. ***
Comment 2 Dominik Haumann 2010-04-08 00:56:11 UTC

*** This bug has been marked as a duplicate of bug 200858 ***