Bug 213328 - Kate crashes after collapsing top levels
Summary: Kate crashes after collapsing top levels
Status: RESOLVED DUPLICATE of bug 200858
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-05 21:55 UTC by artirum
Modified: 2009-11-05 23:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description artirum 2009-11-05 21:55:47 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
OS: kubuntu 9.10
uname -r: 2.6.31-14-generic
on a Toshiba laptop satellite M-100 series
Kate: Version 3.3.2
KDE: 4.3.2

Kate simply crashes after collapsing top leves with Ctrl + Shit + - and pressing either 'up' or 'up-arrow' keys. It is consistent.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0, viewLine=-1) at ../../kate/render/katelinelayout.cpp:173
#7  KateLineLayout::viewLine (this=0x0, viewLine=-1) at ../../kate/render/katelinelayout.cpp:179
#8  0x017e81c4 in KateLayoutCache::textLayout (this=0x95e90f0, realLine=361, _viewLine=-1) at ../../kate/render/katelayoutcache.cpp:346
#9  0x0183d610 in KateViewInternal::previousLayout (this=0x9507338) at ../../kate/view/kateviewinternal.cpp:1282
#10 0x01847261 in KateViewInternal::cursorUp (this=0x9507338, sel=false) at ../../kate/view/kateviewinternal.cpp:1462
#11 0x0182233b in KateView::up (this=0x95e5a68) at ../../kate/view/kateview.cpp:2583
#12 0x0182d218 in KateView::qt_metacall (this=0x95e5a68, _c=QMetaObject::InvokeMetaMethod, _id=67, _a=0xbf89ba58) at ./kateview.moc:371
#13 0x00265263 in QMetaObject::activate (sender=0x966f998, from_signal_index=5, to_signal_index=6, argv=0xbf89ba58) at kernel/qobject.cpp:3113
#14 0x002656d8 in QMetaObject::activate (sender=0x966f998, m=0x6254e48, from_local_signal_index=1, to_local_signal_index=2, argv=0xbf89ba58) at kernel/qobject.cpp:3207
#15 0x059ec9b1 in QAction::triggered (this=0x966f998, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#16 0x059edf32 in QAction::activate (this=0x966f998, event=QAction::Trigger) at kernel/qaction.cpp:1160
#17 0x059f0a18 in QAction::event (this=0xbf89b87c, e=0x0) at kernel/qaction.cpp:1079
#18 0x00ecaeb3 in KAction::event (this=0x966f998, event=0xbf89bea8) at ../../kdeui/actions/kaction.cpp:88
#19 0x059f2f54 in QApplicationPrivate::notify_helper (this=0x8f78328, receiver=0x966f998, e=0xbf89bea8) at kernel/qapplication.cpp:4056
#20 0x059fa67c in QApplication::notify (this=0xbf89ddfc, receiver=0x966f998, e=0xbf89bea8) at kernel/qapplication.cpp:3603
#21 0x00fb1bfa in KApplication::notify (this=0xbf89ddfc, receiver=0x966f998, event=0xbf89bea8) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x0024f6cb in QCoreApplication::notifyInternal (this=0xbf89ddfc, receiver=0x966f998, event=0xbf89bea8) at kernel/qcoreapplication.cpp:610
#23 0x05a2bdfd in QCoreApplication::sendEvent (this=0x8f783c8, e=0xbf89c254) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QShortcutMap::dispatchEvent (this=0x8f783c8, e=0xbf89c254) at kernel/qshortcutmap.cpp:884
#25 0x05a2dc7e in QShortcutMap::tryShortcutEvent (this=0x8f783c8, o=0x9507338, e=0xbf89c254) at kernel/qshortcutmap.cpp:369
#26 0x059fba0d in QApplication::notify (this=0xbf89ddfc, receiver=0x9507338, e=0xbf89c254) at kernel/qapplication.cpp:3645
#27 0x00fb1bfa in KApplication::notify (this=0xbf89ddfc, receiver=0x9507338, event=0xbf89c254) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x0024f6cb in QCoreApplication::notifyInternal (this=0xbf89ddfc, receiver=0x9507338, event=0xbf89c254) at kernel/qcoreapplication.cpp:610
#29 0x059f3e2e in QCoreApplication::sendSpontaneousEvent (receiver=0x9507338, event=0xbf89b87c) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#30 qt_sendSpontaneousEvent (receiver=0x9507338, event=0xbf89b87c) at kernel/qapplication.cpp:4958
#31 0x05a90440 in QKeyMapper::sendKeyEvent (keyWidget=0x9507338, grab=false, type=QEvent::KeyPress, code=16777235, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=111, nativeVirtualKey=65362, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#32 0x05a92989 in QKeyMapperPrivate::translateKeyEvent (this=0x8f9fd98, keyWidget=0x9507338, event=0xbf89da3c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#33 0x05a66ed7 in QApplication::x11ProcessEvent (this=0xbf89ddfc, event=0xbf89da3c) at kernel/qapplication_x11.cpp:3443
#34 0x05a94502 in x11EventSourceDispatch (s=0x8f7b300, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x0574be78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x0574f720 in ?? () from /lib/libglib-2.0.so.0
#37 0x0574f853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x0027a02c in QEventDispatcherGlib::processEvents (this=0x8efaa58, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#39 0x05a93be5 in QGuiEventDispatcherGlib::processEvents (this=0x8efaa58, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#40 0x0024dc79 in QEventLoop::processEvents (this=0xbf89dd34, flags=) at kernel/qeventloop.cpp:149
#41 0x0024e0ca in QEventLoop::exec (this=0xbf89dd34, flags=...) at kernel/qeventloop.cpp:201
#42 0x0025053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#43 0x059f2dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#44 0x014dbb0d in kdemain () from /usr/lib/libkdeinit4_kate.so
#45 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x8f3f7a8 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x80511a5 "0") at ../../kinit/kinit.cpp:677
#46 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#47 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#48 0x0804fbaf in main (argc=2, argv=0xbf89ea14, envp=0xbf89ea20) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 200858

Reported using DrKonqi
Comment 1 Dominik Haumann 2009-11-05 23:05:12 UTC
this = 0x0.
Should be fixable by someone who knows what's supposed to happen ;)
Comment 2 Dominik Haumann 2009-11-05 23:20:39 UTC
yes, duplicate.

*** This bug has been marked as a duplicate of bug 200858 ***