Bug 232554 - Auto-Hide panel does not show on other monitor, when an application is in fullscreen mode
Summary: Auto-Hide panel does not show on other monitor, when an application is in ful...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Unclassified
Component: containment-panel (show other bugs)
Version: 4.8.3
Platform: Ubuntu Packages Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 211931 257712 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-29 10:39 UTC by Andreas Blochberger
Modified: 2018-06-08 19:36 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Blochberger 2010-03-29 10:39:24 UTC
Version:            (using KDE 4.4.1)
Installed from:    Ubuntu Packages

In a twinview configuration, When i run an application in fullscreen mode (krdc or gwenview) on monitor 1, autohide panels on monitor 2 do not show when moving the mouse over them.
Seems like the fullscreen mode does not realize, that there are two monitors, and that it is not necessary to block panels from the other monitor.
Comment 1 Andreas Blochberger 2010-03-29 10:46:09 UTC
In the display settings, support for fullscreen on multiple monitors has to be activated, otherwise fullscreen spans across the two monitors
Comment 2 Martin Flöser 2010-03-29 13:24:02 UTC
So after activating that feature the autohiding works? If yes I don't see a bug :-)
Comment 3 Andreas Blochberger 2010-03-29 15:19:56 UTC
No. Interstingly, playing around a bit with the application (krdc in this case), minimizing it, and other things, that i can't reproduce anymore, it suddenly worked. I had the fullscreen krdc on my left monitor, and the autohide panel appeared on the right monitor on the top edge, when moving the mouse to the top edge of the right monitor.
Minimizing and restoring the fullscreen krdc again, and now the autohide panel on my right monitor does not show when i move my mouse to the top edge of the screen.
krdc seems to have some other bugs too, because even if i click in the window, not all keyboard requests go the the remote computer (pressing Ctrl-F12 brings up the widget desktop, rather than the file list of the BDE ;-)
But i noticed, that this is dependant on the position of my mouse cursor, when its on the right monitor, krdc seems to lose focus for some keys in some way. But this may not be related to this auto-hide bug.
Comment 4 Andreas Blochberger 2010-04-08 14:38:39 UTC
I've found a workaround. Problem obviously is, that the fullscreen application captures the mouse somehow and avoids displaying panels on *all* monitors, not just the one that it occupies.
The workaround is clicking somewhere in the other monitor, then the auto-hide panels on this monitor can be made visible again :D

But it's still a bug, because windows in fullscreen mode should only capture the mouse on the monitor they sit in.
Comment 5 Martin Flöser 2011-01-22 00:01:14 UTC
I just added an auto-hide panel and can reproduce. Plasma is responsible for the auto-hide panel, so I reassign. As lately there have been some fixes to auto-hide panels it might be fixed alreade (svn rev 1213515 here).
Comment 6 Karsten König 2011-02-11 15:57:18 UTC
http://websvn.kde.org/?view=revision&revision=1213515 is an unrelated change, it'd be nice to know the exact git commit or svn revision to see weather it is in 4.6 branch and if not can be quickly added to the opensuse packages to test it.

On 4.6.0 the bug is still present.
Comment 7 Urs Wolfer 2011-02-11 18:52:37 UTC
*** Bug 211931 has been marked as a duplicate of this bug. ***
Comment 8 Urs Wolfer 2011-02-11 18:52:51 UTC
*** Bug 257712 has been marked as a duplicate of this bug. ***
Comment 9 Thijs 2012-05-31 07:15:27 UTC
Still present in 4.8.3
Comment 10 Nate Graham 2018-06-08 19:36:03 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham