Bug 232275 - Dolphin crash with multiple file select and click on background
Summary: Dolphin crash with multiple file select and click on background
Status: RESOLVED DUPLICATE of bug 222324
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-26 21:43 UTC by David Merriman
Modified: 2010-03-26 22:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Merriman 2010-03-26 21:43:48 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.9-70.fc12.i686 i686
Distribution: "Fedora release 12 (Constantine)"

-- Information about the crash:
Was copying files from directory to MP3 player using two instances of Dolphin. When clicking on background of file listing with multiple files selected, Dolphin experienced total crash (disappeared completely).

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771a7a0 (LWP 13527))]

Thread 3 (Thread 0xb5dd9b70 (LWP 13551)):
#0  0x006bd416 in __kernel_vsyscall ()
#1  0x005fcf72 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S:179
#2  0x012306b5 in ?? () from /usr/lib/libxine.so.1
#3  0x005f8ab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00523dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb0df8b70 (LWP 13953)):
[KCrash Handler]
#6  QMutex::lock (this=0x50) at thread/qmutex.cpp:150
#7  0x0232c7df in QThreadPrivate::finish (arg=0xa8ed440) at thread/qthread_unix.cpp:270
#8  0x0232cce7 in ~__pthread_cleanup_class (arg=0xa8ed440) at /usr/include/pthread.h:535
#9  QThreadPrivate::start (arg=0xa8ed440) at thread/qthread_unix.cpp:253
#10 0x005f8ab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#11 0x00523dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb771a7a0 (LWP 13527)):
#0  0x006bd416 in __kernel_vsyscall ()
#1  0x005193d6 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x008960c0 in ?? () from /usr/lib/libxcb.so.1
#3  0x0089662b in ?? () from /usr/lib/libxcb.so.1
#4  0x008969c8 in xcb_writev () from /usr/lib/libxcb.so.1
#5  0x00797d59 in _XSend (dpy=<value optimized out>, data=<value optimized out>, size=<value optimized out>) at xcb_io.c:332
#6  0x00789160 in _XSetClipRectangles (dpy=<value optimized out>, gc=<value optimized out>, clip_x_origin=<value optimized out>, clip_y_origin=<value optimized out>, 
    rectangles=<value optimized out>, n=<value optimized out>, ordering=<value optimized out>) at SetCRects.c:56
#7  0x00789318 in XSetClipRectangles (dpy=<value optimized out>, gc=<value optimized out>, clip_x_origin=<value optimized out>, clip_y_origin=<value optimized out>, rectangles=<value optimized out>, 
    n=<value optimized out>, ordering=<value optimized out>) at SetCRects.c:77
#8  0x037f7f2d in x11SetClipRegion (this=0xa2f7340, clipRegion=..., op=ReplaceClip) at painting/qpaintengine_x11.cpp:166
#9  QX11PaintEngine::updateClipRegion_dev (this=0xa2f7340, clipRegion=..., op=ReplaceClip) at painting/qpaintengine_x11.cpp:2078
#10 0x037fd5d1 in QX11PaintEngine::updateState (this=0xa2f7340, state=...) at painting/qpaintengine_x11.cpp:1087
#11 0x037421e5 in QPainterPrivate::updateStateImpl (this=0xa8f6b50, newState=0xa735098) at painting/qpainter.cpp:892
#12 0x037422ad in QPainterPrivate::updateState (this=0xa8f6b50, newState=0xa735098) at painting/qpainter.cpp:920
#13 0x037480b0 in QPainter::setClipRegion (this=0xbf88b190, r=..., op=ReplaceClip) at painting/qpainter.cpp:2825
#14 0x006cc92a in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#15 0x00703840 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#16 0x00710c19 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#17 0x02421e3a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9f38170, receiver=0xa015b00, event=0xbf88b684) at kernel/qcoreapplication.cpp:819
#18 0x035f1d0a in QApplicationPrivate::notify_helper (this=0x9f38170, receiver=0xa015b00, e=0xbf88b684) at kernel/qapplication.cpp:4296
#19 0x035f85f1 in QApplication::notify (this=0xbf88c414, receiver=0xa015b00, e=0xbf88b684) at kernel/qapplication.cpp:4265
#20 0x0723b7db in KApplication::notify (this=0xbf88c414, receiver=0xa015b00, event=0xbf88b684) at /usr/src/debug/kdelibs-4.4.1/kdeui/kernel/kapplication.cpp:302
#21 0x02422c03 in QCoreApplication::notifyInternal (this=0xbf88c414, receiver=0xa015b00, event=0xbf88b684) at kernel/qcoreapplication.cpp:704
#22 0x0364d327 in sendSpontaneousEvent (this=0xa01a720, pdev=0xa22bf24, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0xa22bc20) at ../../src/corelib/kernel/qcoreapplication.h:218
#23 QWidgetPrivate::drawWidget (this=0xa01a720, pdev=0xa22bf24, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0xa22bc20) at kernel/qwidget.cpp:5339
#24 0x0380c1c5 in QWidgetBackingStore::sync (this=0xa22bc20) at painting/qbackingstore.cpp:1291
#25 0x0363e3b3 in QWidgetPrivate::syncBackingStore (this=0xa01a720) at kernel/qwidget.cpp:1672
#26 0x036451ae in QWidget::event (this=0xa015b00, event=0xa6c9b10) at kernel/qwidget.cpp:8291
#27 0x03a2fad7 in QMainWindow::event (this=0xa015b00, event=0xa6c9b10) at widgets/qmainwindow.cpp:1433
#28 0x0731a554 in KMainWindow::event (this=0xa015b00, ev=0xa6c9b10) at /usr/src/debug/kdelibs-4.4.1/kdeui/widgets/kmainwindow.cpp:1103
#29 0x0735b7a0 in KXmlGuiWindow::event (this=0xa015b00, ev=0xa6c9b10) at /usr/src/debug/kdelibs-4.4.1/kdeui/xmlgui/kxmlguiwindow.cpp:131
#30 0x035f1d2c in QApplicationPrivate::notify_helper (this=0x9f38170, receiver=0xa015b00, e=0xa6c9b10) at kernel/qapplication.cpp:4300
#31 0x035f85f1 in QApplication::notify (this=0xbf88c414, receiver=0xa015b00, e=0xa6c9b10) at kernel/qapplication.cpp:4265
#32 0x0723b7db in KApplication::notify (this=0xbf88c414, receiver=0xa015b00, event=0xa6c9b10) at /usr/src/debug/kdelibs-4.4.1/kdeui/kernel/kapplication.cpp:302
#33 0x02422c03 in QCoreApplication::notifyInternal (this=0xbf88c414, receiver=0xa015b00, event=0xa6c9b10) at kernel/qcoreapplication.cpp:704
#34 0x02423ac3 in sendEvent (receiver=0x0, event_type=0, data=0x9f19858) at kernel/qcoreapplication.h:215
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9f19858) at kernel/qcoreapplication.cpp:1345
#36 0x02423c1e in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#37 0x0244b350 in sendPostedEvents (s=0x9f43510) at kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=0x9f43510) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00146fb8 in g_main_dispatch (context=0x9f43490) at gmain.c:1960
#40 IA__g_main_context_dispatch (context=0x9f43490) at gmain.c:2513
#41 0x0014a8e8 in g_main_context_iterate (context=0x5fbeb0, block=1, dispatch=1, self=0x9f40180) at gmain.c:2591
#42 0x0014aa14 in IA__g_main_context_iteration (context=0x9f43490, may_block=1) at gmain.c:2654
#43 0x0244ae46 in QEventDispatcherGlib::processEvents (this=0x9f19330, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#44 0x036a00e6 in QGuiEventDispatcherGlib::processEvents (this=0x9f19330, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x024212da in QEventLoop::processEvents (this=0xbf88c374, flags=...) at kernel/qeventloop.cpp:149
#46 0x0242161a in QEventLoop::exec (this=0xbf88c374, flags=...) at kernel/qeventloop.cpp:201
#47 0x02423ce7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#48 0x035f1dd8 in QApplication::exec () at kernel/qapplication.cpp:3579
#49 0x080780e7 in main (argc=5, argv=0xbf88c5f4) at /usr/src/debug/kdebase-4.4.1/apps/dolphin/src/main.cpp:101

Possible duplicates by query: bug 231242, bug 231184, bug 230517, bug 230394, bug 229973.

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-26 22:24:00 UTC
Fixed for KDE SC 4.4.2.
Regards

*** This bug has been marked as a duplicate of bug 222324 ***