Bug 229973 - Dolphin crashed while in columns view and in dropbox folder
Summary: Dolphin crashed while in columns view and in dropbox folder
Status: RESOLVED DUPLICATE of bug 222324
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-08 18:34 UTC by Andrei Sebastian Cimpean
Modified: 2010-03-10 12:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Sebastian Cimpean 2010-03-08 18:34:58 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
I was looking through some files and when i moved to another column dolphin crashed. This seems to be the problem. I was uploading files to dropbox in this period.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d6760 (LWP 3257))]

Thread 2 (Thread 0xb5768b70 (LWP 4951)):
[KCrash Handler]
#6  QMutex::lock (this=0x53) at thread/qmutex.cpp:150
#7  0x01e92e8e in QThreadPrivate::finish (arg=0xa70bdb0) at thread/qthread_unix.cpp:270
#8  0x01e93376 in ~__pthread_cleanup_class (arg=0xa70bdb0) at /usr/include/pthread.h:535
#9  QThreadPrivate::start (arg=0xa70bdb0) at thread/qthread_unix.cpp:253
#10 0x0065980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#11 0x0077b8de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77d6760 (LWP 3257)):
#0  0x0062d422 in __kernel_vsyscall ()
#1  0x0076dc96 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x00f16d80 in ?? () from /usr/lib/libxcb.so.1
#3  0x00f189d2 in xcb_wait_for_reply () from /usr/lib/libxcb.so.1
#4  0x00535506 in _XReply () from /usr/lib/libX11.so.6
#5  0x005291a7 in XSync () from /usr/lib/libX11.so.6
#6  0x01582bec in QClipboardWatcher::getDataInFormat (this=0xa568a40, fmtatom=237) at kernel/qclipboard_x11.cpp:1281
#7  0x015830cf in QClipboardWatcher::formats_sys (this=0xa568a40) at kernel/qclipboard_x11.cpp:1211
#8  0x01502866 in QInternalMimeData::formats (this=0xa568a40) at kernel/qdnd.cpp:559
#9  0x01582e01 in QClipboardWatcher::retrieveData_sys (this=0xa568a40, fmt=..., requestedType=QVariant::ByteArray) at kernel/qclipboard_x11.cpp:1247
#10 0x01502047 in QInternalMimeData::retrieveData (this=0xa568a40, mimeType=..., type=QVariant::ByteArray) at kernel/qdnd.cpp:574
#11 0x01fa2b5a in QMimeDataPrivate::retrieveTypedData (this=0xa6a2528, format=..., type=QVariant::ByteArray) at kernel/qmimedata.cpp:107
#12 0x01fa3491 in QMimeData::data (this=0xa568a40, mimeType=...) at kernel/qmimedata.cpp:524
#13 0x002c6804 in KFilePreviewGenerator::Private::decodeIsCutSelection (this=0xa3476a8, mimeData=0xa568a40) at ../../kfile/kfilepreviewgenerator.cpp:1061
#14 0x002c704d in KFilePreviewGenerator::Private::applyCutItemEffect (this=0xa3476a8, items=...) at ../../kfile/kfilepreviewgenerator.cpp:839
#15 0x002c94f6 in KFilePreviewGenerator::Private::updateIcons (this=0xa3476a8, items=...) at ../../kfile/kfilepreviewgenerator.cpp:512
#16 0x002c9e03 in KFilePreviewGenerator::updateIcons (this=0xa2e6390) at ../../kfile/kfilepreviewgenerator.cpp:1190
#17 0x002c9e79 in KFilePreviewGenerator::cancelPreviews (this=0xa2e6390) at ../../kfile/kfilepreviewgenerator.cpp:1198
#18 0x00a3c6be in ?? () from /usr/lib/libdolphinprivate.so.4
#19 0x01f9ae5a in QMetaObject::metacall (object=0xa346998, cl=QMetaObject::ReadProperty, idx=0, argv=0xa346998) at kernel/qmetaobject.cpp:237
#20 0x01fa95f5 in QMetaObject::activate (sender=0xa2d48b0, m=0xa57e68, local_signal_index=16, argv=0x0) at kernel/qobject.cpp:3293
#21 0x00a00607 in DolphinController::cancelPreviews() () from /usr/lib/libdolphinprivate.so.4
#22 0x00a019dd in DolphinController::setUrl(KUrl const&) () from /usr/lib/libdolphinprivate.so.4
#23 0x00a0c372 in ?? () from /usr/lib/libdolphinprivate.so.4
#24 0x00a0ca9b in ?? () from /usr/lib/libdolphinprivate.so.4
#25 0x01f9ae5a in QMetaObject::metacall (object=0xa2d5c30, cl=QMetaObject::ReadProperty, idx=170739888, argv=0xbfc2ca28) at kernel/qmetaobject.cpp:237
#26 0x01fa95f5 in QMetaObject::activate (sender=0xa2e7710, m=0x20aa5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#27 0x01ffac97 in QTimer::timeout (this=0xa2e7710) at .moc/release-shared/moc_qtimer.cpp:134
#28 0x01fb179e in QTimer::timerEvent (this=0xa2e7710, e=0xbfc2d060) at kernel/qtimer.cpp:271
#29 0x01fa6494 in QObject::event (this=0xa2e7710, e=0xffffffff) at kernel/qobject.cpp:1212
#30 0x014e73cc in QApplicationPrivate::notify_helper (this=0xa0f4180, receiver=0xa2e7710, e=0xbfc2d060) at kernel/qapplication.cpp:4300
#31 0x014ee01e in QApplication::notify (this=0xbfc2d3c4, receiver=0xa2e7710, e=0xbfc2d060) at kernel/qapplication.cpp:3704
#32 0x011da42a in KApplication::notify (this=0xbfc2d3c4, receiver=0xa2e7710, event=0xbfc2d060) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x01f95beb in QCoreApplication::notifyInternal (this=0xbfc2d3c4, receiver=0xa2e7710, event=0xbfc2d060) at kernel/qcoreapplication.cpp:704
#34 0x01fc4eb6 in QCoreApplication::sendEvent (this=0xa0f31a4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0xa0f31a4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x01fc1b14 in timerSourceDispatch (source=0xa0f3170) at kernel/qeventdispatcher_glib.cpp:184
#37 0x08695e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#38 0x08699730 in ?? () from /lib/libglib-2.0.so.0
#39 0x08699863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#40 0x01fc1805 in QEventDispatcherGlib::processEvents (this=0xa0d0b30, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#41 0x015a6b35 in QGuiEventDispatcherGlib::processEvents (this=0xa0d0b30, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x01f94209 in QEventLoop::processEvents (this=0xbfc2d324, flags=) at kernel/qeventloop.cpp:149
#43 0x01f9465a in QEventLoop::exec (this=0xbfc2d324, flags=...) at kernel/qeventloop.cpp:201
#44 0x01f9884f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#45 0x014e7467 in QApplication::exec () at kernel/qapplication.cpp:3579
#46 0x0807b84f in _start ()

Possible duplicates by query: bug 229270, bug 229075, bug 228964, bug 228567, bug 227932.

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-10 12:56:54 UTC
Fixed for KDE SC 4.4.2: bug 222324. Regards

*** This bug has been marked as a duplicate of bug 222324 ***