Bug 231858 - Show in media sources resets the Local Music sorting scheme.
Summary: Show in media sources resets the Local Music sorting scheme.
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Collection Browser (show other bugs)
Version: 2.4-GIT
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 235479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-23 01:52 UTC by Karthik Periagaram
Modified: 2012-02-18 19:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karthik Periagaram 2010-03-23 01:52:26 UTC
Version:           2.3.0 (using KDE 4.4.1)
OS:                Linux
Installed from:    Archlinux Packages

The latest version allows one to right click the playlist and select "Show in Media Sources". This runs a search on the collection browser and shows the song.

Unfortunately, when the search term is cleared using the 'x' in the lineEdit, the sorting is reset to Artist/Album. I use the Genre/Artist/Album sorting and it doesn't return to that.

This may be related to the cause of the bug, but I believe there used to be a check mark against the currently used sorting order in the sort menu. That check mark doesn't appear anymore in 2.3.0.

If you need more info, just ask!
Comment 1 Myriam Schweingruber 2010-08-14 18:56:05 UTC
*** Bug 235479 has been marked as a duplicate of this bug. ***
Comment 2 Myriam Schweingruber 2010-08-14 18:57:53 UTC
Confirmed by duplicate.
Comment 3 Samuel Brack 2010-12-08 15:04:28 UTC
This bug is confirmed in 2.4-GIT
Comment 4 Sam Lade 2012-02-18 19:59:48 UTC
Git commit 79458f1fbb2c5026076df5335ee49d6a5e8ba2da by Sam Lade.
Committed on 18/02/2012 at 20:56.
Pushed by lade into branch 'master'.

Fix show in media sources buttons resetting collection sorting

Patch by Ravi Arora
FIXED-IN:2.6
REVIEW:104018

M  +1    -0    ChangeLog
M  +0    -1    src/core-impl/collections/db/sql/CapabilityDelegateImpl.cpp

http://commits.kde.org/amarok/79458f1fbb2c5026076df5335ee49d6a5e8ba2da